Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Skype on 11.3: error loading libXV.so.1

  1. #1
    Join Date
    Aug 2010
    Posts
    11

    Default Skype on 11.3: error loading libXV.so.1

    I downloaded the latest Skype beta from Skype's site and installed it. When I click on the icon, nothing happens, so I tried from an xterm and I get the error:

    skype: error while loading shared libraries: libXv.so.1: cannot open shared object file: No such file or directory.

    I looked up libXv in the software manager, and it looks to be installed.

    What do I need to do to get Skype running?

    BTW, two question:

    Is it standard in case of errors that running from the UI simply does nothing, and there's need to run from a terminal window to see them?

    How do I copy text from xterm (in order to paste in a post like this)?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype on 11.3: error loading libXV.so.1

    If you are running 64-bit openSUSE, install xorg-x11-libXv-32bit. Skype is a 32-bit program.

  3. #3
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    45

    Default Re: Skype on 11.3: error loading libXV.so.1

    Quote Originally Posted by ken_yap View Post
    If you are running 64-bit openSUSE, install xorg-x11-libXv-32bit. Skype is a 32-bit program.
    I found this x86_64 Skype installed and runs beautifully:

    obs://build.opensuse.org/home:broumbroum23

    To install from that site, open YAST, choose Software Repositories and click the radio button for Community. You will be able to scroll down lots of apps that have been packaged by the community, including Skype x86_64.

    (The 32 bit Skype will ask you for libpng12-0-1.2.44-2.1.i586.rpm as well and it gets overwritten by the 64 bit libpng when you install other apps, like Virtual Box. It also requires loads of 32 bit libraries to be installed).

    Hope this helps.

  4. #4
    Join Date
    Aug 2010
    Posts
    11

    Default Re: Skype on 11.3: error loading libXV.so.1

    I ended up installing the required libraries before I read this, and Skype is working. I've already have VirtualBox installed, and it seems to continue working, so everything is fine currently. But I'll keep your advice in mind in case something goes wrong in the future. Thanks!

  5. #5
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    45

    Default x86_64 Skype from Community repo crashes on conference call

    Quote Originally Posted by jenspen View Post
    A while back I wrote:

    I found this x86_64 Skype installed and runs beautifully:

    obs://build.opensuse.org/home:broumbroum23

    [snip]

    Hope this helps.
    Huh. Since I wrote that I tried a conference call with obs://build.opensuse.org/home:broumbroum23 Skype. Whether I was being invited to join a chat or inviting others to join I found that Skype crashed.

    Is there any other 64 bit Skype that is known to work?

    Thanks.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Skype on 11.3: error loading libXV.so.1

    jenspen wrote:

    >
    > Is there any other 64 bit Skype that is known to work?
    >
    > Thanks.
    >

    In fact there is no real thing like a 64 bit skype (even if the package is
    named so).
    I cannot guarantee that what you want to do (is it video conference?) will
    work with what I use, I do conference only with audio.

    http://www.skype.com/go/getskype-linux-beta-static

    That works for me on 64 bit opensuse 11.3. I installed it simply in my home
    folder (installation = unpack it) and made a symlink in ~/bin to the skype
    executable.
    So if it does not work for you it is almost trivial to remove it.




  7. #7
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    45

    Default Re: Skype on 11.3: error loading libXV.so.1

    Quote Originally Posted by martin_helm View Post
    jenspen wrote:
    [color=blue]
    >
    In fact there is no real thing like a 64 bit skype (even if the package is
    named so).
    I cannot guarantee that what you want to do (is it video conference?) will
    work with what I use, I do conference only with audio.

    http://www.skype.com/go/getskype-linux-beta-static

    That works for me on 64 bit opensuse 11.3. I installed it simply in my home
    folder (installation = unpack it) and made a symlink in ~/bin to the skype
    executable.
    So if it does not work for you it is almost trivial to remove it.
    Thanks. I'll give that a go. It was audio conferencing I was thinking of.

  8. #8
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: Skype on 11.3: error loading libXV.so.1

    Quote Originally Posted by ET3D View Post
    I ended up installing the required libraries before I read this, and Skype is working. I've already have VirtualBox installed, and it seems to continue working, so everything is fine currently. But I'll keep your advice in mind in case something goes wrong in the future. Thanks!
    What are the required libaries?

    I see a link for a rancom repositoy but I don't trust it just because it's "community."
    Tumbleweed

  9. #9
    Join Date
    May 2010
    Location
    Thessaloniki
    Posts
    454

    Default Re: Skype on 11.3: error loading libXV.so.1

    I try to install Skype to friend's PC. He has gnome 64bit.

    He installed it but he doesn't have an icon in his Application menu.

    He gets the following message:

    skype: error while loading shared libraries: libXv.so.1: cannot open shared object file: No such file or directory
    And when he tries to install it with the command:

    zypper in libXv.so.1
    He gets the result:

    Loading repository data...
    Reading installed packages...
    'libXv.so.1' not found in package names. Trying capabilities.
    'xorg-x11-libXv' providing 'libXv.so.1' is already installed.
    Resolving package dependencies...

    Nothing to do.
    Does anybody knows what to do?

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype on 11.3: error loading libXV.so.1

    Try installing xorg-x11-libXv-32bit

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •