Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: more command - Highlights text

  1. #1
    Join Date
    May 2010
    Location
    East Bay, CA
    Posts
    32

    Default more command - Highlights text

    Hello All,

    I am pretty new to Suse Linux, coming from Sun Solaris. I have an issue with the "more" command. It highlights all the lines beyond the first terminal appearance; anyway I can kill this highlighting?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: more command - Highlights text

    Why not use the less command? it's more modern.

  3. #3
    Carlos E. R. NNTP User

    Default Re: more command - Highlights text

    On 2010-08-04 00:36, missingunix wrote:
    >
    > Hello All,
    >
    > I am pretty new to Suse Linux, coming from Sun Solaris. I have an
    > issue with the "more" command. It highlights all the lines beyond the
    > first terminal appearance; anyway I can kill this highlighting?


    I don't see that behaviour here. What command line do you use and on which terminal and desktop?
    Perhaps a screenshot uploaded somewhere?


    Although I prefer less to more, which is really more than more >:-)

    Did you understood my meaning? Then there is also a dog :-p

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Elessar))

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: more command - Highlights text

    Carlos E. R. wrote:
    > Although I prefer less to more, which is really more than more >:-)


    i also vote for less and have never seen the highlighting noted with
    more (but don't use it much)..

    man more | grep -i high
    returns zip..

    you might _try_ launching more with the -u switch (suppress
    underlining)....or, once launched try a ^L to redraw the screen..

    beyond that i have to *guess* some kind of graphic problem and guess
    we might need to know the OS, version, state of update, DE used (if
    any), graphics chip/driver in use and what?

    bash or other?

    GUI terminal, or boot to run level 3 command line, Ctrl+Alt+F1, or what?

    oh, and if using bash have you 'customized' /etc/bash.bashrc or
    /home/[you]/.bashrc, or added a /etc/bash.bashrc.local ?? if so can
    you back level and try again?

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,864

    Default Re: more command - Highlights text

    I use more rather often (after typing | more for more then 20 years it is not easy to change to less ), but I never experienced what I think you post.
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: more command - Highlights text

    Easy, just do

    alias more='less'

    and more is less, or should that be less is more? Or more or less?

    But I suspect some terminfo issues with the OP. Without knowing more about his environment, can't really say.

  7. #7
    Join Date
    May 2010
    Location
    East Bay, CA
    Posts
    32

    Default Re: more command - Highlights text

    Hello Gentleman/Ladies,

    Thank you for the replies, I now use less as all of you have stated; much better than more.

    But, I am still having the highlighting issue. On the man page for less it only states how to remove highlighting for search strings; but, I am getting highlighting on every line after my first forward move.


    Here is the info on my system:
    uname -a ---> Linux hostname* 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 Time* x86_64 x86_64 x86_64 GNU/Linux

    echo $TERM--> xterm (this I am assuming because I am remotely logging into the Linux box from a Solaris Box)

    Currently using standard .vimrc and DIR_COLORS


    Thanks in advance!!!

  8. #8
    Join Date
    May 2010
    Location
    East Bay, CA
    Posts
    32

    Default Re: more command - Highlights text

    Ken, I agree with yourself. It most likely is a term issues on Solaris box; but, not sure what it could be.

    When I login from my windows machine into my Linux box using Cygwin, I have no such highlighting issues.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: more command - Highlights text

    missingunix wrote:
    > When I login from my windows machine into my Linux box using Cygwin, I
    > have no such highlighting issues.


    i bet you need to ask a Solaris Guru..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  10. #10
    Join Date
    May 2010
    Location
    East Bay, CA
    Posts
    32

    Default Re: more command - Highlights text

    Hi Denver,

    I would assume it would be some kind of terminal issue that I am overlooking; as Ken stated? I have no such issue when I am logging from Solaris --> Solaris. Hence, pointing to some kind of environment setting on my Linux box?

    I use the bash shell, and from my understanding these are the only files that get sourced during login:
    $HOME/.bashrc
    /etc/bash.bashrc


    Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •