Results 1 to 6 of 6

Thread: Suspend doesn't work when screensaver is active

  1. #1

    Default Suspend doesn't work when screensaver is active

    Hi,

    got a suspend problem with OpenSuse 11.3.
    I configured the powersave module that whenever I close down the screen of my laptop it suspends to ram. Works fine so far except when the screensaver is active.
    It just stays on when I close down the lid.

    Any suggestions?

    Thanks in advance.

    Regards
    Michael

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Suspend doesn't work when screensaver is active

    I really don't know but to help trouble shoot..... Do you have the screen save set to require a password? The only thing I can think of the might block the event.

  3. #3

    Default Re: Suspend doesn't work when screensaver is active

    Quote Originally Posted by gogalthorp View Post
    I really don't know but to help trouble shoot..... Do you have the screen save set to require a password? The only thing I can think of the might block the event.
    Nope, no password required. If I move the mouse the screensaver gets disabled and suspend works again.

    Do you have a link with some info on how to trace the events? Didn't find any useful info about the powersave infrastructure in OpenSuse11.3 and have the feeling that's an area that got changed a lot over the last couple of versions.

    Thanks again.
    Michael

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Suspend doesn't work when screensaver is active

    This very well may be a bug. Anyone else with a notebook seeing this??? Also may help to know about the exact hardware. ie brand model.

  5. #5

    Default Re: Suspend doesn't work when screensaver is active

    It's an Acer Extensa 5220, which hasn't had any problems so far (except that the Render Extension crashes the X Server but that's stuff I don't care about at the moment, just disabled it)

    The weird thing is that suspend works really fine when the screensaver isn't active but the whole thing fails if it is (doesn't make a difference if it's a fancy OpenGL one or just a blank screen)

    Regards
    Michael

  6. #6

    Default Re: Suspend doesn't work when screensaver is active

    it's a bug indeed, and a long known one:
    Bug 205453 - Closing laptop lid not working when screensaver is active

    It's been fixed for OpenSuse 11.2 but not for 11.3

    Regards
    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •