Results 1 to 7 of 7

Thread: Oxygen icons in OpenOffice

  1. #1
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Oxygen icons in OpenOffice

    I'am using OpenOffice 3.2.1 and Opensuse 11.3 with KDE 4.4.4.. When I use the KDE4 integration and the oxygen icon set, I'am getting a mixture of oxygen (KDE4) icons and crystal (KDE3) icons in the symbol panel (I hope this is the correct word in english). E.g. the icons for "bold", "italic" or underlined are crystal icons instead of oxygen. I had the same "problem" with Opensuee 11.2 and older OpenOffice versions.
    Interestingly, when I start OpenOffice in my root account, OpenOffice shows all icons correctly as oxygen icons. When creating a new user account (a test account), OpenOffice use the icon mixture. Also transfering the ".oo3" folder of root to my user account didn't solve the "problem".
    Of course, this is not a real problem with OpenOffice, it's more a desing error (but I like to solve it ).
    Who else has a mixture of oxygen and crystal icons?

    Best wishes

    Michael

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Oxygen icons in OpenOffice

    So I do not seem to be having this problem. I am using OpenOffice 3.2.1 and OpenSUSE11.3 (64 bit) with KDE 4.4.4. (release 4). When you say "KDE4 integration" which file are we talking about? I have the OpenOffice to openSUSE branding file installed, but not sure if this is the one you are talking about. In any case as I switch between the various icon sets, the "B U I" icons change with each icon set I select and appear to be correct. Could you post an image for us to look at by chance?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: Oxygen icons in OpenOffice

    Hi,

    thanks for the answer.
    I can't attach a desktop screenshot of OpenOffice, because I have to find a server where I can place my screenshot file and create a link (it would be a great improvement for this forum, if it would be possible to attach screenshoots to a comment) or I'am to stupid for it .
    The Opensuse branding is installed. With KDE4 integration I mean "OpenOffice_org-KDE4" (When I'am working with OpenOffice, I have to deinstall the Integration, see also: https://bugzilla.novell.com/show_bug.cgi?id=616047).
    I'am using the 32 bit version of OpenSuse and Release 2 of KDE4.4.4..
    I can also switch the icon sets, e.g. when switching to Galaxy, the "B I U" icons are in the Galaxy style, but it's not working for Oxygen, here the icons appear in the old Crystal style. I have the same issue on the notebook of my girlfriend (but with Opensuse 11.2). Perhaps it's an issue of using 32bit or 64bit.

    Best wishes

    Michael

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,657

    Default Re: Oxygen icons in OpenOffice

    Try creating a new user. If it works right for it then the problem is in the KDE configurations ( ~/.kde4 ) somewhere. Don't ask me where.

  5. #5
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: Oxygen icons in OpenOffice

    Hi gogalthorp,

    I tried it. Also when created a new user, I got the Crystal icons instead of the Oxygen icons. Only OpenOffice in the root account is showing the right icons.

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Oxygen icons in OpenOffice

    Now you know that in OpenOffice you can go into Tools / Options / View and switch between the icon files you have loaded for OpenOffice, Right? My selections are Automatic (Oxygen), Galaxy (Default), High Contrast, Crystal, Tango, Classic & Oxygen. Some of the choices seem to be present due to icon files loaded in Software Management. Switching between them and saying OK causes an instant change of ALL the icons for me.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: Oxygen icons in OpenOffice

    Hi jdmcdaniel3,

    this is what is not working on the computers I'am using.
    I don't have the styles Tango and Classic, because I didn't installed them. The Styles Crystal, Galaxy, High Contrast and Oxygen are installed.
    OpenOffice is changing to Oxygen, but the old crystal icons seems to be a part of Oxygen (as User). When looking into the complete icon set (e.g. by choosing a specific icon for a function), the Oxygen "B U I" icons are not there, but the corresponding Crystal icons.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •