Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: OpenOffice .org problem/oocalc

  1. #1
    Join Date
    Sep 2008
    Location
    Ploiesti
    Posts
    101

    Default OpenOffice .org problem/oocalc

    Dear users and SuSE fans,
    ////////////////////////////////////////////////////////
    ..... # oocalc
    OpenOffice.org(10762): Session bus not found

    ....# KCrash: Application 'soffice.bin' crashing...
    sock_file=/root/.kde4/socket-NMyL/kdeinit4__0
    Warning: connect() failed: : No such file or directory
    KCrash cannot reach kdeinit, launching directly.
    drkonqi(10764): Session bus not found

    //////////////////////////////////////////////////////////

    So ,when from CLI (staying in KDE ) a navigate to a mounted partition from Win 7 when I have stored old files (tables,docs etc.) as root /otherwise can't do ,of course as you know and I type the command to open that file for working on it I get the above message.NO NEED to change the owner or rights ,as root.Till now I didn't have this problem.

    I did also this think:with chown user folder file path/chmod 0777 and after launch the application I get the same result/ERROR.

    BUT if from KDE I make double click with the mouse it's working,OF COURSE ,in this case with chown/chmod done BEFORE.
    Why ,do I have this strange behaviour ,when I think I know right the CLI is the strongest ,fastest and easiest way to work.

    Till now as I sad I navigated to the folder file /from mounted win partition and with oocalc,ooimpress etc as root I did what I needed without any trouble.
    The problem occured recently and I don't have explanation for and in plus keep ,please in mind ,from GUI/KDE double click and it is working.
    Really ,why?
    Otherpening directly oocalc as root from CLI staying in KDE from usr/bin / the same ERROR.uf.........

    Please,HELP me!

    Thank you in advance.

  2. #2

    Default Re: OpenOffice .org problem/oocalc

    Not sure I follow you exactly but IMO you root doesn't know the path to oocalc.
    IMHO, the right answer is GUI double click, the CLI for uid (and root) should be
    Code:
    /usr/bin/oocalc
    Why are you using root for CLI oocalc?
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  3. #3
    Join Date
    Sep 2008
    Location
    Ploiesti
    Posts
    101

    Default Re: OpenOffice .org problem/oocalc

    Because ,as I told you I have some files in win partition and from linux I must work on those.
    I can open them as normal user but I can't modify.

    So from CLI as root with kDE working ,just I open a Terminal,I can open those files and I can modify.I did this manny times.Now it doesn't work.
    Strange is the fact when I am logged directly as root from restart the CLI doesn't work but from KDE/GUI as root directly (with startx or whatever) it's working.
    Believe me I now very sure in the past in 11.2 no problem.

    see yu

  4. #4

    Default Re: OpenOffice .org problem/oocalc

    Ok need root to modify.

    My apology, I'm not clear what CLI is not working in your statement:
    Strange is the fact when I am logged directly as root from restart the CLI doesn't work but from KDE/GUI as root directly (with startx or whatever) it's working.
    Are you getting error messages when the CLI doesn't work?

    Oocalc requires X system, right? Startx and whatever makes sense, as does KDE/GUI terminal windows.

    "I am logged directly as root from restart the CLI" means what? X system or no X system running?
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  5. #5
    Join Date
    Sep 2008
    Location
    Ploiesti
    Posts
    101

    Default Re: OpenOffice .org problem/oocalc

    ..... # oocalc
    OpenOffice.org(10762): Session bus not found

    ....# KCrash: Application 'soffice.bin' crashing...
    sock_file=/root/.kde4/socket-NMyL/kdeinit4__0
    Warning: connect() failed: : No such file or directory
    KCrash cannot reach kdeinit, launching directly.
    drkonqi(10764): Session bus not found



    ERROR AS root

    NMyL:/mnt/sda3winDot/MCO/MCOblending # oocalc FUEL.xls
    OpenOffice.org(16227): Session bus not found

    NMyL:/mnt/sda3winDot/MCO/MCOblending # KCrash: Application 'soffice.bin' crashing...
    sock_file=/root/.kde4/socket-NMyL/kdeinit4__0
    Warning: connect() failed: : No such file or directory
    KCrash cannot reach kdeinit, launching directly.
    drkonqi(16229): Session bus not found
    NMyL:/mnt/sda3winDot/MCO/MCOblending # oocalc
    OpenOffice.org(16735): Session bus not found

    NMyL:/mnt/sda3winDot/MCO/MCOblending # KCrash: Application 'soffice.bin' crashing...
    sock_file=/root/.kde4/socket-NMyL/kdeinit4__0
    Warning: connect() failed: : No such file or directory
    KCrash cannot reach kdeinit, launching directly.
    drkonqi(16737): Session bus not found



    NO ERROR as regular user
    pushy@NMyL:/mnt/sda3winDot/MCO/MCOblending> oocalc
    pushy@NMyL:/mnt/sda3winDot/MCO/MCOblending>


    BUT as regular user I can't modify my files from win partition!
    And I need usually to do this.

    So could I get some help?
    Thank you in advance to all.

  6. #6
    Join Date
    Sep 2008
    Location
    Ploiesti
    Posts
    101

    Default Re: OpenOffice .org problem/oocalc

    btw:win partitions mounted;chown/chmod done for file I need to modify.

  7. #7

    Default Re: OpenOffice .org problem/oocalc

    Quote Originally Posted by Pushy View Post
    btw:win partitions mounted;chown/chmod done for file I need to modify.
    Does that fix the problem?

    Sorry, I really don't have answers for you, I'm just a sounding board.

    My thought, if you've logged in a user, then su to root, kde4 can't find /root/.kde4/socket-NMyL/kdeinit4__0 or the kdeinit to start a display session.

    Have you tried ?
    Code:
    kdesu 
    oocalc
    #
    # or
    #
    su 
    Password: 
    cd 
    oocalc
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  8. #8
    Join Date
    Sep 2008
    Location
    Ploiesti
    Posts
    101

    Default Re: OpenOffice .org problem/oocalc

    Hello again,

    I will try your soluton on monday.I let my lap with openSuSE at workplace/at home I have Debian.

    Thank you.

    Till then maybe our friends will come with additional solutions.

    First I am going to chech solution given by tarapharazon.

    Manny thanks to all for idea and time consumed here.

    Cheers

    Pushy from Ploiesti/Romania

  9. #9
    Carlos E. R. NNTP User

    Default Re: OpenOffice .org problem/oocalc

    On 2010-07-30 17:36, tararpharazon wrote:

    > My thought, if you've logged in a user, then su to root, kde4 can't
    > find /root/.kde4/socket-NMyL/kdeinit4__0 or the kdeinit to start a
    > display session.


    Or use "su -" instead of "su".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Elessar))

  10. #10
    Join Date
    Sep 2008
    Location
    Ploiesti
    Posts
    101

    Default Re: OpenOffice .org problem/oocalc

    I tried,it doen't work.

    thank you

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •