Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Firefox extremely slow (OpenSuse 11.3)

  1. #1

    Angry Firefox extremely slow (OpenSuse 11.3)

    Hi Folks,

    my Firefox is broken. Updated to latest 3.6.8 (Repo: Mozilla) with no effect. Killed my .mozilla directory and created brand new profile with no effect. OS is OpenSuse 11.3 (x64).
    While starting up, firefox seems to render really slow and does not accept interactions meanwhile, though it does not eat up lots of my CPU - it seems to wait for something? After loading the initial website completely, the URL- and Tab-Bars react as normal, but if I click on the menu bar, it takes about 20 seconds until the menu pops up.
    What else can I test?
    Your help is very much apreciated!

    BR
    Thomas

  2. #2

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    I'm sorry I can't help, but I have the exact same problem on a freshly installed and updated 11.3 x86_64.

    I noticed that both Firefox and Thunderbird have problems with menu's (right click or regular menus both take ~20 seconds to appear).

    Keyboard short-cuts such as CTRL-T or CTRL-W work as expected (ie. a new tab is opened / closed immediately)... CTRL-Q doesn't - it waits for about 20 second before the confirmation dialog pops up...

    Any ideas?

    Danilo

  3. #3

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    Installed a Flash via Yast (not Adobe Flash- cautious of this because I believe that I may have gotten nasty viruses in Windoze via that door). Don't know the exact name of the pkg in the repository. Can't look it up. Currently, there is some type of repository linkage problem from here... Anyways, it sucked up CPU like crazy - 100% according to the Gnome System Monitor. It was immediately uninstalled - and everything was fine again.
    My mission to politely ask all bike riders with loud exhausts to make their bikes quieter. Should be easy.

  4. #4

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    Quote Originally Posted by danperecky View Post
    Installed a Flash via Yast (not Adobe Flash- cautious of this because I believe that I may have gotten nasty viruses in Windoze via that door). Don't know the exact name of the pkg in the repository. Can't look it up. Currently, there is some type of repository linkage problem from here... Anyways, it sucked up CPU like crazy - 100% according to the Gnome System Monitor. It was immediately uninstalled - and everything was fine again.
    In my case there was close to no CPU usage...

    But I did find out something - I used 'strace' to see what Firefox is doing and found out that everytime I click on some menu (or a new dialog opens), strace shows some TCP connection to 127.0.0.1, port 4713. A bit of Googling revealed that 4713 is used by 'PulseAudio', which wasn't installed by default.

    After installing pulseaudio Firefox seems to work well - not so sure about other audio apps (Amarok etc.).

    Danilo

  5. #5
    Join Date
    Jul 2008
    Location
    Estonia
    Posts
    100

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    I've upgraded to 11.4 and now I have this issue too. And yes, when I start pulseaudio, the lag is gone. But I do not want to use pulseaudio, but with Firefox I have to? I didn't have this problem before though (even with Firefox 4.0b12 etc). Maybe upgrading Firefox to 4.0 is to blame?

  6. #6

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    I also find firefox to be extremely slow in 11.4 so I installed Chrome and it is running very quickly, running at a speed I would expect. Firefox is still slow so I would assume it is a firefox problem?

  7. #7
    Join Date
    Jul 2008
    Location
    Estonia
    Posts
    100

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    You mean it's slow as menus showing up lag multiple seconds etc?

  8. #8

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    Not slow to load the browser itself,but slow as if I were using a 56k modem at a very busy time when I'm using a fast cable connection.I'm finding Chrome to still be lightning fast loading and connecting to web pages after a reboot, and a few hours time.Firefox is still morbidly slow! *lol*
    Last edited by susemortal; 14-Mar-2011 at 14:30. Reason: grammar

  9. #9
    Join Date
    Nov 2009
    Location
    Santiago, Chile
    Posts
    171

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    Got similar issue with FF4 beta on openSUSE 11.4... It takes to much in "conecting" status for every website I request.
    HP pavilion dv6-6185la - Intel i7 - AMD Radeon 6770M - openSUSE 12.2 - KDE 4.9

  10. #10
    Join Date
    Jul 2008
    Location
    Estonia
    Posts
    100

    Default Re: Firefox extremely slow (OpenSuse 11.3)

    I think that's another issue in this case.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •