Results 1 to 3 of 3

Thread: /usr/lib/xulrunner-1.9.1.9 becomes empty

  1. #1
    Join Date
    Jun 2010
    Location
    Amman, Jordan
    Posts
    38

    Exclamation /usr/lib/xulrunner-1.9.1.9 becomes empty

    Hi all,
    when I open a terminal from any where I get the following massage:
    Code:
    ERROR: ld.so: object '/usr/lib/xulrunner-1.9.1.9/libmozjs.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/lib/xulrunner-1.9.1.9/libmozjs.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/lib/xulrunner-1.9.1.9/libmozjs.so' from LD_PRELOAD cannot be preloaded: ignored.
    these massages were appear after I installed the FREEWRL (3D visulaization ) program.
    I added the following two lines in the .bashrc :
    Code:
    export G4VRMLFILE_VIEWER=freewrl
    export LD_PRELOAD=/usr/lib/xulrunner-1.9.1.9/libmozjs.so freewrl
    also I do the following command in the terminal:
    Code:
    sudo cp /usr/share/fonts/truetype/VeraMono.ttf /usr/share/fonts
    other problem that when I did that , it was a some files and folders inside /usr/lib/xulrunner-1.9.1.9 but now its empty and the application does not work ( it was work)
    there was no /usr/lib/xulrunner-1.9.1.10 but now its appear!!!!
    I changed the second line to be :
    Code:
    export LD_PRELOAD=/usr/lib/xulrunner-1.9.1.10/libmozjs.so freewrl
    but the first massage is still appears and the application worked for a few seconds only.

    I am using openSUSE11.2 (i586) with KDE4.3.5

    I will be appreciated for any help or any idea

    respectfully,

  2. #2

    Default Re: /usr/lib/xulrunner-1.9.1.9 becomes empty

    Hello al-nobani,

    Quote Originally Posted by al-nobani
    these massages were appear after I installed the FREEWRL (3D visulaization ) program.
    I added the following two lines in the .bashrc :
    Code:
    export G4VRMLFILE_VIEWER=freewrl
    export LD_PRELOAD=/usr/lib/xulrunner-1.9.1.9/libmozjs.so freewrl
    I think your mozzila-xulrunner package got updated somehow.
    Maybe when you installed freewrl it auto-updated mozilla-xulrunner for a security fix?

    Could you post the output of this command:
    Code:
    zypper info mozilla-xulrunner191
    I changed the second line to be :
    Code:
    export LD_PRELOAD=/usr/lib/xulrunner-1.9.1.10/libmozjs.so freewrl
    but the first massage is still appears and the application worked for a few seconds only.
    These changes will only have effect when you log-out and log-in again.
    Or you could use this command to reload the .bashrc file:
    Code:
    source .bashrc
    If you still get the same error message after this then maybe ld remembers the previous one.
    To update the cache of ld run these command:
    Code:
    su -
    Enter your root password when prompted for it to become root.
    Code:
    ldconfig -v
    The -v is optional but it let's ldconfig print more information.
    Could you post the output of that command?

    This may not solve the problem that freewrl doesn't start.
    What happens when you run it from terminal?

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3
    Join Date
    Jun 2010
    Location
    Amman, Jordan
    Posts
    38

    Thumbs up Re: /usr/lib/xulrunner-1.9.1.9 becomes empty

    Hello Edward_Iii,
    yes you right,
    Code:
    nobani@linux-m9c6:~> zypper info mozilla-xulrunner191
    Loading repository data...
    Reading installed packages...
    
    
    Information for package mozilla-xulrunner191:
    
    Repository: @System
    Name: mozilla-xulrunner191
    Version: 1.9.1.10-0.1.1
    Arch: i586
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 22.5 MiB
    Summary: Mozilla Runtime Environment 1.9.1
    Description:
    XULRunner is a single installable package that can be used to bootstrap
    multiple XUL+XPCOM applications that are as rich as Firefox and
    Thunderbird.
    nobani@linux-m9c6:~>
    every thing is ok now, and the application is working correctly.
    But the system become frozen after few second, this is when I want to generate a g4_00.wrl (which is generated from freewrl application).
    The good thing that I can open the g4_00.wrl using the terminal after restarting the system

    thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •