Results 1 to 9 of 9

Thread: rebuilding yast/zypper repos

  1. #1
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    455

    Default rebuilding yast/zypper repos

    I'm wondering if there is a way to delete all the repos I have, and start afresh. Is there something I can delete (like a directory for example, similar to rebuilding one's firefox directory) and then simply restart yast and then add the repos I need?
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: rebuilding yast/zypper repos

    You can simply remove/add them in the repo management in Yast

    Or you can use zypper command to remove/add them (see man zypper)

    Perhaps you should say what problem you have. You could start with showing the current list
    zypper lr -d

  3. #3
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Default Re: rebuilding yast/zypper repos

    If you delete repos, it may result in totaling YaST, I speak from my experience. If you keep repos they wont bite you or eat your disk.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: rebuilding yast/zypper repos

    Quote Originally Posted by avenuemax View Post
    If you keep repos they wont bite you or eat your disk.
    Only if you disable them, else they will be able to bite you.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    455

    Default Re: rebuilding yast/zypper repos

    The problem I have, is that the repo "subpixel", which was giving me error windows and that I have deleted (because there is a new repo with a different name now), is giving me errors even though it has been deleted (does any of this make any sense?). So what I would like to do, is start fresh and rebuid my repos with the repos that weren't giving me errors, ie, all of them except subpixel.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: rebuilding yast/zypper repos

    If you installed stuff from that address and it no longer exists you may need to change the source repo in Yast for that package or packages.

  7. #7
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Default Re: rebuilding yast/zypper repos

    Trade packages with other repo that are active on your install.

  8. #8
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    455

    Default Re: rebuilding yast/zypper repos

    Actually, I don't know why I'm going on with this, 11.3 will be out in a few days and I'm intending to upgrade anyway.
    Thanks to all who tried to help.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  9. #9
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    455

    Default Re: rebuilding yast/zypper repos

    And as such, I am now on 11.3. Beautiful!
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •