Results 1 to 10 of 10

Thread: X server fails in runlevel 5

  1. #1
    Join Date
    Jun 2009
    Location
    Paraiso, Cartago, Costa Rica
    Posts
    7

    Default X server fails in runlevel 5

    I recently updated from OS 11.2 to OS 11.3 and right after that had problems with my X.org server.

    If started with normal settings X crashes in runlevel 5, so right at the end of the boot process.

    If started with x11debug option X works, However I cannot use wine with this option.

    boot.msg (no debug options):

    I don't even have an idea how to look for the problem, but there must be some feature that causes X to crash, which is not included in the debug-mode.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: X server fails in runlevel 5

    Did you add nomodeset to the boot argument and do
    the System/Kernel option NO_KMS_IN_INITRD from "No" to "Yes" in the /etc/sysconfig Editor in Yast.
    Try booting in Failsafe first, it has the nomodeset option in it's arguments already.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2009
    Location
    Paraiso, Cartago, Costa Rica
    Posts
    7

    Default Re: X server fails in runlevel 5

    I hadn't set these options, yet, but I tried and they couldn't solve my problem.

    My failsafe option doesn't include that nomodeset option, but it starts the X server with limited options as I said already. The option responsible for this is x11failsafe not x11debug as I called it earlier.

    My failsafe mode:

    kernel /boot/vmlinuz-2.6.31.12-0.2-desktop root=/dev/disk/by-id/ata-SAMSUNG_HM120JI_S09GJ30LB62942-part2 showopts ide=nodma apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x367
    Adding nomodeset to my normal boot option unfortunately didn't do the trick.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: X server fails in runlevel 5

    That kernel is not 11.3
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: X server fails in runlevel 5

    That kernel is not 11.3
    Well spotted Carl!

    I recently updated from OS 11.2 to OS 11.3 and right after that had problems with my X.org server.
    I think you need to tell us more about how you upgraded, and maybe provide the output of

    Code:
    zypper lr -d

  6. #6
    Join Date
    Jun 2009
    Location
    Paraiso, Cartago, Costa Rica
    Posts
    7

    Default Re: X server fails in runlevel 5

    Wow, never saw that ...

    Well, I replaced all Repositories from 11.2 with the ones from 11.3, than

    zypper update
    Here is the output from zypper lr -d

    # | Alias | Name | Aktiviert | Aktualisieren | Prioritt | Typ | URI | Dienst
    --+-----------------------+-----------------------+-----------+---------------+-----------+--------+-----------------------------------------------------------------+-------
    1 | ftp.skynet.be-suse | Packman Repository | Ja | Ja | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    2 | google-chrome | google-chrome | Ja | Ja | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/x86_64 |
    3 | openSUSE-11.3-Debug | openSUSE-11.3-Debug | Nein | Ja | 99 | yast2 | Index of /debug/distribution/11.3/repo/oss |
    4 | openSUSE-11.3-Non-Oss | openSUSE-11.3-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    5 | openSUSE-11.3-Source | openSUSE-11.3-Source | Nein | Ja | 99 | yast2 | Index of /source/distribution/11.3/repo/oss |
    6 | openSUSE-11.3-Update | openSUSE-11.3-Update | Ja | Ja | 99 | rpm-md | Index of /update/11.3 |
    7 | openSUSE_11.3-0 | openSUSE 11.3-0 | Ja | Ja | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    I'll try obtain the new kernel now.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: X server fails in runlevel 5

    You need to delete (or adjust) that Packman repo - its for 11.2!

    Usually you would use

    Code:
    zypper dup
    for this type of upgrade.

  8. #8
    Join Date
    Jun 2009
    Location
    Paraiso, Cartago, Costa Rica
    Posts
    7

    Default Re: X server fails in runlevel 5

    Oh, ****, thank you.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: X server fails in runlevel 5

    Outlined here:

    SDB:System upgrade - openSUSE

    Good luck. :-D

  10. #10
    Join Date
    Jun 2009
    Location
    Paraiso, Cartago, Costa Rica
    Posts
    7

    Default Re: X server fails in runlevel 5

    OK it works now.

    Turns out the command line update doesn't recognize some of the updates or cannot find an update strategy. The GUI-Software-Management however does, so I got all the missing packages including the kernel. Hope my next update will work better.

    Thanks to everyone who helped me.

    Thread can be closed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •