Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Execute Blender 2.53 Beta

  1. #1
    Join Date
    Jul 2010
    Location
    Portugal
    Posts
    6

    Default Execute Blender 2.53 Beta

    Hi...
    Any one have try the blender 2.53 Beta??
    I'm trying to use on openSuse 11.3 KDE but blender don’t executes

    Any ideas?! Tks

  2. #2

    Default Re: Execute Blender 2.53 Beta

    Hello odeartgre and welcome to the community!

    Quote Originally Posted by odeartgre
    I'm trying to use on openSuse 11.3 KDE but blender dont executes
    Could you explain what the exact error is?
    If you get an error message or not.
    And could you post the output of blender when you run it from terminal?

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3
    Join Date
    Jul 2010
    Location
    Portugal
    Posts
    6

    Default Re: Execute Blender 2.53 Beta

    this is what says on blender help

    Linux, FreeBSD, Irix, Solaris: Unpack the distribution, copy the .blender directory from it to your home directory. Then run the Blender executable.
    Install scripts by putting them in the .blender/scripts inside your home folder.
    linux-u3a5:/home/ze/Downloads/Blender253/blender-2.53-beta-linux-glibc27-x86_64 # dir
    total 50952
    drwxr-xr-x 6 ze users 4096 2010-07-21 15:35 2.53
    -rwxr-xr-x 1 ze users 52103776 2010-07-21 15:36 blender
    drwxr-xr-x 27 ze users 4096 2010-07-21 15:36 .blender
    -rwxr-xr-x 1 ze users 630 2010-07-21 15:36 blender-softwaregl
    -rw-r--r-- 1 ze users 5716 2010-07-21 15:36 copyright.txt
    -rw------- 1 ze users 69 2010-07-25 18:46 .directory
    -rw-r--r-- 1 ze users 17992 2010-07-21 15:36 GPL-license.txt
    drwxr-xr-x 6 ze users 4096 2010-07-21 15:35 icons
    drwxr-xr-x 2 ze users 4096 2009-06-19 08:38 lib
    drwxr-xr-x 5 ze users 4096 2010-07-21 15:36 plugins
    -rw-r--r-- 1 ze users 2396 2010-07-21 15:36 Python-license.txt
    -rw-r--r-- 1 ze users 6428 2010-07-21 15:36 readme.html
    linux-u3a5:/home/ze/Downloads/Blender253/blender-2.53-beta-linux-glibc27-x86_64 # blender
    If 'blender' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf blender
    linux-u3a5:/home/ze/Downloads/Blender253/blender-2.53-beta-linux-glibc27-x86_64 # blender
    If 'blender' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf blender
    linux-u3a5:/home/ze/Downloads/Blender253/blender-2.53-beta-linux-glibc27-x86_64 # cnf blender

    The program 'blender' can be found in following packages:
    * blender [ path: /usr/bin/blender, repository: zypp (repo-oss) ]
    * blender [ path: /usr/bin/blender, repository: zypp (cd-704e4539) ]

    Try installing with:
    zypper install blender

    linux-u3a5:/home/ze/Downloads/Blender253/blender-2.53-beta-linux-glibc27-x86_64 #
    i dont get any error ...

  4. #4
    Join Date
    Aug 2009
    Location
    Mountain View, CA
    Posts
    204

    Default Re: Execute Blender 2.53 Beta

    From the same directory, could you execute blender by running this command:

    ./blender

  5. #5

    Default Re: Execute Blender 2.53 Beta

    I've got the same problem and 'ldd blender' will list its dependancies. You're probably missing the same as I was which is libjpeg.so.62 which is in the package manager if you search for libjpeg, and libtiff.so.4. That's a bit more of a problem because other posts are telling me it doesn't exist yet and to create a symlink from 3 to 4 which I've done but it had no effect. Any ideas?

  6. #6

    Default Re: Execute Blender 2.53 Beta

    Hello odeartgre,

    Quote Originally Posted by odeartgre
    linux-u3a5:/home/ze/Downloads/Blender253/blender-2.53-beta-linux-glibc27-x86_64 # blender
    If 'blender' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf blender
    linux-u3a5:/home/ze/Downloads/Blender253/blender-2.53-beta-linux-glibc27-x86_64 # cnf blender

    The program 'blender' can be found in following packages:
    * blender [ path: /usr/bin/blender, repository: zypp (repo-oss) ]
    * blender [ path: /usr/bin/blender, repository: zypp (cd-704e4539) ]

    Try installing with:
    zypper install blender
    @ash25 I think your right he needs to run ./blender instead of blender.
    Or add the blender directory to his PATH variable.

    Quote Originally Posted by adam-red
    I've got the same problem and 'ldd blender' will list its dependancies. You're probably missing the same as I was which is libjpeg.so.62 which is in the package manager if you search for libjpeg, and libtiff.so.4. That's a bit more of a problem because other posts are telling me it doesn't exist yet and to create a symlink from 3 to 4 which I've done but it had no effect. Any ideas?
    I've downloaded blender myself and encountered the same error.
    And I think when odeartgre gets it running he'll encounter the same error.

    I my case I had libjpeg already installed.
    But I still got the libtiff.so.4 error.

    To solve this make sure you've got libtiff3 installed.
    Code:
    zypper install libtiff3
    Now go to your library directory:
    Code:
    cd /usr/lib
    Now make a symlink:
    Code:
    ln -s ./libtiff.so.3.8.0 ./libtiff.so.4
    There's a chance you've got a different version.
    In that case change 3.8.0 to your version or make a symlink of ./libtiff.so.3.

    Now I could run blender and I must say the new interface looks nice!

    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  7. #7
    Join Date
    Jul 2010
    Location
    Portugal
    Posts
    6

    Default Re: Execute Blender 2.53 Beta

    linux-u3a5:/home/ze # cd /home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64/
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 # dir
    total 50952
    drwxr-xr-x 6 ze users 4096 2010-07-21 15:35 2.53
    -rwxr-xr-x 1 ze users 52103776 2010-07-21 15:36 blender
    drwxr-xr-x 27 ze users 4096 2010-07-21 15:36 .blender
    -rwxr-xr-x 1 ze users 630 2010-07-21 15:36 blender-softwaregl
    -rw-r--r-- 1 ze users 5716 2010-07-21 15:36 copyright.txt
    -rw------- 1 ze users 68 2010-07-28 19:59 .directory
    -rw-r--r-- 1 ze users 17992 2010-07-21 15:36 GPL-license.txt
    drwxr-xr-x 6 ze users 4096 2010-07-21 15:35 icons
    drwxr-xr-x 2 ze users 4096 2009-06-19 08:38 lib
    drwxr-xr-x 5 ze users 4096 2010-07-21 15:36 plugins
    -rw-r--r-- 1 ze users 2396 2010-07-21 15:36 Python-license.txt
    -rw-r--r-- 1 ze users 6428 2010-07-21 15:36 readme.html
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 # ./blender
    ./blender: error while loading shared libraries: libtiff.so.4: cannot open shared object file: No such file or directory
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 # ./blender
    ./blender: error while loading shared libraries: libtiff.so.4: cannot open shared object file: No such file or directory
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 #
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 # zypper install libtiff3
    Loading repository data...
    Reading installed packages...
    'libtiff3' is already installed.
    No update candidate for 'libtiff3-3.9.2-5.1.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...

    Nothing to do.
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 # cd /usr/lib
    linux-u3a5:/usr/lib # ln -s ./libtiff.so.3.9.0 ./libtiff.so.4
    linux-u3a5:/usr/lib # ln -s ./libtiff.so.3.9.2 ./libtiff.so.4
    ln: creating symbolic link `./libtiff.so.4': File exists
    linux-u3a5:/usr/lib # ./blender
    bash: ./blender: No such file or directory
    linux-u3a5:/usr/lib # cd /home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64/
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 # ./blender
    ./blender: error while loading shared libraries: libtiff.so.4: cannot open shared object file: No such file or directory
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 #
    I thing i did not any thing wrong but ...!!! now i get libtiff.so.4 error

  8. #8

    Default Re: Execute Blender 2.53 Beta

    Hello odeartgre,

    Quote Originally Posted by odeartgre
    ...
    linux-u3a5:/home/ze/Downloads/blender-2.53-beta-linux-glibc27-x86_64 # cd /usr/lib
    linux-u3a5:/usr/lib # ln -s ./libtiff.so.3.9.0 ./libtiff.so.4
    linux-u3a5:/usr/lib # ln -s ./libtiff.so.3.9.2 ./libtiff.so.4
    ln: creating symbolic link `./libtiff.so.4': File exists
    ...
    I think the problem lies here.
    You've done this command twice but each with a different version.
    The problem is that only one can be installed at the time.

    Could you post the output of this command:
    Code:
    dir /usr/lib/libtiff*
    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  9. #9
    Join Date
    Jul 2010
    Location
    Portugal
    Posts
    6

    Default Re: Execute Blender 2.53 Beta

    Resolved

    cd /usr/lib64
    not
    cd /usr/lib
    my problem ... was lib ... tk's to all ... great

  10. #10
    Join Date
    Oct 2009
    Location
    Berlin.
    Posts
    90

    Default Re: Execute Blender 2.53 Beta

    I ran dir /usr/lib64/libtiff*
    and got this:
    Code:
    lrwxrwxrwx 1 root root     16 2010-08-01 09:47 /usr/lib64/libtiff.so.3 -> libtiff.so.3.9.2
    -rwxr-xr-x 1 root root 409768 2010-07-15 01:46 /usr/lib64/libtiff.so.3.9.2
    lrwxrwxrwx 1 root root     18 2010-09-08 14:04 /usr/lib64/libtiff.so.4 -> ./libtiff.so.3.9.0
    lrwxrwxrwx 1 root root     18 2010-08-01 09:47 /usr/lib64/libtiffxx.so.3 -> libtiffxx.so.3.9.2                                                                  
    -rwxr-xr-x 1 root root  10424 2010-07-15 01:46 /usr/lib64/libtiffxx.so.3.9.2
    However, when I try ./blender it doesn't work. Error libtiff.so.4
    Code:
    ./blender: error while loading shared libraries: libtiff.so.4: cannot open shared object file: No such file or directory
    What can I do?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •