Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Digikam 1.3.0 will not start - OpenSuse 11.3

  1. #1

    Default Digikam 1.3.0 will not start - OpenSuse 11.3

    I'm a new OpenSuse user so I'm not exactly sure the right protocol on this. But I want to make sure this is not a problem I have before I file a bug report.

    Digikam will not start.
    I tried starting it in a terminal to get a little feedback. Here is the result:
    Code:
    tubasoldier@thinkpad:~> digikam
    QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
    Time elapsed: 21 ms
    Time elapsed: 3 ms
    Model: Time elapsed: 98 ms
    TextureColorizer: Time elapsed: 20 ms
    Time elapsed: 3 ms
    Time elapsed: 2 ms
    Model: Time elapsed: 10 ms
    digikam: symbol lookup error: /usr/lib/libdigikamcore.so.1: undefined symbol: _ZN11KDcrawIface19RawDecodingSettingsaSERKS0_
    tubasoldier@thinkpad:~>
    I believe the symbol lookup error is the real issue. Is this something I need to fix in my system? Or should I file a bug report over this? I would just like to clear this up if it is my issue, that way I'm not filing extra bug reports for no reason. Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    Which repo is it from?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    Same problem here:
    Code:
    jpo@jpo-hp-lap:~> digikam 
    QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
    Time elapsed: 30 ms
    Time elapsed: 9 ms
    Model: Time elapsed: 191 ms
    TextureColorizer: Time elapsed: 20 ms
    Time elapsed: 5 ms
    Time elapsed: 4 ms
    Model: Time elapsed: 18 ms
    digikam: symbol lookup error: /usr/lib/libdigikamcore.so.1: undefined symbol: _ZN11KDcrawIface19RawDecodingSettingsaSERKS0_
    The version is:
    Code:
    jpo@jpo-hp-lap:~> rpm -qif /usr/lib/libdigikamcore.so.1
    Name        : digikam                      Relocations: (not relocatable)
    Version     : 1.3.0                             Vendor: obs://build.opensuse.org/KDE
    Release     : 41.1                          Build Date: Mo 19 Jul 2010 22:10:06 CEST
    Install Date: So 25 Jul 2010 11:31:38 CEST      Build Host: build17
    Group       : Productivity/Graphics/Viewers   Source RPM: digikam-1.3.0-41.1.src.rpm
    Size        : 16258902                         License: GPLv2+
    Signature   : DSA/SHA1, Mo 19 Jul 2010 22:14:12 CEST, Key ID 27c070176f88bb2f
    URL         : digiKam - Photo Management Program | Manage your photographs as a professional with the power of Open Source
    Summary     : A KDE Photo Manager
    Description :
    digiKam is a simple digital photo management application for KDE, which
    allows you to import and organize your digital photos easily. The
    photos can be organized in albums, which can be sorted chronologically,
    by directory layout, or by custom collections. An easy-to-use interface
    that enables you to connect to your camera and preview, download, or
    delete your images, is provided.
    
    
    
    Authors:
    --------
        Gilles Caulier <caulier dot gilles at gmail dot com>
        Marcel Wiesweg <marcel dot wiesweg at gmx dot de>
        Andi Clemens <andi dot clemens at gmx dot net>
        Renchi Raju <renchi@green.tam.uiuc.edu> (Original author, retired)
    Distribution: KDE:UpdatedApps / openSUSE_11.3
    This is from the UpdatedKDEApps repository.

  4. #4

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    You need libkdcraw8 and libkexiv2-8 from KDE:UpdatedApps.

    Technically it's a packaging problem. But the real problem is that Digikam authors decided Digikam 1.3 would need versions of libkdcraw and libkexiv that will only be officially released with KDE 4.5... two months earlier!!

  5. #5
    Join Date
    Jul 2008
    Location
    Angel Fire, NM USA
    Posts
    330

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    RedDwarf:

    Will 1.3 run reliably if I install from KDE:UpdatedApps and install libkdcraw8 and libkexiv2-8 ?

    I'm having a problem using Digikam 1.2 in 11.3 with not rotating photos from portrait to landscape orientation.

    Tried installing 1.3 from KDE:UpdatedApps but it failed to launch.

  6. #6
    Join Date
    Jun 2009
    Location
    Pennsylvania, USA
    Posts
    233

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    jpo234 wrote:

    >
    >
    > This is from the UpdatedKDEApps repository.
    >
    >

    Don't know about this repository, but digikam 1.3 needs some newer libraries
    (from KDE 4.5); in particular libkdcraw and libkexev2. Did the install of
    1.3 drag in anything else?

  7. #7

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    Quote Originally Posted by GeoBaltz View Post
    jpo234 wrote:

    >
    >
    > This is from the UpdatedKDEApps repository.
    >
    >

    Don't know about this repository, but digikam 1.3 needs some newer libraries
    (from KDE 4.5); in particular libkdcraw and libkexev2. Did the install of
    1.3 drag in anything else?
    It did install libkdcraw and libkexev2 as well.
    I didn't realize the UpdatedKDEApps repository was rather unstable. It sounded as a sort of backports for KDE. So in my situation I've removed it and reinstalled Digikam. Solved for me. Thanks for pointing out the problem.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    UpdatedApps is the same as Backports

    Navigate to backports in the repos and look at the url in your browser
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    Don't know about this repository, but digikam 1.3 needs some newer libraries
    (from KDE 4.5); in particular libkdcraw and libkexev2. Did the install of
    1.3 drag in anything else?
    Nope. Manually changing these two libraries (it's libkexiv2 b.t.w.) did indeed solve the startup problem.
    Unfortunately digikam 1.3.0 ist still unable to rotate pictures from the album view (which was the original problem that triggered my upgrade attempt).

  10. #10

    Default Re: Digikam 1.3.0 will not start - OpenSuse 11.3

    so, i got some help from suse irc channel.

    try:

    #zypper dup -r 6

    that installed some new packages and libs. After that i could start digikam and showfoto. OR: YAST -> Software Install -> View -> Repositories -> Click on the Backports KDE Repository -> Switch system packages to the versions in this repository. And then it'll install a bunch of new happy files!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •