Results 1 to 7 of 7

Thread: gdm

  1. #1

    Smile gdm

    Hi,
    how to change gdm login fonts in opensuse 11.3?
    regards,
    Marek

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: gdm

    I think that is controlled by the configuration file displaymanager located in /etc/sysconfig/. If you use KDE then goto menu / Run Command:

    Code:
    kdesu kwrite /etc/sysconfig/displaymanger
    Read through the help comments. You might create a backup copy of the file first. You must be root to change the file as the above command will ask for the root user password. You must restart your computer for these changes to take effect.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: gdm

    Quote Originally Posted by jdmcdaniel3 View Post
    I think that is controlled by the configuration file displaymanager located in /etc/sysconfig/. If you use KDE then goto menu / Run Command:

    Code:
    kdesu kwrite /etc/sysconfig/displaymanger
    Read through the help comments. You might create a backup copy of the file first. You must be root to change the file as the above command will ask for the root user password. You must restart your computer for these changes to take effect.

    Thank You,
    FWIW, I find with some applications the file .ICEauthority ownership is changed from uid:gid to root:root, and that can cause login problems.
    In my case,
    Code:
    gnomesu -c kwrite
    the .ICEauthority was changed.

    Generally, I use
    Code:
    sudoedit file
    in terminal mode for editing the file with vi and it doesn't affect the .ICEauthority ownership, and sudo for most other commands.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  4. #4
    Join Date
    Jun 2009
    Location
    Pennsylvania, USA
    Posts
    233

    Default Re: gdm

    tararpharazon wrote:

    >> Thank You, FWIW, I find with some applications the file .ICEauthority
    >> ownership

    > is changed from uid:gid to root:root, and that can cause login problems.
    >
    > In my case,
    > Code:
    > --------------------
    > gnomesu -c kwrite
    > --------------------
    > the .ICEauthority was changed.
    >


    If you can reproduce this, please file a bug report. Having gnomesu muck
    about with permissions in ~user is a big no-no, and should be fixed.


    > Generally, I use
    > Code:
    > --------------------
    > sudoedit file
    > --------------------
    > in terminal mode for editing the file with vi and it doesn't affect the
    > .ICEauthority ownership, and sudo for most other commands.
    >
    >



  5. #5

    Default Re: gdm

    in this file i don't see such option, how to do it?

  6. #6

    Default Re: gdm

    Quote Originally Posted by GeoBaltz View Post
    tararpharazon wrote:

    If you can reproduce this, please file a bug report. Having gnomesu muck
    about with permissions in ~user is a big no-no, and should be fixed.
    That doesn't happen with kdesu? May be due to your openSUSE version.

    I reproduced it every time in 11.1, it' s fixed in 11.2 and I expect(assume) 11.3.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  7. #7

    Default Re: gdm

    I can edit this file, but there is no line where I can change font settings

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •