Results 1 to 9 of 9

Thread: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

  1. #1

    Question Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    11.3 KDE 4.4.4

    I've imported my contacts in adressbook and I can see them in Kontact - Adresses. But when I compose a new mail, I can't select any of my contacts. There is a combobox to select between following choices:

    • All
    • Default Adress book
    • Distribution list
    • recent adresses
    • Selected adresses


    But none of these options shows the contacts I have imported. And I can't find an option to make my imported adress book the default adress book. Any ideas?

  2. #2
    upscope NNTP User

    Default Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    suskewiet wrote:

    >
    > 11.3 KDE 4.4.4
    >
    > I've imported my contacts in adressbook and I can see them in Kontact -
    > Adresses. But when I compose a new mail, I can't select any of my
    > contacts. There is a combobox to select between following choices:
    >
    >
    > - All
    > - Default Adress book
    > - Distribution list
    > - recent adresses
    > - Selected adresses
    >
    >
    > But none of these options shows the contacts I have imported. And I
    > can't find an option to make my imported adress book the default adress
    > book. Any ideas?
    >

    I have the same problem, It's been around since MS6 at least.

    --
    Russ
    openSUSE 11.3 (2.6.34-12-desktop) | Platform Version 4.4.4 (KDE 4.4.4)
    "release 2" | Intel DX48BT2 motherboard | 4 GB | GeForce 8400GS | 1TB (1) &
    320 Int. (2) | 1TB & 120 GB Ext.

  3. #3
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    I have the same problem.
    I'm stuck with opening up my contacts so I can copy & past the email adresses into my emails.
    Anyone have a solution?

    KDE 4.5
    KAddressBook 4.4.5
    Kontact 4.4.5

  4. #4
    Join Date
    Aug 2008
    Location
    New Zealand
    Posts
    9

    Default Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    Quote Originally Posted by suskewiet View Post
    11.3 KDE 4.4.4

    I've imported my contacts in adressbook and I can see them in Kontact - Adresses. But when I compose a new mail, I can't select any of my contacts. There is a combobox to select between following choices:

    • All
    • Default Adress book
    • Distribution list
    • recent adresses
    • Selected adresses


    But none of these options shows the contacts I have imported. And I can't find an option to make my imported adress book the default adress book. Any ideas?
    I had the same problem. The fix is:
    • In Kickoff go to system settings
    • > "Advanced" tab
    • > "KDE Resources"
    • Select "Contacts" from the dropdown menu
    • Click add or new(The top button, which for some odd reason on my system doesn't have anything on it, probably a theme issue)
    • select Akonadi address books > ok
    • akonadi-resource will appear in the KDE Resources window, make sure the box is checked and you're good to go

  5. #5
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    Yorick, thank-you for this, it has been bugging quite a few people for a while! The button is blanked out on mine as well, I guess a genuine bug, and the reason that the problem is common?
    I have posted links to your solution to these threads:
    http://forums.opensuse.org/english/g...ml#post2197653
    http://forums.opensuse.org/english/g...se-11-2-a.html

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  6. #6
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Smile Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    Thanks mate, that worked!
    Very happy now.

  7. #7
    upscope NNTP User

    Default Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    Yorick wrote:

    >
    > suskewiet;2195195 Wrote:
    >> 11.3 KDE 4.4.4
    >>
    >> I've imported my contacts in adressbook and I can see them in Kontact -
    >> Adresses. But when I compose a new mail, I can't select any of my
    >> contacts. There is a combobox to select between following choices:
    >>
    >> > > >

    > - All
    > - Default Adress book
    > - Distribution list
    > - recent adresses
    > - Selected adresses
    > > > >

    >>
    >> But none of these options shows the contacts I have imported. And I
    >> can't find an option to make my imported adress book the default
    >> adress book. Any ideas?

    >
    > I had the same problem. The fix is:
    >
    > - In Kickoff go to system settings
    > - > "Advanced" tab
    > - > "KDE Resources"
    > - Select "Contacts" from the dropdown menu
    > - Click add or new(The top button, which for some odd reason on my
    > system doesn't have anything on it, probably a theme issue)
    > - select Akonadi address books > ok
    > - akonadi-resource will appear in the KDE Resources window, make
    > sure the box is checked and you're good to go

    Just for information: on KDE 4.5.1 and I think 4.5.0 it is under Personal
    Settings (Configure Desktop)--> Common Appearance and Behavior --> Personal
    Information.

    --
    Russ
    openSUSE 11.3 (2.6.34-12-default)|KDE 4.5.1|
    Intel core2duo 2.5 MHZ,|4GB DDR3|GeForce 8400GS

  8. #8
    Join Date
    Aug 2008
    Location
    New Zealand
    Posts
    9

    Default Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    Quote Originally Posted by wakou View Post
    Yorick, thank-you for this, it has been bugging quite a few people for a while!
    No problem, glad to help
    The button is blanked out on mine as well, I guess a genuine bug, and the reason that the problem is common?
    There is a bug filed on KDE https://bugs.kde.org/show_bug.cgi?id=236974
    It appears to be an issue with translation when using en_GB

  9. #9
    Join Date
    Mar 2010
    Location
    Paris, France
    Posts
    48

    Default Re: Kmail: Imported my contacts in adressbook, but new mail doesn't see them

    Quote Originally Posted by Yorick View Post
    I had the same problem. The fix is:
    • In Kickoff go to system settings
    • > "Advanced" tab
    • > "KDE Resources"
    • Select "Contacts" from the dropdown menu
    • Click add or new(The top button, which for some odd reason on my system doesn't have anything on it, probably a theme issue)
    • select Akonadi address books > ok
    • akonadi-resource will appear in the KDE Resources window, make sure the box is checked and you're good to go
    As to me, KDE 4.4.4, Kontact 4.4.5, the problem is, as soon as I add an akonadi addressbook in KDE resources, kontact crashes :
    Code:
    akoine@linux-6wx9:~> kontact
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    "/usr/bin/kontact(10771)" Error in thread 140352936191840 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
    "/usr/bin/kontact(10771)" Error in thread 140352936191840 : "QLocalSocket::connectToServer: Connection refused"
    "/usr/bin/kontact(10771)" Error in thread 140352936191840 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
    "/usr/bin/kontact(10771)" Error in thread 140352936191840 : "QLocalSocket::connectToServer: Connection refused"
    "/usr/bin/kontact(10771)" Error in thread 140352936191840 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
    "/usr/bin/kontact(10771)" Error in thread 140352936191840 : "QLocalSocket::connectToServer: Connection refused"
    kontact(10771) KMKernel::recoverDeadLetters: Unable to open autosave file "1284447861.7018.WI9O8" 
    kontact(10771) KMKernel::recoverDeadLetters: Unable to open autosave file "1284448410.7665.erEt1" 
    kontact(10771)/kdeui (kdelibs): No such XML file "/home/akoine/.kde4/share/apps/kontact/local-kmail.rc" 
    kontact(10771)/kio (KDirWatch) KDirWatchPrivate::removeEntry: doesn't know "/home/akoine/.kde4/share/apps/kabc" 
    kontact(10771)/kdepimlibs (kcal): Cannot read uid map file ' "/home/akoine/.kde4/share/apps/kcal/uidmaps/remote_hRgg8f4JOV" ' 
    <unknown program name>(10770)/: Communication problem with  "kontact" , it probably crashed. 
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." " 
    
    akoine@linux-6wx9:~>
    It seems to be a know bug : [Bug 625182] New: using akonadi as a kde contact ressource crashes konta
    I can't find any workaround, and it's very annoying ...
    OpenSUSE 13.1 x64 on a Asrock H87 Performance, 8Go RAM, Intel core i5 4670, GTX 670. Dual boot Windows 8.1, two separate hard drives.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •