Results 1 to 4 of 4

Thread: phpMyadmin will not connect to MySQl.

  1. #1
    upscope NNTP User

    Default phpMyadmin will not connect to MySQl.

    MySQL Server 5.1.46-log
    MySQL Client Version 5.1.46

    Is anyone having problems getting phpMyAdmin
    working with MySQl under openSUSE 11.3-
    Released version? I put a copy of
    config.ini.php from my RC2 setup in
    /srv/www/htdocs/phpMyAdmin but it does not
    work. Also I notice the sample copy in that
    directory is now a link to /etc/phpmyadmin
    and the config.ini.php there is wwwrun:root.
    Is there any documentation on what changes
    are necessary? I can login into the MySQL
    server with command line and MySQL
    administrator with no problems.
    Ithink it has to do with permissions or
    ownership.

    /etc/phpMyAdmin
    -rw-r----- 1 wwwrun root 9895 2010-07-22
    21:25 config.inc.php

    Any help would be appreciated.

    --
    Russ
    openSUSE 11.3(2.6.34-12-desktop)|Platform
    Version 4.4.4 (KDE 4.4.4)"release 2"|Intel
    DX48BT2 mb.4GB|GeForce 8400GS|1TB(1)& 320
    Int.(2)|1TB & 120 GB Ext.

  2. #2

    Default Re: phpMyadmin will not connect to MySQl.

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    What error(s) do you get? Anything show up in /var/log/apache2/error_log
    that is relevant?

    Good luck.





    On 07/23/2010 10:11 AM, upscope wrote:
    > MySQL Server 5.1.46-log
    > MySQL Client Version 5.1.46
    >
    > Is anyone having problems getting phpMyAdmin
    > working with MySQl under openSUSE 11.3-
    > Released version? I put a copy of
    > config.ini.php from my RC2 setup in
    > /srv/www/htdocs/phpMyAdmin but it does not
    > work. Also I notice the sample copy in that
    > directory is now a link to /etc/phpmyadmin
    > and the config.ini.php there is wwwrun:root.
    > Is there any documentation on what changes
    > are necessary? I can login into the MySQL
    > server with command line and MySQL
    > administrator with no problems.
    > Ithink it has to do with permissions or
    > ownership.
    >
    > /etc/phpMyAdmin
    > -rw-r----- 1 wwwrun root 9895 2010-07-22
    > 21:25 config.inc.php
    >
    > Any help would be appreciated.
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJMScFVAAoJEF+XTK08PnB536AP/1wpkwsXVnppDYYUBmp9zvxF
    Dys9AY7L2OLtqBSFMXkXZ/526OVcM0LLNo4VwQvkJ/6xsvQO1dDzMVL23TSMPZfR
    hgXBP8xE0rURl4qbcHMip7C2odv1p+MV5/XkxQUfABRVEgLbKWK49Ji5OqWPxs5i
    dYa7SHjzzxIoaG3GjkuFRNj2k+f6SQ88A49HmZQnKcuCs8awn8K5AccMuAlPWJud
    cL+VDkeC//Yny3Voif2SoFUBFih2gNE+ag7uUwXEClngpcT45YUsPFjoKr5UQyOU
    HcXbGYoitiCcjTk5GhZtIFdr0JF3lFDfn1NuG8e22aGCclqoR+ZESMWoiqf0niUq
    ipqpSSJFeU2H/S5SQZEZnPOaIJg+i/6UgBJ8haH5O8s1RhF3UBp/Q30MXvZHUvbu
    heDaqnYoKzTor9GlbGvyoVtWjgaAiSXNNZx63uO9Jrf8fG97KdICz2yD93SsjORh
    uLOW4BGty31IHcomho/3hdY5joHeAzh9/87lpA/kR3bgnEWq8NV6J5XEuXZ1WvzH
    1TOIsPkEOEMlbNZJB0XvuTGCut2k93WE4UwjG+V3ggDplCPNt/SxdHE9IBtydY19
    sqX93lTBBdCqq1hkKqREEp8eveidZls9Ca3+zHUvNJT8+G8UXN8Z8c1IQPZdJDer
    wWSi0CoxudQS6WO+yium
    =NQuK
    -----END PGP SIGNATURE-----

  3. #3
    upscope NNTP User

    Default Re: phpMyadmin will not connect to MySQl.

    ab@novell.com wrote:

    > -----BEGIN PGP SIGNED MESSAGE-----
    > Hash: SHA1
    >
    > What error(s) do you get? Anything show up

    in /var/log/apache2/error_log
    > that is relevant?
    >
    > Good luck.
    >
    >

    Nothing I saw in the log indicated an error.
    I lost my main drive yesterday afternoon,
    with bad supper block. Fixed it and now
    recovering. Will reinstall phpmyadmin and
    make sure it was not releated to the disk
    problem. Will post sometime tommorrow I hope.

    Thanks for your help so far.
    >
    > On 07/23/2010 10:11 AM, upscope wrote:
    >> MySQL Server 5.1.46-log
    >> MySQL Client Version 5.1.46
    >>
    >> Is anyone having problems getting

    phpMyAdmin
    >> working with MySQl under openSUSE 11.3-
    >> Released version? I put a copy of
    >> config.ini.php from my RC2 setup in
    >> /srv/www/htdocs/phpMyAdmin but it does not
    >> work. Also I notice the sample copy in

    that
    >> directory is now a link to /etc/phpmyadmin
    >> and the config.ini.php there is

    wwwrun:root.
    >> Is there any documentation on what changes
    >> are necessary? I can login into the MySQL
    >> server with command line and MySQL
    >> administrator with no problems.
    >> Ithink it has to do with permissions or
    >> ownership.
    >>
    >> /etc/phpMyAdmin
    >> -rw-r----- 1 wwwrun root 9895 2010-07-22
    >> 21:25 config.inc.php
    >>
    >> Any help would be appreciated.
    >>

    > -----BEGIN PGP SIGNATURE-----
    > Version: GnuPG v2.0.12 (GNU/Linux)
    > Comment: Using GnuPG with Mozilla -

    http://enigmail.mozdev.org/
    >
    >

    iQIcBAEBAgAGBQJMScFVAAoJEF+XTK08PnB536AP/1wpkwsXVnppDYYUBmp9zvxF
    >

    Dys9AY7L2OLtqBSFMXkXZ/526OVcM0LLNo4VwQvkJ/6xsvQO1dDzMVL23TSMPZfR
    >

    hgXBP8xE0rURl4qbcHMip7C2odv1p+MV5/XkxQUfABRVEgLbKWK49Ji5OqWPxs5i
    >

    dYa7SHjzzxIoaG3GjkuFRNj2k+f6SQ88A49HmZQnKcuCs8awn8K5AccMuAlPWJud
    >

    cL+VDkeC//Yny3Voif2SoFUBFih2gNE+ag7uUwXEClngpcT45YUsPFjoKr5UQyOU
    >

    HcXbGYoitiCcjTk5GhZtIFdr0JF3lFDfn1NuG8e22aGCclqoR+ZESMWoiqf0niUq
    >

    ipqpSSJFeU2H/S5SQZEZnPOaIJg+i/6UgBJ8haH5O8s1RhF3UBp/Q30MXvZHUvbu
    >

    heDaqnYoKzTor9GlbGvyoVtWjgaAiSXNNZx63uO9Jrf8fG97KdICz2yD93SsjORh
    >

    uLOW4BGty31IHcomho/3hdY5joHeAzh9/87lpA/kR3bgnEWq8NV6J5XEuXZ1WvzH
    >

    1TOIsPkEOEMlbNZJB0XvuTGCut2k93WE4UwjG+V3ggDplCPNt/SxdHE9IBtydY19
    >

    sqX93lTBBdCqq1hkKqREEp8eveidZls9Ca3+zHUvNJT8+G8UXN8Z8c1IQPZdJDer
    > wWSi0CoxudQS6WO+yium
    > =NQuK
    > -----END PGP SIGNATURE-----



  4. #4
    upscope NNTP User

    Default Re: phpMyadmin will not connect to MySQl.

    <snip>
    ab@novell.com wrote:

    > -----BEGIN PGP SIGNED MESSAGE-----
    > Hash: SHA1
    >
    > What error(s) do you get? Anything show up in /var/log/apache2/error_log
    > that is relevant?
    >
    > Good luck.
    >

    </snip>
    Problem solved. I must have missed any document that mentioned moving
    config.inc.php from /srv/www/htdocs/phpMyAdmin to /etc/phpMyAdmin.I have
    most just taken the version that I had on old release and copied it to
    /srv/www/htdocs/phpMyAdmin.

    Thanks for your help, got me started in right direction.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •