Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Virtualbox troubles

  1. #1

    Default Virtualbox troubles

    I tried installed Virtualbox but when I click on the icon "Oracle VM Virtualbox" it acts like its loading then the window in the task bar disappears and nothing happens, there were no errors on the install mind you.

    Any thoughts???

  2. #2

    Default Re: Virtualbox troubles

    Hi and welcome to the forums. First, a couple of questions: what version of openSUSE do you have? The live disks of 11.3 have the OSE version of Virtualbox already installed. Secondly, which version of Virtualbox did you try to install?
    I'm confused...No, wait...Maybe I'm not...

  3. #3

    Default Re: Virtualbox troubles

    I have this issue too. I installed version 3.2.6 r63112 directly from the Virtual Box site.

    By running "VirtualBox" in a command line I get permission denied error. Turns out for some reason virtual box is forgetting its execute permissions. This also applies VBoxHeadless.

    Executing "sudo chmod +x /usr/lib/virtualbox/VirtualBox" fixes it for a short time (you can run this on on VBoxHeadless too, but you shouldn't need that if you are not running headless VMs).

    I don't have a reason for why this is happening, nor do I know why it forgets the execute permissions regularly (I seem to have run this _every_ time I want to run VirtualBox or VBoxHeadless so something is resetting the execute permissions).

  4. #4

    Default Re: Virtualbox troubles

    Did you remember to add yourself to the Virtualbox group?
    I'm confused...No, wait...Maybe I'm not...

  5. #5

    Default Re: Virtualbox troubles

    Yes. And the installer does it automatically as well. The problem is it keeps dropping the permissions.

  6. #6

    Default Re: Virtualbox troubles

    I thought the installer only created the group, not added you to it...I could be wrong, but this is from the online Virtualbox manual:

    The group vboxusers will be created during installation. Note that a user who is going to run VirtualBox must be member of that group. A user can be made member of the group vboxusers through the GUI user/group management or at the command line with

    sudo usermod -a -G vboxusers username

    Also note that adding an active user to that group will require that user to log out and back in again. This should be done manually after successful installation of the package.
    You can add yourself to the Virtualbox group in YaST->Security and Users->User and Group Management. Select Edit, then look in the Details tab. If there's an X near the vboxusers group, then there's no loss but a few moments of your time. If there isn't, hopefully that will fix the issue.
    I'm confused...No, wait...Maybe I'm not...

  7. #7
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: Virtualbox troubles

    I've *never* had the installer add me (my user) the the vboxusers group. I always had to do it myself, and I've been installing it for over a year now on many different machines. Better double check your membership in the vboxusers group because that is the exact symptom of not being a member of it. You have to use the YaST "Security and Users" function on your username to obtain this membership correctly. (or else if you're a command-line guru, there may be a way to do it, not sure...)

    Patti

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Virtualbox troubles

    Quote Originally Posted by Superfuzz View Post
    Yes. And the installer does it automatically as well. The problem is it keeps dropping the permissions.
    The VBox binaries (VirtualBox, VBoxHeadless, and a few others) in /usr/lib/virtualbox should be owned by root:virtualbox and setuid owner (root). If you find the permissions are being reset, check /etc/permissions.*. Depending on the level of security you have chosen: easy, secure or paranoid, openSUSE may be resetting the permissions at startup because of your chosen security level and you have to edit the appropriate file to tell it that it's ok for these binaries to be setuid root.

  9. #9

    Default Re: Virtualbox troubles

    Interesting. I have been using VirtualBox for several years now and I have never had to manually add my users to the vboxusers group. Although in the latest version I do confirm what you all are saying, my user was not in the vboxusers group.

    Quote Originally Posted by ken_yap View Post
    The VBox binaries (VirtualBox, VBoxHeadless, and a few others) in /usr/lib/virtualbox should be owned by root:virtualbox and setuid owner (root). If you find the permissions are being reset, check /etc/permissions.*. Depending on the level of security you have chosen: easy, secure or paranoid, openSUSE may be resetting the permissions at startup because of your chosen security level and you have to edit the appropriate file to tell it that it's ok for these binaries to be setuid root.
    That seems like a good explanation for permissions being reset. This one was bothering me a bit, I don't like it when my software changes its setting without my permission. I was unaware of this feature in opensuse. Thanks.

  10. #10
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: Virtualbox troubles

    Upon a first install in an OpenSuSE x86_64 system (at least from 11.1 - 11.3 in my experience), the vboxusers group gets created and nobody seems to be added to it. Once you add yourself, then you seem to stay added through upgrades of virtualbox. I think you're right, before a year or two ago, you never had to add yourself. I had trouble figuring that out about a year or so ago.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •