Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Continuous short term hanging w/ multicore + KDE

  1. #1

    Default Continuous short term hanging w/ multicore + KDE

    Hello,

    I'm wondering if anyone is having a similar issue to what I'm experiencing. openSuSE 11.2 was very fast on my system. Since installing openSuSE 11.3, I've been experiencing many short term hangs where I'll lose control of the mouse for a few seconds (usually about 2-5) and the system will do nothing. I don't have unusual load during these time periods and I don't really see any spikes during these periods. If I leave a cpu monitor active, I can see a very very light spike one core0 when it happens, but the mouse and keyboard (and seemingly the whole desktop) hang during this spike so I can't see what's causing it, if that's really the culprit.

    I am almost suspecting that I'm experiencing an issue with interrupts... since it seems that everything is hanging for a few seconds, then coming back to life. It does seem to happen more often when I'm resizing or minimizing windows... but that's about all I can say as it also seems pretty random.

    Here's some basic info on my hardware:
    ASUS M3A78 Pro motherboard
    AMD Phenom(tm) 9950 Quad-Core Processor
    GeForce GTX 260
    G15 Keyboard and MX revolution mouse (just in case USB interrupts turn out to be the issue)

    So, is anyone else experiencing a similar issue? Maybe we can narrow down what we have in common. Oh, I'm running x86_64.

  2. #2
    Join Date
    Apr 2010
    Location
    i am location
    Posts
    1,421

    Default Re: Continuous short term hanging w/ multicore + KDE

    No, my mouse is fine, but my keyboard is gone.
    At one point, not sure if there is a pattern, everything freezes up and the only thing i can do is move my mouse and press reset.

    Running KDE (pure) and 11.3 64bit.
    +++ ATH0

    . . . . . . . .
    LOGOFF COMPLETE

  3. #3

    Default Re: Continuous short term hanging w/ multicore + KDE

    I have an intel quad core and I experience the following
    1) keyboard hangs
    2) mouse hangs
    3) screen goes black (Switch monitor off then on then it shows no video input)

    Yet the file sharing under Samba and DHCP all work fine.

    I just cannot work on the keyboard or mouse. Even toggling num-lock does not work - status light on keyboard doesnot switch on/off. It is as though video, mouse and keyboard have been disconnected.

    I have a standard 11.3 64bit installation, running DHCP and Samba. Desktop is KDE 4.4 as shipped on DVD

    I have no screen savers running - thought this was the problem initially. "Apply automatically" has been deselected

    The system runs fine but usually hangs up over night.

    When I power the system down and then start it up again all is fine.

    I seem to have a similar problem on the 32bit version of 11.3

  4. #4

    Default Re: Continuous short term hanging w/ multicore + KDE

    I have the exact same problem, exact same symptoms, as the OP. I'm running 11.3 with all up-to-date packages and I think it might be related to nvidia drivers, since we seem to have that in common, and I never notice lock ups when X is not running.

    Any ideas?

  5. #5
    Join Date
    Jan 2010
    Location
    Canada
    Posts
    33

    Default Re: Continuous short term hanging w/ multicore + KDE

    Same symptoms (mouse freezes for 2 seconds) on my laptop on both KDE 4.4.4 and 4.5. I have disabled desktop effects and that seems to have made a noticeable difference.
    Desktop- AMD Phenom II X4 810 8GB RAM Radeon HD 4790 openSUSE 11.2 x86_64 KDE 4.3.5
    Laptop - Intel 2.27GHz Core i5 M430 6 GB RAM nVidia GeForce 310M openSUSE 11.3 x86_64 KDE 4.5.2

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: Continuous short term hanging w/ multicore + KDE

    Disable desktop effects in KDE and it should be OK.
    Gnome was/is OK for me though with effects.
    I didn't try switching KDE to Compiz instead of kwin
    This is only a problem with my main box that has nvidia driver.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jul 2010
    Location
    Aschaffenburg
    Posts
    166

    Default AW: Re: Continuous short term hanging w/ multicore + KDE

    stop monitoring gpu temperature (gkrellm, nvdock, nvidia-settings for example ..) and the nvidia system works very well.
    Desktop effects are not the reason for the freezes.

  8. #8
    Join Date
    Jan 2010
    Location
    Canada
    Posts
    33

    Default Re: Continuous short term hanging w/ multicore + KDE

    Currently not monitoring anything regarding the Nvidia gpu.

    All I know is after switching off desktop effects I don't receive the 2-3 second delay.
    Desktop- AMD Phenom II X4 810 8GB RAM Radeon HD 4790 openSUSE 11.2 x86_64 KDE 4.3.5
    Laptop - Intel 2.27GHz Core i5 M430 6 GB RAM nVidia GeForce 310M openSUSE 11.3 x86_64 KDE 4.5.2

  9. #9
    Join Date
    Jul 2010
    Location
    Aschaffenburg
    Posts
    166

    Default AW: Re: Continuous short term hanging w/ multicore + KDE

    shure not running nvidia-settings in background?

    ~/.config/autostart/nvidia-settings.desktop

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: AW: Re: Continuous short term hanging w/ multicore + KDE

    Quote Originally Posted by kaiserhg View Post
    shure not running nvidia-settings in background?

    ~/.config/autostart/nvidia-settings.desktop
    No. LOL

    I just switched to Gnome on my box, which the 'Mrs' uses mostly. I run from a Laptop mostly and work to my box via ssh.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •