Results 1 to 6 of 6

Thread: [opensuse 11.3] firefox 3.6.7 not start

Hybrid View

  1. #1

    Default [opensuse 11.3] firefox 3.6.7 not start

    After upgrade opensuse from 11.2 to 11.3 a cannot use firefox. I start firefox form shell and nothing. When I use strace then firefox stop on "waitpid(-1, ". Firefox work well only when i login as a root. I removed java sun plugin and started firefox in save-mode and check to disable all extensions etc and nothing to do. Any suggestion?

  2. #2

    Default Re: [opensuse 11.3] firefox 3.6.7 not start

    I don't have much to add, other than that I'm seeing the same behavior. I believe the "waitpid(-1," is waiting on the process that the firefox.sh script launches, which is actually /usr/lib/firefox/firefox. When I strace that process by itself, I get a little more info:

    strace /usr/lib/firefox/firefox:


    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb3c00000
    _llseek(40, 0, 0xbfb1da00, SEEK_CUR) = -1 ESPIPE (Illegal seek)
    fcntl64(43, F_GETFL) = 0x1 (flags O_WRONLY)
    fstat64(43, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb1503000
    _llseek(43, 0, 0xbfb1da00, SEEK_CUR) = -1 ESPIPE (Illegal seek)
    read(40, "/system/proxy/mode\tnone\n", 4096) = 24
    read(40, "/system/http_proxy/use_authentic"..., 4096) = 44
    read(40, "/system/http_proxy/authenticatio"..., 4096) = 44
    read(40, "/system/http_proxy/authenticatio"..., 4096) = 40
    read(40, "/system/proxy/autoconfig_url\t\n", 4096) = 30
    read(40, "/system/http_proxy/ignore_hosts\t"..., 4096) = 69
    read(40, "/system/http_proxy/port\t8118\n", 4096) = 29
    read(40, "/system/proxy/ftp_host\t\n", 4096) = 24
    read(40, "/system/proxy/ftp_port\t0\n", 4096) = 25
    read(40, "/system/proxy/secure_host\t\n", 4096) = 27
    read(40, "/system/proxy/secure_port\t0\n", 4096) = 28
    read(40, "/system/proxy/socks_host\t\n", 4096) = 26
    read(40, "/system/proxy/socks_port\t8080\n", 4096) = 30
    read(40, "/system/http_proxy/use_same_prox"..., 4096) = 39
    read(40,


    Still looking...

  3. #3

    Default Re: [opensuse 11.3] firefox 3.6.7 not start

    FIXED:

    I removed the package libproxy1-config-gnome as root ("rpm -e libproxy1-config-gnome"), and firefox now launches.

    Obviously this is a short term workaround, but hopefully it helps.

    Justin

  4. #4

    Default Re: [opensuse 11.3] firefox 3.6.7 not start

    I compiled the latest libproxy1-config-gnome from source and the problem doesn't seem to exist in the latest svn version.

  5. #5

    Default Re: [opensuse 11.3] firefox 3.6.7 not start

    Having a similar issue since my in-place upgrade from 11.2 to 11.3 on Wednesday. I don't have a libproxy1-config-gnome package, probably because I installed only KDE. Upgrading to Firefox 3.6.8 did not fix the issue, but I've noticed that if I pull up KRunner and run "firefox -safe-mode" it comes right up; I can then close Firefox and it will open again normally as long as I do it soon after. If I close the browser for more than a few seconds, though, then I'm back to square one.

    <MR>

  6. #6

    Default Re: [opensuse 11.3] firefox 3.6.7 not start

    I'm facing this issue as well, when I'm trying to connect to my high speed Internet modem via wvdial.Konqueror works but firefox doesn't seem to pick up the proxy settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •