Results 1 to 6 of 6

Thread: How to force OpenOffice to use GTK theme under KDE?

  1. #1

    Default How to force OpenOffice to use GTK theme under KDE?

    Hi,

    I am using openSUSE 11.3 with KDE. I use the regular Oxygen KDE theme for KDE apps. However, Oxygen looks awful on GTK apps, so I have set the GTK theme to Industrial in the KDE control center for GTK apps. Now, apps like Gimp and Firefox look fine with the Industrial theme under KDE. But OpenOffice refuses to change. It still uses the Oxygen theme, which looks terrible on OpenOffice. I tried removing the OpenOffice KDE integration package and installing the Gnome integration package, but it makes no difference. In Debian I always just removed the KDE integration packages and installed the -gtk integration package, and it was that simple. Any suggestions?
    Thanks!

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: How to force OpenOffice to use GTK theme under KDE?

    I can find that there are four icon themes loaded into the program which can be selected through the tools / options / view / icon size & style option. But I don't see any other control that you have over just OpenOffice. Perhaps some one else can tell us more.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: How to force OpenOffice to use GTK theme under KDE?

    Hmmm, thanks for the reply. It's not just an icon theme problem, it's the way the widgets are rendered by the GTK engine that tries to emulate the KDE theme. It's really bad. There are no settings in OpenOffice itself for the widget controls styles.

    Any ideas?

  4. #4

    Default Re: How to force OpenOffice to use GTK theme under KDE?

    I have the following set in my ~/.profile that should take care of it:

    export OOO_FORCE_DESKTOP=gnome

    Hope this helps.

  5. #5

    Default Re: How to force OpenOffice to use GTK theme under KDE?

    Quote Originally Posted by SeanCHill View Post
    I have the following set in my ~/.profile that should take care of it:

    export OOO_FORCE_DESKTOP=gnome

    Hope this helps.
    Thank you kindly! This is the solution. What a relief. I spend most of the day in OpenOffice, so this is of major importance to me.

    Have a good one!

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How to force OpenOffice to use GTK theme under KDE?

    export OOO_FORCE_DESKTOP=gnome
    Thanks SeanCHill for providing bummmm with the help needed.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •