Results 1 to 9 of 9

Thread: Firefox won't load

  1. #1

    Default Firefox won't load

    Firefox won't load. On clicking the icon in the plasma box the bouncing loading icon appears but after about 30 secs it disappears and nothing further happens.

    I am running Suse 11.1. Not sure of the original version of FF! I have tried deleting it in Yast and reinstalling the latest version with the same result. It certainly used to work but as the machine is primarily a mail server, FF is not used much.

    Any ideas?

  2. #2

    Default Re: Firefox won't load

    Hello rcrosoer,

    Quote Originally Posted by rcrosoer
    Firefox won't load. On clicking the icon in the plasma box the bouncing loading icon appears but after about 30 secs it disappears and nothing further happens.
    Could you post the output of firefox when you run it from terminal?

    Quote Originally Posted by rcrosoer
    I am running Suse 11.1. Not sure of the original version of FF! I have tried deleting it in Yast and reinstalling the latest version with the same result. It certainly used to work but as the machine is primarily a mail server, FF is not used much.
    If you're sure it did work before it's most likely a wrong settings.
    So run this command to rename your .firefox folder:
    Code:
    mv ~/.mozilla/firefox/ ~/.mozilla/firefoxBU/
    Then try to restart firefox.

    In your firefox folder are all your firefox settings and add-ons.
    So if you rename your firefox folder it's just like a fresh install.

    If it didn't work you can get your settings back with this command:
    Code:
    mv ~/.mozilla/firefoxBU/ ~/.mozilla/firefox/
    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3

    Default Re: Firefox won't load

    Quote Originally Posted by Edward_Iii View Post
    Hello rcrosoer,


    Could you post the output of firefox when you run it from terminal?

    Code:
    Couldn't load XPCOM
    I get the same result renaming the firefox folder too.

  4. #4
    Join Date
    Aug 2009
    Location
    Mountain View, CA
    Posts
    204

    Default Re: Firefox won't load

    I think you might need to install XULrunner or some other dependency of firefox related to XPCOM

    Also this page might help you: https://developer.mozilla.org/en/Tro...s_registration

  5. #5

    Default Re: Firefox won't load

    Quote Originally Posted by ash25 View Post
    I think you might need to install XULrunner or some other dependency of firefox related to XPCOM

    Also this page might help you: https://developer.mozilla.org/en/Tro...s_registration
    According to Yast I have xulrunner 1.9.1 loaded,

    The FF is 3.5.10

  6. #6
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Firefox won't load

    Have a look at this thread:
    Upgraded Firefox won't fire up

    The Firefox and openSUSE versions were different, however the error was the same, i.e. "Couldn't load XPCOM." The culprit was the package mozilla-js192 which came from the Packman repo.

  7. #7

    Default Re: Firefox won't load

    Looks similar but this is a 32 bit system and I don't have the mozilla-js192 package. There is no link to libmozjs.so but even when I create one it still doesn't load.

  8. #8

    Default Re: Firefox won't load

    Hello rcrosoer,

    Could you post the output of this command:
    Code:
    ldd -d -r /usr/lib/firefox/firefox
    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  9. #9
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Firefox won't load

    Quote Originally Posted by rcrosoer View Post
    Looks similar but this is a 32 bit system and I don't have the mozilla-js192 package.
    I have 32 bit too and I had the same problem then. In any case, if there is no mozilla-js192, you could still see that there are no Mozilla packages coming from anywhere else (i.e. Packman) than from where your Firefox installs comes (OSS? Mozilla?).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •