Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 11.3 GNOME constantly locks up or automatically logs out

  1. #1

    Exclamation 11.3 GNOME constantly locks up or automatically logs out

    Hello all,

    I'm running 11.3 with GNOME on my Dell Inspiron 1525 with on board Intel video card.
    I had 11.2 64 bit running but did a fresh install of 11.3 with the 32 bit version. When the problems started occurring (locking up, logging out by itself, applications crashing that were fine in 11.2...), I tried reinstalling. When that didn't help I tried the 64 bit 11.3 but the problems keep happening. I can't get any work done.
    I've noticed that these occur while the computer is idle (either screensaver or later after the display has been turned off). I'll come back to my computer and notice that either the computer is locked up (screensaver frozen, audio on a one-second-loop...) and have to restart the computer or I come back to find the login screen waiting for me (and obviously have a new session when I log in).

    Any help would be greatly appreciated...

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    Video card and driver????? Have you installed the proprietary driver for the card???

  3. #3

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    Thanks for your reply.
    My video card is an Intel GM965. I haven't installed any drivers on my own but from what I can gather on Google these should be included in xorg-x11-driver-video (or in the kernel?) or am I way off?

  4. #4
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    199

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    yeah, this is my 1st post here in this forum. I have the similar weird behaviour when I leave the pc idle for few minutes, invoking any keys will return into user login screen . I am using opensuse 11.3 (Gnome), it happened many times since this morning after I am download and install gnome shell, does it related to that? as it never happened before. I disabled the screensaver and power management as I thought they are the culprit behind this.

  5. #5

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    ye i have had the same issue, also upgraded to suse 11.3 32 bit, with gnome gui, i havent had it freeze on me, yet like 80% of the time when i go afk and i come back, the screen is on the login screen, so the xwindows system has obviously restarted itself, im sure its gotta do with the screen saver.

    im gonna disable the screen saver and see what happens then report it here.

    i have a HP nx6310, intel graphics, 2gig's ram, 320 gig seagate hdd.

  6. #6

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    Ok I set the screen saver to "blank" and I haven't had x window reset/crash on me once, its been 2 days now.
    so might even be some kinda opengl prob?

  7. #7
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    I've got an Acer Power series, Intel video, Gnome 2.30, and have had the same thing happen to me. I'm going to disable the screensavers and see if that helps my issue.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  8. #8

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    I turned off the screen saver and have the power management turn off the display after 5 minutes instead. It's been 3 days and I haven't had any lock-ups or log-outs. So I guess it must be the screensaver. Anybody have any ideas on how to fix this?

  9. #9

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    I have the same problem in KDE 4.5, it has to do with KMS(kernel mode setting) in the kernel. The new intel video drivers depend on it. One fix is to tell Xorg to use the intellegacy drivers(older driver version that doesnt dep on KMS) and add a kernel boot option that is "nomodeset" at boot time, or in the menu.lst file to make it perm.

    I did this and it did fix the problem, however, I can not get compiz or kde effects to work for carp. Ive gotten my own xorg.conf file to load the params to xorg, but I cant seem to make the intellegacy drivers work any better. I have to have my rotating cube man.

    Just like you, mine only freezes on screen saver. SO far i have been able to suspend to ram and just let the screen turn off via power management without issue.

    THis will be my fix of choice because other than the SS lockup, the video is impressively smooth and operational using the new KMS dependent intel driver.

    This problem started for me in 11.3 with stock kernal and persists into factory(11.4) using kernel 2.6.34.14-4.

    I have read about others getting lockups at other times, but I would have to say for me it seem as though the SS is misbehaving ?(doesnt matter which one, opengl or not).

  10. #10
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: 11.3 GNOME constantly locks up or automatically logs out

    I'm now running 11.3 64-bit, and have both KDE 4.4 & Gnome 2.30. Video is an integrated Intel 946GZ. My lockup problem seems to have gone away after turning off the screen savers in both KDE and Gnome. The lock up problem only presented in Gnome. The screen saver was annoying in KDE because it was set for five minutes and would not change from that interval no matter what I tried. Turning it off works for me in both desktops, so I'll leave it there . . .
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •