Page 1 of 7 123 ... LastLast
Results 1 to 10 of 61

Thread: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

  1. #1

    Default OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Hi Everyone,

    This problem again for me. Seems to happen with every version! I have the same problem as my last thread. Basically it was solved by removing an IPv6 line from the hosts file or adjusting the vnc configuration to use an IP and not host name. Both of these are not working for me on 11.3. I'm not seeing any errors in log/messages. It just sits there with an X cursor that moves around then times out after around a minute or so. I don't know if there are any other logs that will help.

    To clarify, starting a vncserver from a terminal will work, but the 'Remote administration' vnc with the login screen will produce a fully black screen with an X cursor that updates with my mouse position.

    Please suggest what I can do

  2. #2
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Try disabling desktop effects if you have them on.

  3. #3

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Quote Originally Posted by brucecadieux View Post
    Try disabling desktop effects if you have them on.
    I just disabled them via control panel (I assume this is a system-wide change?) and restarted. Still the same problem.

  4. #4

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Same issue here on two different boxes. I thought it was screen resolution to start, but my last box was setup with 800x600 resolution, which would have resolved that problem. In addition, I didn't even install Desktop Effects (just for testing). Same issue.

  5. #5

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Quote Originally Posted by joharmon View Post
    Same issue here on two different boxes. I thought it was screen resolution to start, but my last box was setup with 800x600 resolution, which would have resolved that problem. In addition, I didn't even install Desktop Effects (just for testing). Same issue.
    I thought it was just me from doing something else. I just reinstalled 11.3 today and again same problem. I spent a couple hours just going around looking for possible solutions, reinstalling, verifying firewall, hosts file, setting a hard IP instead of localhost, verifying policies etc. No luck. That and the fact that Firefox java doesnt work out of the box kinda got to me.

    I'm back to 11.1

  6. #6

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Ah, I think we should be able to figure it out.

    I tried over http on port 5801 and had the exact same issue BTW. Still working with it.

  7. #7

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    I spent time looking for a VNC log but never found one. Is there a log for that particular vnc server? Just having that would be very helpful.

  8. #8

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    I too had the same problem with the black screen and X cursor for the Remote Administration VNC Server. It was cured exactly the same way as per my post for Suse 11.2 here:

    VNC is not working

    See post #62.

    Hope that helps.

  9. #9

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Im having the same problem and still working on it.

    As VNC is running under xinetd you can find logs in /var/log/xinetd.log

    10/7/20@21:59:24: START: vnc1 from=10.8.0.10
    10/7/20@22:01:30: EXIT: vnc1 status=0 duration=126(sec)
    10/7/20@22:01:30: START: vnc1 from=10.8.0.10
    10/7/20@22:01:50: EXIT: vnc1 status=0 duration=20(sec)
    10/7/20@22:12:02: START: vnc2 from=10.8.0.10
    10/7/20@22:12:31: EXIT: vnc2 status=0 duration=29(sec)
    No much info is given, worst is that it seems to be no error, but I only see the black window with the X.
    I installed 11.3 today, clear install from a 11.1 version working without problems.
    Im looking into gdm now, but any help will be appreciated.

  10. #10

    Default Re: OpenSuse 11.3 VNC Black Screen /w Cursor then Timeout

    Quote Originally Posted by jbuchmann View Post
    Im having the same problem and still working on it.

    As VNC is running under xinetd you can find logs in /var/log/xinetd.log

    No much info is given, worst is that it seems to be no error, but I only see the black window with the X.
    I installed 11.3 today, clear install from a 11.1 version working without problems.
    Im looking into gdm now, but any help will be appreciated.
    I had the same in my logs. I do remember now that I stumbled accross that log. Mine would always time out at 126 seconds or something around there (maybe 129 like yours)

Page 1 of 7 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •