Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 57

Thread: Configuring graphics cards in openSUSE 11.3

  1. #21
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,192
    Blog Entries
    1

    Default Re: Configuring graphics cards in openSUSE 11.3

    If you can adjust the desired resolution via the display settings tool, then xrandr will work for you too. Then you can automate as explained in this thread:

    Won't save display settings

  2. #22
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Configuring graphics cards in openSUSE 11.3

    Quote Originally Posted by jpradigan View Post
    Thanks. Unfortunately, the .vmx file already has the following in it:

    svga.vramSize = "13417728"
    svga.maxWidth = "1680"
    svga.maxHeight = "1050"

    They work fine on an 11.2 or earlier guest. Also, I'm able to get the display to use 1680x1050, but only via the KDE display configuration.

    It's only in Xorg that the pitch error shows up.
    What happens if you edit xorg.conf to "comment out" the 1680x1050 modeline? Like this:
    Code:
    #Modeline "1680x1050" 117.69 1680 1776 1952 2224 1050 1051 1054 1080
    Don't change anything else. Save, and then reboot the VM guest 11.3.

    Please try that, then post back with the resulting resolution achieved, with the answer to the following questions.

    At this stage, I'm assuming that the statements in Section "Monitor" (i.e. DisplaySize, HorizSync, VertRefresh) exactly match your monitor's spec. Are they correct?

    Did you have an xorg.conf in VM guest 11.2?

    Did you edit the .vmx with those values, or were they system generated?

    Thanks.

  3. #23

    Default Re: Configuring graphics cards in openSUSE 11.3

    Okay, got it working...

    After going back to my 11.2 VM I realized that I used the wrong .vmx template when I first built the VM. Windows VMs need the svga.* lines present but not Linux VMs. I should have picked up on that when it was first mentioned.

    However, the auto-config in X.org doesn't set it correctly. I was able to copy over the monitor, screen and device sections from the xorg.conf I used in my 11.1 and 11.2 VMs to the appropriate files in /etc/xorg.conf.d.

    But, if I didn't have that it would have been a lot harder due to 11.3 not including sax2. Hope adding that back into the distribution for 11.4 is reconsidered, there are going to be plenty of reasons to use that regardless of how mature the auto-config function becomes.

    Anyway, here's what I'm using in case someone else can benefit from them:

    ######################################
    # /etc/xorg.conf.d/50-device.conf
    ######################################
    Section "Device"
    Identifier "Default Device"
    BoardName "VMWARE0405"
    Driver "vmware"
    VendorName "VMWare Inc"
    EndSection


    ######################################
    # /etc/xorg.conf.d/50-monitor.conf
    ######################################
    Section "Monitor"
    Identifier "Default Monitor"
    HorizSync 1-10000
    VertRefresh 1-10000
    ModelName "LCD"
    VendorName "VMWare"

    # NOTE: I have two VMware setups, server and desktop and each has a different resolution display
    # attached. Also, these modelines come from an xorg.conf that was created via
    # vmware-config-tools.pl, not Sax2.

    # these lines are commented out when using the 1680x1050 display...
    #Option "PreferredMode" "1920x1200"
    #ModeLine "1920x1200" 100 1920 2000 2100 2200 1200 1300 1400 1500

    Option "PreferredMode" "1680x1050"
    ModeLine "1680x1050" 100 1680 1700 1800 1900 1050 1100 1200 1300
    EndSection


    ######################################
    # /etc/xorg.conf.d/50-screen.conf
    ######################################
    Section "Screen"
    Identifier "Default Screen"
    Device "Default Device"
    Monitor "Default Monitor"
    DefaultDepth 24

    SubSection "Display"
    Depth 15
    Modes "1920x1200" "1680x1050"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1920x1200" "1680x1050"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1920x1200" "1680x1050"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1920x1200" "1680x1050"
    EndSubSection
    EndSection

  4. #24
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Configuring graphics cards in openSUSE 11.3

    Thanks for the detailed feedback. I prefer using xorg.conf.d files over the old xorg.conf, to simplify complexity.

  5. #25

    Default Re: Configuring graphics cards in openSUSE 11.3

    Well i just tried to install drivers for NVIDIA GEFORCE GT 320M card. When i was going through the steps mentioned on a website i thought ok finally ill see the 3d-CUBE effect so i add the repository, install the drivers n stuff and all i had to restart, so i did that and guess what i see the splash screen and thats it...goes to a blank screen after that :S any suggestions ! im using the debug mode now PLEASE HELP

  6. #26
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Configuring graphics cards in openSUSE 11.3

    Quote Originally Posted by saeen View Post
    Well i just tried to install drivers for NVIDIA GEFORCE GT 320M card. When i was going through the steps mentioned on a website i thought ok finally ill see the 3d-CUBE effect so i add the repository, install the drivers n stuff and all i had to restart, so i did that and guess what i see the splash screen and thats it...goes to a blank screen after that :S any suggestions ! im using the debug mode now PLEASE HELP
    Before installing the drivers did you follow the recommendation in the openSUSE-11.3 release notes wrt Initializing Graphics with KMS (Kernel Mode Setting) ?

    For example, did you disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. And then reboot your machine ?

  7. #27

    Default Re: Configuring graphics cards in openSUSE 11.3

    Quote Originally Posted by oldcpu View Post
    Before installing the drivers did you follow the recommendation in the openSUSE-11.3 release notes wrt Initializing Graphics with KMS (Kernel Mode Setting) ?

    For example, did you disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. And then reboot your machine ?

    I had no clue there were recommendations...can u please guide me as to how i can roll back this action and start all over again ?
    Thank You

  8. #28
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Configuring graphics cards in openSUSE 11.3

    oldcpu:

    -==Brand-new install of 11.3==-
    I have resolved myself to follow the guidelines at SDB:Configuring graphics cards - openSUSE
    I printed it out and found myself at "3rd thing to try".

    my install did not have a /etc/X11/xorg.conf.install so I moved on to "4th thing to try".
    I did not see an /etc/X11/xorg.conf either.

    Checking /etc/X11/xorg.conf.d/50-device.conf I have this:
    Section "Device"
    Identifier "Default Device"

    #Driver "radeon"

    ## Required magic for radeon/radeonhd drivers; output name
    ## (here: "DVI-0") can be figured out via 'xrandr -q'
    #Option "monitor-DVI-0" "Default Monitor"

    EndSection

    In /etc/X11/xorg.conf.d/50-monitor.conf I have this:
    Section "Monitor"
    Identifier "Default Monitor"

    ## If your monitor doesn't support DDC you may override the
    ## defaults here
    #HorizSync 28-85
    #VertRefresh 50-100

    ## Add your mode lines here, use e.g the cvt tool

    EndSection

    I left that alone since my system is working the way I'd prefer. I have Desktop Effects and 1280x1024@75Hz
    I have an installed kernel version 2.6.34-12-default.
    I was notified of 1 update for SoftwareManagementTool and I ran it.
    I got notified of 93 additional updates.
    That is where I stopped. I know that proceeding with the updates is what kills my Desktop Effects so I came to ask you what I should to do as a precautionary measure
    to "save" my current working setup before applying the 93 updates.
    I checked the kernel version listed in the update and it is 2.6.34.4
    I did NOT check for any video updates in the list.

    I appreciate your time and Thank You for any advice you may have on this issue.

  9. #29
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Configuring graphics cards in openSUSE 11.3

    Quote Originally Posted by Habitual View Post
    oldcpu:

    -==Brand-new install of 11.3==-
    I have resolved myself to follow the guidelines at SDB:Configuring graphics cards - openSUSE
    I printed it out and found myself at "3rd thing to try".

    ........

    I left that alone since my system is working the way I'd prefer. I have Desktop Effects and 1280x1024@75Hz

    I have an installed kernel version 2.6.34-12-default.

    I was notified of 1 update for SoftwareManagementTool and I ran it.
    I got notified of 93 additional updates.

    That is where I stopped. I know that proceeding with the updates is what kills my Desktop Effects so I came to ask you what I should to do as a precautionary measure to "save" my current working setup before applying the 93 updates.

    I checked the kernel version listed in the update and it is 2.6.34.4 I did NOT check for any video updates in the list.

    I appreciate your time and Thank You for any advice you may have on this issue.
    Please, can you explain better why you believe the update will break your Desktop Effects? I note this thread: I have to delete .config just to login? but that appears to be a more basic problem than what you are encountering/are-worried-about now.

    Note the 2.6.34.4 kernel does not appear to be correct. It should be a 2.6.34.7 kernel. That has me puzzled, and makes me wonder if your repositories are bad? Please, provide the output of:
    Code:
    zypper lr -d
    IF you are using the open source radeon driver, then the update should NOT break your special Desktop effects, but I do need to see the output of that zypper command.

    Note I always recommend only 4 enabled repositories, those being OSS, Non-OSS, Update and Packman.

  10. #30
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Configuring graphics cards in openSUSE 11.3

    oldcpu:

    I believe that updating my system breaks Desktop Effects because it has every single time I have done so in the past (5 installs now)

    Here's the output of zypper lr -d

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+--------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    2 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    3 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    4 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    5 | repo-update | openSUSE-11.3-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.3 | These are what was installed by the OS, I didn't touch anything.

    I don't know what driver I "have". This is a stock install.

    I believe my other post at I have to delete .config just to login?
    has all the particulars about my hardware.

    Thank you sir.

Page 3 of 6 FirstFirst 12345 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •