Results 1 to 8 of 8

Thread: BUG - SpiderOak Install issue - openSUSE 11.3

  1. #1
    Join Date
    Dec 2008
    Location
    Philadelphia, PA, USA
    Posts
    108

    Question BUG - SpiderOak Install issue - openSUSE 11.3

    When I try to install SpiderOak from the openSuse 11.3 repository, I get the error
    Code:
    Problem: nothing provides python-zope-interface needed by python-transaction-1.0a1-1.2.i586
    After installing python-zopeinterface from the repository I still get the same error. Below is the snapshot of my console. I feel its a bug and I dont know where to log it other than this forum.

    Code:
    linux-cyfj:/home/anant # zypper install spideroak
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides python-zope-interface needed by python-transaction-1.0a1-1.2.i586
     Solution 1: do not install spideroak-9667-2.1.i586
     Solution 2: break python-transaction by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): c
    Then I installed pythonzomeinterface and tried to install SpiderOak but got the same error

    Code:
    linux-cyfj:/home/anant # zypper search python-zope
    Loading repository data...
    Reading installed packages...
    
    S | Name                 | Summary                                     | Type   
    --+----------------------+---------------------------------------------+--------
      | python-zope-event    | Very basic event publishing system          | package
      | python-zope-proxy    | Generic Transparent Proxies                 | package
      | python-zopeinterface | Python library for API definitions throug-> | package
    linux-cyfj:/home/anant # zypper install python-zopeinterface
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      python-zopeinterface 
    
    1 new package to install.
    Overall download size: 114.0 KiB. After the operation, additional 663.0 KiB 
    will be used.
    Continue? [y/n/?] (y): y
    Retrieving package python-zopeinterface-3.3.0-112.1.i586 (1/1), 114.0 KiB (663.0 KiB unpacked)
    Retrieving: python-zopeinterface-3.3.0-112.1.i586.rpm [done]
    Installing: python-zopeinterface-3.3.0-112.1 [done]
    linux-cyfj:/home/anant # zypper install spideroak
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides python-zope-interface needed by python-transaction-1.0a1-1.2.i586
     Solution 1: do not install spideroak-9667-2.1.i586
     Solution 2: break python-transaction by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    [/CODE]

  2. #2

    Default Re: BUG - SpiderOak Install issue - openSUSE 11.3

    it's actually called python-zopeinterface in the repositories so if you install it SpiderOak should install and run, may need install with --nodeps (or what ever zypper option is equivalent).

    Definitely a bug
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,571
    Blog Entries
    15

    Default Re: BUG - SpiderOak Install issue - openSUSE 11.3

    Quote Originally Posted by google01103
    it's actually called python-zopeinterface in the repositories so if you
    install it SpiderOak should install and run, may need install with
    --nodeps (or what ever zypper option is equivalent).

    Definitely a bug

    Hi
    It's a known bug https://bugzilla.novell.com/show_bug.cgi?id=621581

    Unless you know exactly what is going to happen installing with nodeps
    I would not recommend that at all, unless you want a borked system....

    Be patient and wait for the fix to appear.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.13-0.4-default
    up 1 day 16:54, 2 users, load average: 0.08, 0.08, 0.02
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35


  4. #4
    Join Date
    Dec 2008
    Location
    Philadelphia, PA, USA
    Posts
    108

    Default Re: BUG - SpiderOak Install issue - openSUSE 11.3

    Thanks Malcolm, I would rather wait then doing something stupid and mess the system. Where can I log the bugs? I know I can log bugs for SUSE linux Enterprise in the bugzilla.novell.com but what about openSUSE 11.3?

  5. #5

    Default Re: BUG - SpiderOak Install issue - openSUSE 11.3

    apologies - my bad
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,571
    Blog Entries
    15

    Default Re: BUG - SpiderOak Install issue - openSUSE 11.3

    Quote Originally Posted by anantg
    Thanks Malcolm, I would rather wait then doing something stupid and mess
    the system. Where can I log the bugs? I know I can log bugs for SUSE
    linux Enterprise in the bugzilla.novell.com but what about openSUSE
    11.3?

    Hi
    The same place, just follow this link
    http://en.opensuse.org/openSUSE:Submitting_bug_reports

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.13-0.4-default
    up 1 day 19:23, 2 users, load average: 0.07, 0.04, 0.01
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35


  7. #7
    Join Date
    Dec 2008
    Location
    Philadelphia, PA, USA
    Posts
    108

    Default Re: BUG - SpiderOak Install issue - openSUSE 11.3

    Thanks buddy

  8. #8

    Default Re: BUG - SpiderOak Install issue - openSUSE 11.3

    I just downloaded the rpm from the SpiderOak website and it worked fine. I think you can do that if you don't want to wait til it is fixed. I found it funny that SpiderOak is included as one of the features of openSUSE 11.3 when I couldn't even install it.

    Joon

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •