Results 1 to 8 of 8

Thread: Cannot update to KDE4.5

  1. #1
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Cannot update to KDE4.5

    Don't know what happens, but I cannot update to KDE4.5
    Neither zypper nor yast seem to see what is in that repo, even with higher priority.
    Code:
    root# user> zypper up -r KDE4.5 -D
    
    Nothing to do.
    Code:
    root# zypper if -r KDE4.5 kdebase4
    
    
    Information for package kdebase4:
    
    Repository: @System
    Name: kdebase4
    Version: 4.4.4-1.5
    Arch: i586
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 480.0 KiB
    Summary: The Base KDE Apps
    Description: 
    This package contains the basic applications for a K Desktop
    Environment workspace.
    Another piece of info
    Code:
    root# zypper lr -p -u
    #  | Alias                               | Name                                                | Enabled | Refresh | Priority | URI                                                                                                        
    ---+-------------------------------------+-----------------------------------------------------+---------+---------+----------+----------------------------------------------------------------------------------------------------------  
    1  | CD_Local_iso_-_11-3_-_Non_OSS       | CD Local iso - 11-3 - Non OSS                       | No      | No      |   99     | iso:///?iso=openSUSE-11.3-Addon-NonOss-BiArch-i586-x86_64.iso&url=file:///Multimedia/                      
    2  | DVD_Local_iso_11.3                  | DVD Local iso 11.3                                  | No      | No      |   99     | iso:///?iso=openSUSE-11.3-DVD-i586.iso&url=file:///Multimedia/                                             
    3  | KDE-Extra                           | KDE-Extra                                           | Yes     | Yes     |   99     | http://download.opensuse.org/repositories/KDE%3a/Extra/openSUSE_11.3_KDE_Distro_Factory/                 
    4  | KDE4.5_1                            | KDE4.5                                              | Yes     | Yes     |   92     | http://download.opensuse.org/repositories/KDE%3a/Distro%3a/Factory/openSUSE_11.3/                        
    5  | Playground                          | Playground                                          | Yes     | Yes     |   99     | http://download.opensuse.org/repositories/KDE%3a/Unstable%3a/Playground/openSUSE_11.3_KDE_Distro_Factory/
    6  | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82                 | Yes     | Yes     |   99     | http://download.opensuse.org/update/11.3/                                                                
    7  | download.opensuse.org-2.30          | openSUSE BuildService - GNOME:STABLE:2.30           | No      | Yes     |   99     | http://download.opensuse.org/repositories/GNOME:/STABLE:/2.30/openSUSE_11.3/                             
    8  | download.opensuse.org-Apps          | openSUSE BuildService - GNOME:Apps                  | No      | Yes     |   99     | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_11.3/                                     
    9  | download.opensuse.org-STABLE        | openSUSE BuildService - OpenOffice.org              | No      | Yes     |   99     | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.3/                          
    10 | download.opensuse.org-UpdatedApps   | openSUSE BuildService - KDE:UpdatedApps             | No      | Yes     |   99     | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.3/                                
    11 | download.opensuse.org-VirtualBox    | openSUSE BuildService - Virtualization (VirtualBox) | No      | Yes     |   99     | http://download.opensuse.org/repositories/Virtualization:/VirtualBox/openSUSE_11.3/                      
    12 | download.opensuse.org-mozilla       | openSUSE BuildService - Mozilla                     | No      | Yes     |   99     | http://download.opensuse.org/repositories/mozilla/openSUSE_11.3/                                         
    13 | download.videolan.org-SuSE          | VideoLan Repository                                 | No      | Yes     |   99     | http://download.videolan.org/pub/videolan/vlc/SuSE/11.3/                                                 
    14 | openSUSE-11.3 11.3-1.82             | openSUSE-11.3 11.3-1.82                             | No      | No      |   99     | cd:///?devices=/dev/sr0                                                                                  
    15 | packman.inode.at-suse               | Packman Repository                                  | Yes     | Yes     |   99     | http://packman.inode.at/suse/11.3/                                                                       
    16 | repo-debug                          | openSUSE-11.3-Debug                                 | No      | Yes     |   99     | http://download.opensuse.org/debug/distribution/11.3/repo/oss/                                           
    17 | repo-non-oss                        | openSUSE-11.3-Non-Oss                               | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/11.3/repo/non-oss/                                             
    18 | repo-oss                            | openSUSE-11.3-Oss                                   | No      | Yes     |   99     | http://download.opensuse.org/distribution/11.3/repo/oss/                                                 
    19 | repo-source                         | openSUSE-11.3-Source                                | No      | Yes     |   99     | http://download.opensuse.org/source/distribution/11.3/repo/oss/
    Can anybody help me please? It should be very easy, but...

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Cannot update to KDE4.5

    zypper dup -r 4

    should do it
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Cannot update to KDE4.5

    Quote Originally Posted by caf4926 View Post
    zypper dup -r 4

    should do it
    Great! It worked. Thanks.
    Just a small question if you don't mind: why

    zypper dup -r 4

    better than

    zypper up -r 4 (I had already done this without success)
    Last edited by wrbbt; 11-Aug-2010 at 04:14. Reason: just to complete

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Cannot update to KDE4.5

    up and dup are very different

    dup= distribution upgrade
    It switches all the packages to the repo you specify in this case.
    Similar to this, which you can also do: ImageBam - Fast, Free Image Hosting and Photo Sharing

    You may need to manually switch kaffeine back to packman with the radio switcher:
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    (that shows k3b but you get the idea)

    Read more about zypper here:
    SDBypper usage - openSUSE
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: Cannot update to KDE4.5

    You tried 'zypper dup'??

  6. #6
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Cannot update to KDE4.5

    @wrbbt, your list of repos show that the one for 11,3-oss is disabled. Is that really what you want?

  7. #7
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Cannot update to KDE4.5

    Replies:

    To caf4926.: Thanks a lot. I have always used yast for software management; I'm beginning to use zypper. Your information was very useful.

    To Fruchtratte: No. I preferred not to update everything in that moment, just one repo. Maybe what you say would be better, but as I say to caf4926, I had very little experience with zypper.

    To pilotgi: Not really. In fact, I enabled it before doing what caf4926 suggested. I had disabled it before just to see if the KDE4.5 repo got the priority. I understand that the oss repo should be always enabled.

    Thanks to all of you for your help.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Cannot update to KDE4.5

    Adjusting priority is really not necessary since 11.2
    All mine are 99
    I just use the switcher - carefully, to get what I want.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •