Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Skype errors with 11.3

  1. #1

    Default Skype errors with 11.3

    Anyone else having problems installing Skype beta (direct from Skype) on 11.3 x86_64?
    Error is:
    Code:
      skype: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv
    I've been through the forums and Google and made sure I have all the 32-bit libs required by skype. For example:
    Code:
    6930p:~ # rpm -qa | grep -i libqt4
      libqt4-32bit-4.6.3-125.1.x86_64
      libqt4-qt3support-4.6.3-125.1.x86_64
      libqt4-sql-sqlite-4.6.3-125.1.x86_64
      libqt4-sql-mysql-32bit-4.6.3-127.1.x86_64
      libqt4-x11-32bit-4.6.3-125.1.x86_64
      libqt4-sql-sqlite-32bit-4.6.3-125.1.x86_64
      libqt4-sql-4.6.3-125.1.x86_64
      libqt4-4.6.3-125.1.x86_64
      libqt4-sql-mysql-4.6.3-127.1.x86_64
      libqt4-qt3support-32bit-4.6.3-125.1.x86_64
      libqt4-sql-32bit-4.6.3-125.1.x86_64
      libqt4-x11-4.6.3-125.1.x86_64
    Others on the net had issues with references to nessus libs in the ld.conf file. I don't have nessus installed here.
    Code:
    6930p:~ # cat /etc/ld.so.conf
      /usr/X11R6/lib64/Xaw3d
      /usr/X11R6/lib64
      /usr/lib64/Xaw3d
      /usr/X11R6/lib/Xaw3d
      /usr/X11R6/lib
      /usr/lib/Xaw3d
      /usr/x86_64-suse-linux/lib
      /usr/local/lib
      /opt/kde3/lib
      /lib64
      /lib
      /usr/lib64
      /usr/lib
      /usr/local/lib64
      /opt/kde3/lib64
      include /etc/ld.so.conf.d/*.conf
    Can anyone offer any suggestions or hints? Please.
    And thank you.


    --
    chris

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype errors with 11.3

    What does

    ldd `which skype`

    return? Any missing libraries? I suspect not. I suspect Skype was built against an older release of libQt. Until they release an updated version of Skype that will work with 11.3, you may have to use the static version from Skype.

  3. #3

    Default Re: Skype errors with 11.3

    ldd says:
    Code:
    6930p:~ # ldd `which skype`
      linux-gate.so.1 =>  (0xffffe000)
      libasound.so.2 => /usr/lib/libasound.so.2 (0xf75ea000)
      libXv.so.1 => /usr/lib/libXv.so.1 (0xf75e4000)
      libXss.so.1 => /usr/lib/libXss.so.1 (0xf75e0000)
      libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0xf7568000)
      libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xf7521000)
      libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xf74de000)
      libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0xf6bfb000)
      libpng12.so.0 => /usr/lib/libpng12.so.0 (0xf6bd0000)
      libSM.so.6 => /usr/lib/libSM.so.6 (0xf6bc7000)
      libICE.so.6 => /usr/lib/libICE.so.6 (0xf6bac000)
      libXi.so.6 => /usr/lib/libXi.so.6 (0xf6b9b000)
      libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf6b90000)
      libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf6b87000)
      libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf6b81000)
      libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf6b75000)
      libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf6b70000)
      libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf6ae9000)
      libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf6ab3000)
      libXext.so.6 => /usr/lib/libXext.so.6 (0xf6aa1000)
      libX11.so.6 => /usr/lib/libX11.so.6 (0xf6966000)
      libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xf6846000)
      libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0xf6620000)
      libz.so.1 => /lib/libz.so.1 (0xf660c000)
      libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xf6606000)
      librt.so.1 => /lib/librt.so.1 (0xf65fc000)
      libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf6516000)
      libdl.so.2 => /lib/libdl.so.2 (0xf6511000)
      libpthread.so.0 => /lib/libpthread.so.0 (0xf64f5000)
      libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf6405000)
      libm.so.6 => /lib/libm.so.6 (0xf63db000)
      libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf63bd000)
      libc.so.6 => /lib/libc.so.6 (0xf6252000)
      libuuid.so.1 => /lib/libuuid.so.1 (0xf624b000)
      libexpat.so.1 => /lib/libexpat.so.1 (0xf6221000)
      libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf6201000)
      /lib/ld-linux.so.2 (0xf76e6000)
      libpcre.so.0 => /lib/libpcre.so.0 (0xf61d2000)
      libXau.so.6 => /usr/lib/libXau.so.6 (0xf61cd000)

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype errors with 11.3

    Report the problem to Skype.com so that they can start building a new version suitable for 11.3.

  5. #5

    Default Re: Skype errors with 11.3

    I have problem on 11.3 x86_64 with Skype untill I installed libpng12-0-32bit

  6. #6

    Default Re: Skype errors with 11.3

    Quote Originally Posted by vlk3259 View Post
    I have problem on 11.3 x86_64 with Skype untill I installed libpng12-0-32bit
    Thanks for the post. Skype was not working for me, either, until I installed that same file.

  7. #7
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Skype errors with 11.3

    The problem is you need qt4 32bit.
    libqt4-32bit
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype errors with 11.3

    Quote Originally Posted by cshanahan View Post
    ldd says:
    Code:
    6930p:~ # ldd `which skype`
      linux-gate.so.1 =>  (0xffffe000)
      libasound.so.2 => /usr/lib/libasound.so.2 (0xf75ea000)
      libXv.so.1 => /usr/lib/libXv.so.1 (0xf75e4000)
      libXss.so.1 => /usr/lib/libXss.so.1 (0xf75e0000)
      libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0xf7568000)
      libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xf7521000)
      libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xf74de000)
      libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0xf6bfb000)
      libpng12.so.0 => /usr/lib/libpng12.so.0 (0xf6bd0000)
      libSM.so.6 => /usr/lib/libSM.so.6 (0xf6bc7000)
      libICE.so.6 => /usr/lib/libICE.so.6 (0xf6bac000)
      libXi.so.6 => /usr/lib/libXi.so.6 (0xf6b9b000)
      libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf6b90000)
      libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf6b87000)
      libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf6b81000)
      libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf6b75000)
      libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf6b70000)
      libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf6ae9000)
      libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf6ab3000)
      libXext.so.6 => /usr/lib/libXext.so.6 (0xf6aa1000)
      libX11.so.6 => /usr/lib/libX11.so.6 (0xf6966000)
      libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xf6846000)
      libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0xf6620000)
      libz.so.1 => /lib/libz.so.1 (0xf660c000)
      libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xf6606000)
      librt.so.1 => /lib/librt.so.1 (0xf65fc000)
      libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf6516000)
      libdl.so.2 => /lib/libdl.so.2 (0xf6511000)
      libpthread.so.0 => /lib/libpthread.so.0 (0xf64f5000)
      libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf6405000)
      libm.so.6 => /lib/libm.so.6 (0xf63db000)
      libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf63bd000)
      libc.so.6 => /lib/libc.so.6 (0xf6252000)
      libuuid.so.1 => /lib/libuuid.so.1 (0xf624b000)
      libexpat.so.1 => /lib/libexpat.so.1 (0xf6221000)
      libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf6201000)
      /lib/ld-linux.so.2 (0xf76e6000)
      libpcre.so.0 => /lib/libpcre.so.0 (0xf61d2000)
      libXau.so.6 => /usr/lib/libXau.so.6 (0xf61cd000)
    Whoops, I noticed something. You have your own versions of some Qt libraries in /usr/local/lib. How did this happen? Did you compile Qt yourself? They are causing the mismatch.

  9. #9
    Join Date
    Sep 2008
    Location
    Canada
    Posts
    16

    Default Re: Skype errors with 11.3

    Where can I download the latest skype for 64bit?

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype errors with 11.3

    AFAIK there is no 64-bit version, you have to use Skype's 32-bit version.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •