Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Vmware 7 doesn't install on Opensuse 11.3

  1. #11

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    this shopuld allow you to compile the necessary modules for vmware.
    This does not work

  2. #12

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    Well thats what I did to get it running. If you never built a kernel, you may also be missing /usr/src/linux/include/linux/version.h as well which would also be required, so you may have to symlink this too.

    Note too you must link to the version of your kernel under /usr/src/linux-2.6.34-12-obj/x86_64 which is appropiate.

  3. #13

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    Well thats what I did to get it running. If you never built a kernel, you may also be missing /usr/src/linux/include/linux/version.h as well which would also be required, so you may have to symlink this too.

    Note too you must link to the version of your kernel under /usr/src/linux-2.6.34-12-obj/x86_64 which is appropiate.
    This does not help either :-(

  4. #14

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    You can try running this script, it tries to manually compile the modules, at the very least it wil probably tell you what files it can't find:

    Code:
    cd ~
    rm -rf vmware-modules
    mkdir vmware-modules
    cd vmware-modules
    find /usr/lib/vmware/modules/source -name "*.tar" -exec tar xf '{}' \;
    mkdir -p /lib/modules/`uname -r`/misc
    rm -f /lib/modules/`uname -r`/misc/{vmblock.ko,vmci.ko,vmmon.ko,vmnet.ko,vsock.ko}
    cd vmblock-only; make; cd ..; cp -p vmblock.o /lib/modules/`uname -r`/misc/vmblock.ko
    cd vmci-only; make; cd ..; cp -p vmci.o /lib/modules/`uname -r`/misc/vmci.ko
    cd vmmon-only; make; cd ..; cp -p vmmon.o /lib/modules/`uname -r`/misc/vmmon.ko
    cd vmnet-only; make; cd ..; cp -p vmnet.o /lib/modules/`uname -r`/misc/vmnet.ko
    #cd vmppuser-only; make; cd ..; cp -p vmppuser.o /lib/modules/`uname -r`/misc/vmppuser.ko
    cd vsock-only; make; cd ..; cp -p vsock.o /lib/modules/`uname -r`/misc/vsock.ko
    depmod -a
    service vmware restart
    #If a new install, remove the not_configured tag or the error will keep coming back
    rm -f /etc/vmware/not_configured

  5. #15
    Join Date
    Jul 2008
    Location
    Windhoek, Namibia
    Posts
    36

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    I am in the same boat, try to get VMware Player 3.0 running after updating to opernsuse 11.3

    Code:
    / # service vmware restart
    Stopping VMware services:
       VMware USB Arbitrator                                               done
       VM communication interface socket family                            done
       Virtual machine communication interface                             done
       Virtual machine monitor                                             done
       Blocking file system                                                done
    Starting VMware services:
       VMware USB Arbitrator                                               done
       Virtual machine monitor                                            failed
       Virtual machine communication interface                            failed
       VM communication interface socket family                           failed
       Blocking file system                                               failed
       Virtual ethernet                                                   failed
    if I try to start the machine, I get the message Kernel headers for version 2.6.34-12-default were not found. Browsing to '/usr/src/linux-2.6.34-12' gives the message C header files matching your running kernel were not found ...
    but :
    Code:
    uname -r
    2.6.34-12-default
    I have installed for version 2.6.34-12:
    • kernel-coverage
      kernel-default
      kernel-default-base
      kernel-default-devel
      kernel-desktop-devel
      kernel-devel
      kernel-firmware
      kernel-source
      kernel-syms
      kernel-xen-devel
      kexec-tools


    ????

  6. #16

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    Just for the record, I couldn't get Workstation 7 to install on 11.3 (couldn't find kernel headers), so rather than wrestling with that (again), I just downloaded Workstation 7.1 from the VMWare site and that installed fine.

  7. #17
    Carlos E. R. NNTP User

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    On 2010-07-29 13:36, MrSolar wrote:

    > I am in the same boat, try to get VMware Player 3.0 running after
    > updating to opernsuse 11.3


    Did you look here?

    <http://radu.cotescu.com/2010/01/19/how-to-install-vmware-server-ubuntu-fedora-opensuse/>

    It is about the server version, but you might get ideas.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Elessar))

  8. #18

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    Quote Originally Posted by JJMT View Post
    Just for the record, I couldn't get Workstation 7 to install on 11.3 (couldn't find kernel headers), so rather than wrestling with that (again), I just downloaded Workstation 7.1 from the VMWare site and that installed fine.
    I tried the WS 7.1 on 11.3 and it says it cannot find the headers.

  9. #19
    Join Date
    Jul 2008
    Location
    Windhoek, Namibia
    Posts
    36

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    Thanks Carlos! I am not that knowlegable to modiefy scripts like that!

    btw have solved the problem by throwing out all kernels and VMWare Player, then freshly reinstalled kernel desktop and a newer version of player, now it works beautifully!
    I am actually considering going back to WinXP (in the virtual machine) as I have trouble with ooo now, can't access the fileserver in our small network ... relax guys, was just a joke!
    Thank you!

  10. #20

    Default Re: Vmware 7 doesn't install on Opensuse 11.3

    Quote Originally Posted by silenuz View Post
    You can try running this script, it tries to manually compile the modules, at the very least it wil probably tell you what files it can't find:
    It does not help. The script failed with multiple errors.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •