Results 1 to 9 of 9

Thread: Language Bar

  1. #1
    Join Date
    Aug 2009
    Location
    Russia, Siberia
    Posts
    10

    Question Language Bar

    Hi,

    My nice language bar (the switcher / indicator En->Ru) on the task bar got disappered for an unknown reason and I seem to have no idea how to get it back.
    I'm running OpenSuSE 11.2 and KDE.

    Please, help me.

    Thanks in advance,
    Alpha Sisyphus

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Language Bar

    Hi,

    If I recall, you have to go the system settings of kde->regionals settings->keyboard and you have to active the options to switch beetween language.

  3. #3
    Join Date
    Aug 2009
    Location
    Russia, Siberia
    Posts
    10

    Default Re: Re : Language Bar

    Quote Originally Posted by DaaX View Post
    Hi,

    If I recall, you have to go the system settings of kde->regionals settings->keyboard and you have to active the options to switch beetween language.
    I've already done it with no success. Another problem is that I don't see "Language Switcher" widget as well as "Volume Control" in the list of availbale Task Bar widgets. Also notice, that my shortcut to switch between Russian / English works just fine. This is weird. I've updated to OpenSuSE 11.3, but it hasn't solved the problem.

    Wut do? So far, I'm puzzled.

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Language Bar

    Hi,

    The volume control is actually Kmix. Just open the menu launcher and type in kmix and then click on it. It will automatically be added to the system tray.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5
    Join Date
    Aug 2009
    Location
    Russia, Siberia
    Posts
    10

    Default Re: Language Bar

    Quote Originally Posted by ijbreakey View Post
    Hi,

    The volume control is actually Kmix. Just open the menu launcher and type in kmix and then click on it. It will automatically be added to the system tray.

    Take Care,

    Ian
    Thanks Ian,
    Today (oops, yesterday) I upgraded 11.2 to 11.3 and the upgrade was smooth. After that I started to tune the system. Result: I spent about 1 day. Also, I must say that some weird things in this version of KDE just pissed me off. I'm downloading XFce. It's 5:20 MSK, but I'm near with my laptop in order to get thing up and running. I'M VERY VERY ANGRY, LOL

    Regarding the problem with audio mixer I had similar assumptions. Unfortunately, kmix fails to run with the following messages:

    $kmix
    QApplication::qAppName: Please instantiate the QApplication object first
    kdeinit4: preparing to launch /usr/lib64/libkdeinit4_klauncher.so
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kded4.so
    kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kbuildsycoca4.so
    kbuildsycoca4 running...
    kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kconf_update.so
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kglobalaccel.so
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    kglobalaccel(8073) GlobalShortcutsRegistry::loadSettings: Loading group "kmix"
    kglobalaccel(8073) GlobalShortcutsRegistry::registerKey: Registering key "Volume Up" for "kmix" : "increase_volume"
    kglobalaccel(8073) KGlobalAccelImpl::grabKey: grab failed!
    kglobalaccel(8073) GlobalShortcut::setActive: "increase_volume" : Failed to register "Volume Up"
    kglobalaccel(8073) GlobalShortcutsRegistry::registerKey: Registering key "Volume Down" for "kmix" : "decrease_volume"
    kglobalaccel(8073) KGlobalAccelImpl::grabKey: grab failed!
    kglobalaccel(8073) GlobalShortcut::setActive: "decrease_volume" : Failed to register "Volume Down"
    kglobalaccel(8073) GlobalShortcutsRegistry::registerKey: Registering key "Volume Mute" for "kmix" : "mute"
    kglobalaccel(8073) KGlobalAccelImpl::grabKey: grab failed!
    kglobalaccel(8073) GlobalShortcut::setActive: "mute" : Failed to register "Volume Mute"
    QSystemTrayIcon::setVisible: No Icon set
    $QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.8'

  6. #6
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Language Bar

    I don't know, but maybe a fresh ~/.kde4 could help things. It's a suggestion....

  7. #7
    Join Date
    Aug 2009
    Location
    Russia, Siberia
    Posts
    10

    Default Re: Re : Re: Language Bar

    Yup. I cleaned up everything that I think somehow related to KDE in my home folder. Then I started with a "fresh" KDE setup. It looks like I screwed up something with my previous KDE settings.

  8. #8
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Re : Re: Language Bar

    Quote Originally Posted by Alpha_Sisyphus View Post
    Yup. I cleaned up everything that I think somehow related to KDE in my home folder. Then I started with a "fresh" KDE setup. It looks like I screwed up something with my previous KDE settings.
    So does this mean your problem was solved and you just had some borked kde settings? Or is this problem still persistent in 11.3?

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  9. #9

    Default Re: Re : Re: Language Bar

    Quote Originally Posted by ijbreakey View Post
    So does this mean your problem was solved and you just had some borked kde settings? Or is this problem still persistent in 11.3?

    Take Care,

    Ian
    I have this bug very often and now even on system start (previously appeared after some period of work) still: openSUSE 12.1, KDE 4.8.5. Is any solution there?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •