Results 1 to 2 of 2

Thread: Problems after updating suse

  1. #1

    Unhappy Problems after updating suse

    I am newbie to Linux. I have Suse 10.2 Enterprise Desktop Edition installed in my system. I have configured JDK5 and JRE6 along with Jboss5.0 and Eclipse Galileo3.5. I wanted some add ons to be installed on mozilla firefox, but those add ons needed at least 3.5 version of Mozilla. So I updated Suse through YAST-->Install Updates. After this I was able to update the mozilla with the add ons but now I am not able to work in my java environment. I am clueless of what JDK and JRE versions have been updated in the install updates process. Neither my Jboss is starting properly nor the eclipse is working properly. Eclipse is getting closed automatically whenever an internal call is made to java pacakages.

    The error log which I found out in Eclipse is as follows:
    /opt/Eclipse/eclipse/jre/bin/java
    -Dosgi.requiredJavaVersion=1.5
    -XX:MaxPermSize=256m
    -Xms40m
    -Xmx512m
    -jar
    /opt/Eclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
    -data
    /home/ORA-DOM/testing/ambika-WorkSpace_New
    -os
    linux
    -ws
    gtk
    -arch
    x86_64
    -showsplash
    -launcher
    /opt/Eclipse/eclipse/eclipse
    -name
    Eclipse
    --launcher.library
    /opt/Eclipse/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.200.v20090519/eclipse_1206.so
    -startup
    /opt/Eclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
    -exitdata
    378011
    -product
    org.eclipse.epp.package.jee.product
    -vm
    /opt/Eclipse/eclipse/jre/bin/java
    -vmargs
    -Dosgi.requiredJavaVersion=1.5
    -XX:MaxPermSize=256m
    -Xms40m
    -Xmx512m
    -jar
    /opt/Eclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar



    When I tried starting the Jboss server from terminal, it is giving me this error:
    JBoss Bootstrap Environment

    JBOSS_HOME: /home/ORA-DOM/testing/Jboss/jboss-5.0.0.GA

    JAVA: /usr/lib/jvm/jre/bin/java

    JAVA_OPTS: -Dprogram.name=run.sh -server -Xms128m -Xmx512m -XX:MaxPermSize=256m -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true

    CLASSPATH: /home/ORA-DOM/testing/Jboss/jboss-5.0.0.GA/bin/run.jar

    =========================================================================

    Exception in thread "main" java.lang.UnsupportedClassVersionError: org/jboss/Main (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)


    I am clueless to what is going on from past 3 days. Can anybody help me out in this?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Problems after updating suse

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •