Results 1 to 7 of 7

Thread: [KDE4.4.5] "Run command" utility doesn't show buttons

  1. #1
    Join Date
    Sep 2008
    Location
    Israel
    Posts
    34

    Default [KDE4.4.5] "Run command" utility doesn't show buttons

    Hello,

    For some time now, that the "Run command" window (which pops up when clicking alt+F2) doesn't show the 4 buttons, it shows just an empty black rectangle.

    I have another system which is installed with the same kde4.4.5 rpms and I don't have this problem. I went over kde configuration files and can't find the cause.

    Attached is a snapshot or the problem :


    I recently noticed that when pressing alt+tab to scroll between windows,
    only the icon of the window is highlighted when in the 2nd machine there is a bounding box which the surrounds the icon and the text.

    Any help will be appreciated.

    Thank you,
    Sagi.

  2. #2

    Default Re: [KDE4.4.5] "Run command" utility doesn't show buttons

    Hello sagiben,

    First of all you didn't say which version of openSUSE you have.
    Quote Originally Posted by sagiben
    For some time now, that the "Run command" window (which pops up when clicking alt+F2) doesn't show the 4 buttons, it shows just an empty black rectangle.

    I have another system which is installed with the same kde4.4.5 rpms and I don't have this problem. I went over kde configuration files and can't find the cause.
    The most important thing is to remember what you did before it stopped working.
    When I see your screenshot I noticed that you've changed your style.
    Maybe you use a icon set which is missing a few icons.

    I recommend you make a test user.
    Start YaST->Security and Users->User and Group Management.
    Select the tab Users and click on the button add at the bottom of the window.
    Fill in the details and press Ok.
    Now log out and log in as your new user.

    If it works then your normal user has most likely a wrong setting.
    So log-in as your normal user and rename the folder .kde4 to .kde4BU.
    Warning: Don't remove it or you'll lose most of your kde settings.

    Now you have got two options:

    1. Configure/Style everything from scratch.
    2. Copy parts one for one from your backup to your new .kde4 folder.

    I recommend the second one.
    Here's a list of folder you can copy over without any problems:

    • /home/<USER>/.kde4/share/apps/
    • /home/<USER>/.kde4/share/config/colors/
    • /home/<USER>/.kde4/share/config/kresources/
    • /home/<USER>/.kde4/share/config/ (You can copy almost every file from here but I wouldn't copy krunnerrc)

    If you have any questions feel free to ask!

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3
    Join Date
    Sep 2008
    Location
    Israel
    Posts
    34

    Default Re: [KDE4.4.5] "Run command" utility doesn't show buttons

    Hi Edward,

    Yes you are right, I'm using openSuSE 11.2
    I'm also using KDE Factory repositories for opensuse 11.2

    I think that one of the updates caused this problem.
    I thought that I messed up something with my KDE settings so I did exactly what you suggested,
    I logged out from my account and from terminal I moved ~/.kde4 directory to a different location and re-login, but the problem persist.

    I also changed the theme that I usually use to a different one in order to be sure that it is not a theme issue.
    Yesterday I logged in to my machine as root and noticed for the same problem.

    I think that this issue is a system issue and not a user settings issue but in order to be sure I will create a new user.

    Thank you,
    Sagi.

  4. #4

    Default Re: [KDE4.4.5] "Run command" utility doesn't show buttons

    Hello sagiben,

    Quote Originally Posted by sagiben
    I think that one of the updates caused this problem.
    ...
    I think that this issue is a system issue and not a user settings issue but in order to be sure I will create a new user.
    I think you're right that it is a system issue.
    Maybe the updater updated a kde4 package from another repository giving you some mixed up versions.

    Quote Originally Posted by sagiben
    Yesterday I logged in to my machine as root and noticed for the same problem.
    You should never log-in as root in any desktop environment.
    If you do these things can happen:

    1. It makes your system insecure. If for example a bash script is executed without you noticing it then the program could do a lot of harm to your system.
    2. You can easily change file permissions without noticing and the next time you try to log in as a normal user you can't. For example: just browsing in your home directory while logged into KDE/Gnome/etc as root can lock you out later as yourself.

    I hope you understand the risks of logging-in as root in a desktop environment.
    By the way there's no administrative you can't do without a desktop environment.

    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  5. #5
    Join Date
    Sep 2008
    Location
    Israel
    Posts
    34

    Default Re: [KDE4.4.5] "Run command" utility doesn't show buttons

    Hi Edward,

    Quote Originally Posted by Edward_Iii View Post
    You should never log-in as root in any desktop environment.
    I'm aware of the risks of log-in as root to my system.
    The reason that I did it, was because I wanted to check if this problem is only for my user or a system issue.
    Since I've never login as root to my system I assumed that it will be just the same as creating a new user.

    I have another machine installed with openSuSE 11.2 and kde 4.4.5 and I don't experience this problem.
    So currently I started to look for the differences between those 2 systems.

    Thanks,
    Sagi.

  6. #6
    Join Date
    Sep 2008
    Location
    Israel
    Posts
    34

    Default Re: [KDE4.4.5] "Run command" utility doesn't show buttons

    Suggestion ?! someone ??

    I think I'm going to remove all kde rpms and configuration file and then reinstall kde.

    Sagi.

  7. #7

    Default Re: [KDE4.4.5] "Run command" utility doesn't show buttons

    Hello sagiben,

    Quote Originally Posted by sagiben
    Suggestion ?! someone ??

    I think I'm going to remove all kde rpms and configuration file and then reinstall kde.
    I think it's much easier to follow this tutorial: .:. ANL4U .:. LiNuX Addicted Install KDE4.4 in openSUSE 11.2
    In short it's just adding two kde4 repositories and disabling the old ones.
    Then update your kde4 packages to the ones from the new repository.
    Log-out and log-in again. Done!

    I haven't done it myself but it looks simple and it's only 3 steps.

    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •