Results 1 to 8 of 8

Thread: Clock

  1. #1

    Default Clock

    My clock settings are always keeping out of date, how can I fix this bug? Can anyone help me?

    I'm using opensuse 11.2 with Gnome desktop

    Thanks in advance

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Clock

    Are we talking 'Clock' time
    or 'Clock' date?
    Or both?

    How is it out of date? Describe the problem. Do you dual boot with windows?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Clock

    Both time and date keeps getting out of date. Imagine that now is 23:45 and the clock displays a completly different time; I get to update both time and date but some time later the time will just get another time. In other words, no matter how many times I adjust the clock it just gets delayed

    I dont use Windows, only opensuse 11.2

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Clock

    Are you set to use UTC and NTP?
    Yast - system - Date and Time
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Clock

    In case your computer is online: enable ntp. Add two or three time servers. Yast has a function to do this.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  6. #6
    Join Date
    Jun 2010
    Location
    United Kingdom (temporarily)
    Posts
    40

    Default Re: Clock

    Another thing that you might want to check is whether your BIOS/CMOS battery is still ok. This is usually a small Lithium battery that sits on the motherboard. If it is a laptop, then it is more complicated.

  7. #7
    Carlos E. R. NNTP User

    Default Re: Clock

    On Fri, 02 Jul 2010 13:41:44 GMT
    Dr Salgueiro <> wrote:

    >
    > Both time and date keeps getting out of date. Imagine that now is
    > 23:45 and the clock displays a completly different time; I get to
    > update both time and date but some time later the time will just get
    > another time. In other words, no matter how many times I adjust the
    > clock it just gets delayed


    Does this happen when you power off and reboot, or while running
    continuously? Do you hibernate the machine? Suspend to ram?

    Notice that if the system is always on, no suspend or hibernate, and
    the clock goes wrong, ntp will not help you (nor replacing the
    battery) - sorry to contradict others. Wish I were wrong. I believe ntp
    will quit, but learning if it does would be good to know, so try it.
    There are tricks, but I believe it is either a (non solvable) hardware
    problem or a kernel bug.

    > I dont use Windows, only opensuse 11.2


    Good, it is easier to diagnose then. No other linux, just one 11.2
    install?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Minas Tirith))


  8. #8
    Chill Out NNTP User

    Default Re: Clock

    On Fri, 02 Jul 2010 13:41:44 +0000, Dr Salgueiro wrote for a reply:

    > Both time and date keeps getting out of date. Imagine that now is 23:45
    > and the clock displays a completly different time; I get to update both
    > time and date but some time later the time will just get another time.
    > In other words, no matter how many times I adjust the clock it just gets
    > delayed
    >
    > I dont use Windows, only opensuse 11.2
    >
    > Thanks


    I had a problem like this. Turned out to be a mis-match between my
    hardware clock and the NTP timer. Hardware clock is set to my local time
    but the YaST2 System Time (clock, time zone settings) indicated that the
    Hardware clock was set as UTC time. The NTP timer would reset +4 hours
    and all reboots set the Hardware clock to system clock time.

    --
    Chillingout@opensuse.forum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •