Results 1 to 6 of 6

Thread: BRL-CAD

  1. #1

    Default BRL-CAD

    Hi, complete newbie here, just installed opensuse 11.2 with KDE 4.3.5

    Not sure if this is the place to post this, but searching online it seemed like most people with similar problems posted on the forums of whatever Linux distro they were using. Apologies if I'm in the wrong place...

    I'm trying to get BRL-CAD set up, as I need to use CAD/CAE software a lot and would prefer to use open source software as much as possible. I downloaded the binaries (release 7.10.4), extracted them using tar and tried to run the program by cd-ing to the relevant directory in konsole and typing ./mged"

    I get the following error:

    ./mged: error while loading shared libraries: libtermio.so.19: cannot open shared object file: No such file or directory
    libtermio.so.19 is in a "lib" folder. Does anyone have an idea what could be going wrong here, or what I could try to fix it?

    Thank you in advance for your help

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,079

    Default Re: BRL-CAD

    On Tue, 29 Jun 2010 21:46:01 +0000, narcho wrote:

    >> ./mged: error while loading shared libraries: libtermio.so.19: cannot
    >> open shared object file: No such file or directory

    >
    > libtermio.so.19 is in a "lib" folder. Does anyone have an idea what
    > could be going wrong here, or what I could try to fix it?


    Where specifically is it located on your system - and are you running 32-
    bit or 64-bit (both platform and application)?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator

  3. #3

    Default Re: BRL-CAD

    Quote Originally Posted by narcho View Post
    Not sure if this is the place to post this, but searching online it seemed like most people with similar problems posted on the forums of whatever Linux distro they were using. Apologies if I'm in the wrong place...
    Probably more ideal would to file a BRL-CAD support request on their Sourceforge tracker as your question isn't specific to SUSE, but there's lots of helpful people here too.

    Quote Originally Posted by narcho View Post
    I downloaded the binaries (release 7.10.4), extracted them using tar and tried to run the program by cd-ing to the relevant directory in konsole and typing ./mged" ..snip.. Does anyone have an idea what could be going wrong here, or what I could try to fix it?
    The binary distributions expect to be installed into /usr/brlcad so if you just unpacked the tarball without copying the files into place, then the binaries aren't going to be pointing at the right run-time path. You probably need to either set your LD_LIBRARY_PATH (via something like "export LD_LIBRARY_PATH=/path/to/brlcad/lib:$LD_LIBRARY_PATH") to point to BRL-CAD's "lib" directory where libtermio.so and friends reside, or better -- move the "brlcad" directory that you unpacked into to your /usr directory.

    Similarly, running "./mged" implies that you didn't update your PATH variable to include BRL-CAD's "bin" directory. You shouldn't cd to the bin directory as that will potentially just be more confusing down the road. If you don't want to set your PATH, you can give an absolute path such as "/usr/brlcad/bin/mged" instead.

    The INSTALL file has more details. Good luck!

    Cheers!
    Sean

  4. #4

    Default Re: BRL-CAD

    Quote Originally Posted by narcho View Post
    Hi, complete newbie here, just installed opensuse 11.2 with KDE 4.3.5

    Not sure if this is the place to post this, but searching online it seemed like most people with similar problems posted on the forums of whatever Linux distro they were using. Apologies if I'm in the wrong place...

    I'm trying to get BRL-CAD set up, as I need to use CAD/CAE software a lot and would prefer to use open source software as much as possible. I downloaded the binaries (release 7.10.4), extracted them using tar and tried to run the program by cd-ing to the relevant directory in konsole and typing ./mged"

    I get the following error:



    libtermio.so.19 is in a "lib" folder. Does anyone have an idea what could be going wrong here, or what I could try to fix it?

    Thank you in advance for your help
    You may like to check out my post earlier this year for an alternative Cad package.

    New Cad Offering - openSUSE Forums

  5. #5

    Default Re: BRL-CAD

    Thanks for your swift replies!

    Where specifically is it located on your system - and are you running 32-bit or 64-bit (both platform and application)?
    The libtermio file is located in /usr/brlcad/rel-7.10.4/lib

    My system is 32-bit and... tbh I don't know how to check whether the app is 32- or 64-bit. Sorry, I'm a newbie.

    The binary distributions expect to be installed into /usr/brlcad so if you just unpacked the tarball without copying the files into place, then the binaries aren't going to be pointing at the right run-time path. You probably need to either set your LD_LIBRARY_PATH (via something like "export LD_LIBRARY_PATH=/path/to/brlcad/lib:$LD_LIBRARY_PATH") to point to BRL-CAD's "lib" directory where libtermio.so and friends reside, or better -- move the "brlcad" directory that you unpacked into to your /usr directory.

    Similarly, running "./mged" implies that you didn't update your PATH variable to include BRL-CAD's "bin" directory. You shouldn't cd to the bin directory as that will potentially just be more confusing down the road. If you don't want to set your PATH, you can give an absolute path such as "/usr/brlcad/bin/mged" instead.
    I copied the brlcad directory to /usr and used the absolute path as you said, but still the same problem.

    I think perhaps I've tried to jump in at the deep end. I'm still getting used to working on and navigating a Linux system, so maybe I should wait until I have a better idea of what's going on before I try and tackle BRL-CAD. If you have any further recommendations of what I should try when I'm ready to come back to this, they would be very much appreciated.

    cabernet: thanks for the suggestion, I'll definitely have a look at that too.

  6. #6
    Chris Maaskant NNTP User

    Default Re: BRL-CAD

    narcho wrote:

    > I'm trying to get BRL-CAD set up, as I need to use CAD/CAE software a
    > lot and would prefer to use open source software as much as possible. I
    > downloaded the binaries (release 7.10.4)


    Are you aware that brlcad is in the education repository?
    http://tinyurl.com/2w3ylnq

    Here's how to add repositories.
    http://wiki.opensuse.org/SDB:Add_package_repositories

    --
    Chris Maaskant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •