Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Unable to install any updates...

  1. #1

    Default Unable to install any updates...

    Automatic updates fail because:

    PackageKit Error cannot-remove-system-package: Subprocess failed. Error: RPM failed: error: package libpackagekit-glib12-0.5.1-3.7.i586 is not installed


    Manually updating from yaST gives the same error. However, I cannot find the above packge available for installation. i found the following link in the "Yast2-ncurses broken?" thread, but it doesnt automatically install, and I am unsure whether it will work with ver 11.2:

    Index of /pub/gnu/ncurses

    Any ideas?

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Unable to install any updates...

    libpackagekit-glib12 is on the OSS repo. It seems like it would be installed by default, assuming you are using the Gnome desktop. What is the output of:

    zypper se -i libpackagekit-glib12

    and

    zypper lr -d

  3. #3

    Default Re: Unable to install any updates...

    Hello - thank you for the response!



    linux-cw69:~ # zypper se -i libpackagekit-glib12
    Retrieving repository 'X11:xfce' metadata [done]
    Building repository 'X11:xfce' cache [done]
    Loading repository data...
    Reading installed packages...

    S | Name | Summary | Type
    --+----------------------+--------------------------------------------------+--------
    i | libpackagekit-glib12 | Simple software installation management software | package
    linux-cw69:~ # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+--------------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------------+--------
    1 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    2 | X11:xfce | X11:xfce | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/xfce/openSUSE_Factory |
    3 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
    4 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    7 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    8 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2


    ------------------------------

    Thanks again!

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Unable to install any updates...

    Try installing it through zypper.

    zypper install libpackagekit-glib12

  5. #5

    Default Re: Unable to install any updates...

    Hmmmm...

    linux-cw69:~ # zypper install libpackagekit-glib12
    Loading repository data...
    Reading installed packages...
    'libpackagekit-glib12' is already installed.
    No update candidate for 'libpackagekit-glib12'.
    Resolving package dependencies...

    Nothing to do.

    No comprende

  6. #6
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Unable to install any updates...

    Sorry, I misread the query. I'm not sure why the updater isn't detecting it. Do this:

    rpm --rebuilddb

  7. #7

    Default Re: Unable to install any updates...

    Hi - tried it twice with apparently a null result:

    --------------------------------------------------------

    linux-cw69:~ # rpm --rebuilddb
    linux-cw69:~ # rpm --rebuilddb
    linux-cw69:~ #

    ---------------------------------------------------------

    Hmmmm...

  8. #8
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Unable to install any updates...

    No output is expected, rpm will rebuild your rpm database. Try the update now.

  9. #9

    Default Re: Unable to install any updates...

    Thanks Chief -- all nice & updated. Do you happen to know anything about Broadcom wireless cards in Dell laptops and why mine wont work? I have to use a Belkin USB dongle to access WWW.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Unable to install any updates...

    Quote Originally Posted by protosound View Post
    Thanks Chief -- all nice & updated. Do you happen to know anything about Broadcom wireless cards in Dell laptops and why mine wont work? I have to use a Belkin USB dongle to access WWW.
    For your Dell, post result of

    Code:
    /sbin/lspci -nnk
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •