Results 1 to 10 of 10

Thread: How to stop screensaver during video streaming

  1. #1

    Question How to stop screensaver during video streaming

    I am using opensuse 11.2 Gnome. Screensaver is spoiling video streaming and I have to manually stop it every time. There are options in media players to stop screensaver but when I watch videos online it seems like there is no global option to stop it. Is there a way to resolve this issue?

  2. #2

    Default Re: How to stop screensaver during video streaming

    In Gnome Control Centre, go to 'Look and Feel' and 'Screensaver' and untick 'Activate screensaver when computer is idle'. To be on the safe side because of previous experience with Ubuntu, I also set the slider all the way to 2 Hours.
    The Power Management button below lets you select 'Never' for when to active Sleep Mode. Bring on Futurama Season Six

  3. #3

    Default Re: How to stop screensaver during video streaming

    Thank you for your reply but this is not I want, I don't want to kill screensaver or delay them for hours. Windows is clever enough to stop screensaver during any video streaming but it works when system is idle. I want similar kind of solution , so I can still keep my favourite screensaver without any manual intervention and watch videos without killing them.

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: How to stop screensaver during video streaming

    If you can bear to install a KDE3 program, Kaffeine sends a dummy keypress every so often to stop this happening. So you don't need to do anything with your screensaver settings.

  5. #5

    Default Re: How to stop screensaver during video streaming

    I have installed KDE3 programme, Kaffeine. I started kaffeine and tried screensaver but no success and same thing happens without kaffeine. Is there any other way to resolve this issue? How others are watching videos and running screensaver.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: How to stop screensaver during video streaming

    Well I use KDE so I'm not sure this applies to gnome. In the screen saver setup there is an advanced options button that allows you to set an action when the mouse is in a corner of the screen. Setting it to "no locking" will prevent the screen saver from starting when the mouse is in that position. Don't know if this is available in gnome.

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: How to stop screensaver during video streaming

    Quote Originally Posted by skydreams View Post
    I have installed KDE3 programme, Kaffeine. I started kaffeine and tried screensaver but no success and same thing happens without kaffeine. Is there any other way to resolve this issue? How others are watching videos and running screensaver.
    This suggests that the problem (and therefore the solution) is in Gnome as I have not needed to do anything to my screensaver in KDE for Kaffeine to stop the screensaver from starting.

  8. #8
    Carlos E. R. NNTP User

    Default Re: How to stop screensaver during video streaming

    On 2010-07-01 18:36 GMT john hudson wrote:

    >
    > skydreams;2183477 Wrote:
    > > I have installed KDE3 programme, Kaffeine. I started kaffeine and
    > > tried screensaver but no success and same thing happens without
    > > kaffeine. Is there any other way to resolve this issue? How others
    > > are watching videos and running screensaver.

    >
    > This suggests that the problem (and therefore the solution) is in
    > Gnome as I have not needed to do anything to my screensaver in KDE for
    > Kaffeine to stop the screensaver from starting.


    I use gnome and I don't have a problem with video watching and
    screensavers. This is handled by the viewer, not the desktop (although
    the variety of desktops makes this difficult).

    I'm on NNTP, and I can't see the original post, so I don't know what
    viewer is the OP using. I would suggest xine, but mplayer should be
    fine as well.

    The xine engine (which is what kaffeine uses) can simulate a keypress
    to fool the screensaver into not triggering. Gxine, xine, etc, do the
    same, as they share the same engine. It is configurable.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Minas Tirith))


  9. #9
    Join Date
    Dec 2008
    Location
    London - UK
    Posts
    53

    Default Re: How to stop screensaver during video streaming

    Can you not just turn it off, whilst streaming... I know its not what you originally asked for i.e. an option within a media player. I use mplayer & VLC and it appears to work fine [new install of 11.2/_64/gnome]. My ScreenSaver is set to 5 mins, and i'm watching hr long streams/vids without it kicking in...

    As already mentioned above, maybe using a xine based player might do the trick.

  10. #10

    Default Re: How to stop screensaver during video streaming

    Quote Originally Posted by skydreams View Post
    I am using opensuse 11.2 Gnome. Screensaver is spoiling video streaming and I have to manually stop it every time. There are options in media players to stop screensaver but when I watch videos online it seems like there is no global option to stop it. Is there a way to resolve this issue?
    I simply hit the a up-down or right-left arrow. I'm pretty sure you could also click outside the view screen (totem, mplayer, kaffeine) area, even move the mouse should work.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •