Results 1 to 8 of 8

Thread: Compiz - nvidia

  1. #1

    Default Compiz - nvidia

    Hi there
    I have recently converted from Ubuntu to Open Suse 11.2 x64 (gnome). So far I am liking it, but there are some things that aren't quite so easy as is the case with Ubuntu. One thing is Compiz. I have the latest Nvidia drivers and composite enabled (created the xorg.conf file manually using SaX2), but I just get "desktop effects are not supported" when I go into 'control center' and 'desktop effects'. I have tried various hacks found here and there but to no avail.

    Any ideas?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,829
    Blog Entries
    15

    Default Re: Compiz - nvidia

    Quote Originally Posted by swappa
    HI THERE
    I have recently converted from Ubuntu to Open Suse 11.2 x64 (gnome).
    So far I am liking it, but there are some things that aren't quite so
    easy as is the case with Ubuntu. One thing is Compiz. I have the latest
    Nvidia drivers and composite enabled (created the xorg.conf file
    manually using SaX2), but I just get "desktop effects are not supported"
    when I go into 'control center' and 'desktop effects'. I have tried
    various hacks found here and there but to no avail.

    Any ideas?

    Thanks.

    Hi
    So when you ran sax2, was the 3d checkbox marked and greyed out? Are
    you using the nvidia driver direct from their site or the one from the
    repositories?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 5:30, 2 users, load average: 0.05, 0.05, 0.00
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35


  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,587
    Blog Entries
    38

    Default Re: Compiz - nvidia

    Quote Originally Posted by swappa View Post
    I have recently converted from Ubuntu to Open Suse 11.2 x64 (gnome). So far I am liking it, but there are some things that aren't quite so easy as is the case with Ubuntu. One thing is Compiz. I have the latest Nvidia drivers and composite enabled (created the xorg.conf file manually using SaX2), but I just get "desktop effects are not supported" when I go into 'control center' and 'desktop effects'. I have tried various hacks found here and there but to no avail.
    various hacks? Thats rather worrisome. I hope when they did NOT work you put everything back EXACTLY as it was before.

    Can you do some quality checks?

    Take a look inside /var/log/Xorg.0.log file and confirm it is the 'nvidia' and not the 'nv' nor 'vesa' driver that you have running. You can do that with:
    Code:
    less /var/log/Xorg.0.log
    and look for many occurences of something like " (==) NVIDIA(0) " or " (==) NVIDIA(0) "

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Compiz - nvidia

    Please post your /etc/X11/xorg.conf.

  5. #5

    Default Re: Compiz - nvidia

    Quote Originally Posted by gropiuskalle View Post
    Please post your /etc/X11/xorg.conf.
    Thanks for the replies.
    Here is the xorg.conf;

    # /.../
    # SaX generated X11 config file
    # Created on: 2010-06-25T11:23:22+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "dri"
    Load "dbe"
    Load "extmod"
    Load "glx"
    EndSection

    Section "InputDevice"
    # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"'
    # is set in "ServerFlags" section.
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "no"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"'
    # is set in "ServerFlags" section.
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "13"
    Option "Device" "/dev/input/mice"
    Option "Name" "Microsoft Nano Transceiver v1.0"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 331 207
    HorizSync 30-94
    Identifier "Monitor[0]"
    ModelName "HT009 154WU2 LCD MONITOR"
    Option "DPMS"
    Option "PreferredMode" "1920x1200"
    VendorName "LGD"
    VertRefresh 43-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "Quadro NVS 160M"
    Driver "nvidia"
    Identifier "Device[0]"
    VendorName "NVIDIA"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    # tried with "true", but didnt help
    EndSection

  6. #6

    Default Re: Compiz - nvidia

    Quote Originally Posted by swappa View Post
    Thanks for the replies.
    Here is the xorg.conf;

    # /.../
    # SaX generated X11 config file
    # Created on: 2010-06-25T11:23:22+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "dri"
    Load "dbe"
    Load "extmod"
    Load "glx"
    EndSection

    Section "InputDevice"
    # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"'
    # is set in "ServerFlags" section.
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "no"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"'
    # is set in "ServerFlags" section.
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "13"
    Option "Device" "/dev/input/mice"
    Option "Name" "Microsoft Nano Transceiver v1.0"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 331 207
    HorizSync 30-94
    Identifier "Monitor[0]"
    ModelName "HT009 154WU2 LCD MONITOR"
    Option "DPMS"
    Option "PreferredMode" "1920x1200"
    VendorName "LGD"
    VertRefresh 43-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "Quadro NVS 160M"
    Driver "nvidia"
    Identifier "Device[0]"
    VendorName "NVIDIA"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    # tried with "true", but didnt help
    EndSection
    Guess this explains it?

    From the xorg.log file;
    (EE) Please try reinstalling the NVIDIA driver.(EE) NVIDIA GLX: No supported server extension ABI found(II) UnloadModule: "glx"

    Although, it says the following too;

    (II) Module nvidia: vendor="NVIDIA Corporation"
    (II) NVIDIA dlloader X Driver 195.36.15 Thu Mar 11 22:01:49 PST 2010
    (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
    (==) NVIDIA(0): RGB weight 888
    (==) NVIDIA(0): Default visual is TrueColor
    (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    (**) Jun 25 11:42:55 NVIDIA(0): Enabling RENDER acceleration
    (II) Jun 25 11:42:55 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    (II) Jun 25 11:42:55 NVIDIA(0): enabled.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,587
    Blog Entries
    38

    Default Re: Compiz - nvidia

    Quote Originally Posted by swappa View Post
    Guess this explains it?

    From the xorg.log file;
    Code:
    (EE) Please try reinstalling the NVIDIA driver.(EE) NVIDIA GLX: No supported server extension ABI found(II) UnloadModule: "glx"
    Interesting.

    Clearly the NVIDIA driver is installed, and it is being used. But the log file is suggesting you re-install the driver.

    Perhaps you should remove the proprietary NVIDIA driver and re-install it as suggested by the log file.

    I'm curious, do you have a stock kernel ? ie what is the output of:
    Code:
    uname -a

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Compiz - nvidia

    Composite is *not* enabled. Instead of writing those options yourself, you should use tools such as SaX2 or nvidia-xconfig that do so to avoid typos or (as in this case) wrong options.

    Code:
    Section "Extensions"
    Option "Composite" "on"
    ...should rather be...

    Code:
    Section "Extensions"
        Option         "Composite" "Enable"
    Use the following commands to set composite and some other necessary options:

    Code:
    nvidia-xconfig --composite
    nvidia-xconfig --allow-glx-with-composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    nvidia-xconfig --damage-events
    ...then restart the X-server.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •