Results 1 to 3 of 3

Thread: Problem uninstalling wine.

  1. #1

    Default Problem uninstalling wine.

    Hey All,

    I'm running opensuse 11.2 since a few days. I installed wine to play some game.
    Originally I tried with the default version but since it didn't work I have installed a newer version from winehq website (just the same, an rpm package, supposedly for suse). In the mean time had a lot of stuff installed, like winetricks, or wine-doors, and the necessary wine software like directx or microsoft fonts.

    After a couple of days the game is not working anymore so I have tried to remove everything and start from scratch. The problem is I can't remove wine. If I remove wine the dependency will say, it will remove package 'wine' and install 'wine-snapshot'. If I uninstall wine-snapshot it installs wine. And so on.

    I'd just like to remove everything related so i can check and eventually manually delete rest of wine-related stuff to make sure it's all clean... reinstalling the game didn't help so I figured that wine is broken somehow.
    But this dependency thing is driving me crazy... any ideas?

    thanks

  2. #2

    Default Re: Problem uninstalling wine.

    This is what I'm talking about:

    # zypper remove wine
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    The following NEW package is going to be installed:
    wine-snapshot

    The following package is going to be REMOVED:
    wine

    1 new package to install, 1 to remove.
    Overall download size: 12.6 MiB. After the operation, additional 10.3 MiB will be used.
    Continue? [y/n/p/?] (y):

    # wine --version
    wine-1.1.28

  3. #3

    Default Re: Problem uninstalling wine.

    Not finding Edit button so I keep replying my own thread...

    Found the problem. I had a package called wine-mp3 (I don't remember installing it, maybe some tool did automagically). The dependency was caused by this. After removing it I was able to clear wine for good.
    Ah well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •