Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Python

  1. #1
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Exclamation Python

    Hi,

    How to fix the error stated below -

    linux-lst5:/home/david # zypper dup
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    Problem: nothing provides libpython2.6.so.1.0 needed by python-numpy-1.3.0-0.pm.3.1.i586
    Solution 1: keep python-numpy-1.3.0-2.2.x86_64
    Solution 2: break python-numpy by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c] (c): c

    If I try to remobe python-numpy it asks me to deinstall gedit and some other stuff that I need.

    Best,

    David

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Python

    Thread moved to applications
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Python

    please post result of

    Code:
    zypper verify
    and
    Code:
    zypper lu
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Exclamation Re: Python

    Hi,

    david@linux-lst5:~> zypper verify
    Loading repository data...
    Reading installed packages...
    3 Problems:
    Problem: nothing provides libsigc-2.0.so.0 needed by gparted-0.6.0-2.1.i586
    Problem: java-1_6_0-sun-plugin-1.6.0.u15-1.1.2.x86_64 requires java-1_6_0-sun = 1.6.0.u15-1.1.2, but this requirement cannot be provided
    Problem: mozilla-xulrunner192-gnome-1.9.2.4-1.pm.11.1.x86_64 requires mozilla-xulrunner192 = 1.9.2.4-1.pm.11.1, but this requirement cannot be provided

    Problem: nothing provides libsigc-2.0.so.0 needed by gparted-0.6.0-2.1.i586
    Solution 1: deinstallation of gparted-0.6.0-2.1.i586
    Solution 2: break gparted by ignoring some of its dependencies

    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): c

    david@linux-lst5:~> zypper lu
    Loading repository data...
    Reading installed packages...
    No updates found.
    david@linux-lst5:~>

    I've verified java, it works great but still I get that error and same with gparted.
    Last edited by avenuemax; 21-Jun-2010 at 23:29. Reason: additional information

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Python

    I'll have to look in to this later, I have to go out.

    Post your repo list again

    Code:
    zypper lr -d
    Is it possible those packages are in part provided by a repo you removed? You need to check how they are currently provided in the versions tab
    Eg;
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Python

    Quote Originally Posted by caf4926 View Post
    I'll have to look in to this later, I have to go out.

    Post your repo list again

    Code:
    zypper lr -d
    Is it possible those packages are in part provided by a repo you removed? You need to check how they are currently provided in the versions tab
    Eg;
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    david@linux-lst5:~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-------------------------------+---------------------------+---------+---------+----------+--------+------------------------------------------------------------------+--------
    1 | download.nvidia.com-opensuse | NVIDIA Repository | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2/ |
    2 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    3 | download.opensuse.org-oss_1 | Main Repository (Sources) | Yes | Yes | 99 | yast2 | Index of /source/distribution/11.2/repo/oss |
    4 | mozilla | mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
    5 | packman.inode.at-suse_1 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /suse/11.2/

    Well java is in mains, that should not be a problem. Gparted, I downloaded from site and compiled it. I checked all versions and they are recent. Firefox is new 3.6 version, Java web check confirms latest version and parted is latest as well.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Python

    Use the system switcher on Mozilla
    Like this EG, but on the mozzila repo
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    My Java list


    Code:
    rpm --query --all '*java*'
    java-1_5_0-gcj-compat-1.5.0.0-107.109.2.x86_64
    timezone-java-2009u-0.1.1.noarch
    java-1_6_0-sun-1.6.0.u20-0.1.1.x86_64
    java-1_6_0-openjdk-devel-1.6.0.0_b17-2.1.1.x86_64
    java-1_6_0-openjdk-1.6.0.0_b17-2.1.1.x86_64
    java-1_6_0-sun-plugin-1.6.0.u20-0.1.1.x86_64
    By my search this: libsigc++2
    provides: libsigc-2.0.so.0
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Python

    Quote Originally Posted by caf4926 View Post
    Use the system switcher on Mozilla
    Like this EG, but on the mozzila repo
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    My Java list


    Code:
    rpm --query --all '*java*'
    java-1_5_0-gcj-compat-1.5.0.0-107.109.2.x86_64
    timezone-java-2009u-0.1.1.noarch
    java-1_6_0-sun-1.6.0.u20-0.1.1.x86_64
    java-1_6_0-openjdk-devel-1.6.0.0_b17-2.1.1.x86_64
    java-1_6_0-openjdk-1.6.0.0_b17-2.1.1.x86_64
    java-1_6_0-sun-plugin-1.6.0.u20-0.1.1.x86_64
    By my search this: libsigc++2
    provides: libsigc-2.0.so.0
    Been there, Mozilla switch hung up. I guess I should add sun java repositories by url. Let me try that and I get back.

  9. #9
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Python

    Quote Originally Posted by avenuemax View Post
    Been there, Mozilla switch hung up. I guess I should add sun java repositories by url. Let me try that and I get back.
    Ok, fixed firefox by adding mozilla repo. As per your java o/p, I guess you have openjdk installed, I dont want openjdk. Trying to figure out url for adding sun repo.

  10. #10
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Python

    Beats me, found out libsigc but unable to install, it asks for adding gnome repo. At one hand I need to maintain less repos and on other I cant get what I want. Java has no issue but zyyper verify shows a conflict.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •