Results 1 to 8 of 8

Thread: Dznax 7D connects thru digikam instead of file manager

  1. #1

    Default Dznax 7D connects thru digikam instead of file manager

    I used to plug in my camera into the USB interface and was able to open the picture storage with the KDE file manager - the file manager came up automatically.

    Now since I have installed openSUSE 11.2, digikam insists to take over.

    How can I configure SUSE 11.2 that it offers me the file manager option again? It would be great (but not necessary) if it offered a selection "Open with ..." when the USB cable is plugged in.

    Sorry for the typos but I cannot edit the title.
    Last edited by HaBre99; 21-Jun-2010 at 04:35. Reason: Typos

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,996

    Default Re: Dznax 7D connects thru digikam instead of file manager

    When I enter an USB memory device (USB stick, no camera), the popup offers me the possibility to open with digikam as well as with a file manager. Does that not work at yours?
    Henk van Velden

  3. #3

    Default Re: Dznax 7D connects thru digikam instead of file manager

    This is true but I do not connect a USB memory stick. If I try with a USB memory, I see
    "Devices recently plugged in ... VFAT
    2 options for this device"
    and then the option to open the device with digikam or the file manager.

    With the Dynax 7D camera, however, it says "USB Imaging Interface" (which it did not with previous SUSE versions) and does not give the option to open it with dolphin. The previous SUSE versions handled the Minolta camera storage as a memory media, and this is what I also want to have in the future.

    I am looking for the place where the device identification is handled and the decision is made which application to load. If it was possible to identify the device codes as a memory device, it is hopefully still possible with the right incantations.

  4. #4

    Default Re: Dznax 7D connects thru digikam instead of file manager

    /var/log/messages tells me
    Jun 21 17:10:36 box28 kernel: [ 553.327037] usb 1-3: new high speed USB device using ehci_hcd and address 5
    Jun 21 17:10:36 box28 kernel: [ 553.442394] usb 1-3: New USB device found, idVendor=132b, idProduct=001c
    Jun 21 17:10:36 box28 kernel: [ 553.442399] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    Jun 21 17:10:36 box28 kernel: [ 553.442404] usb 1-3: Product: DYNAX 7D
    Jun 21 17:10:36 box28 kernel: [ 553.442407] usb 1-3: Manufacturer: KONICA MINOLTA
    Jun 21 17:10:36 box28 kernel: [ 553.442499] usb 1-3: configuration #1 chosen from 1 choice

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Dznax 7D connects thru digikam instead of file manager

    HaBre99 wrote:
    > With the Dynax 7D camera it says "USB Imaging Interface" (which it did
    > not with previous SUSE versions) and *does not give the option* to open
    > it with dolphin.


    does it give the option to open with another program, down at the
    bottom of the popup, a "Configure" button maybe...and, if you click
    that i think you can browse a list of possible applications to
    associate with this device..


    --
    DenverD (Linux Counter 282315)
    CAVEAT: http://is.gd/bpoMD
    posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
    2.6.22.19-0.4-default SMP i686
    AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
    CMedia 9761 AC'97 Audio

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Dznax 7D connects thru digikam instead of file manager

    Hi,

    If you go to systemsettings and click on the advanced tab there's an entry called Device Actions. Make sure you have an entry for Storage Volume, Camera to open with dolphin. If you don't have one you can add one with these parameters:

    Action Name: Open with File Manager
    Command: kioclient exec camera:/

    1st Parameter type: Content Disjunction
    2nd Parameter type: Content Conjunction
    3rd Parameter type: Property Match
    3rd Device type: Storage Volume
    3rd Value name: Ignored
    3rd Equals: false
    4th Parameter type: Property Match
    4th Device type: Storage Volume
    4th Value name: Usage
    4th Equals: FileSystem
    5th Parameter type: Property Match
    5th Device type: Camera
    5th Value name: Supported Drivers
    5th Equals: gphoto


    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7

    Default Re: Dznax 7D connects thru digikam instead of file manager

    Thanks, Ian, your post looks as if it is the solution. I have a problem to match it with my the descriptions on my system.

    I have entered
    Code:
    Action Name: Open with File Manager
    Command: kioclient exec camera:/
    
    - Any of the contained conditions must match
       |- All of the contained conditions must match
         | -The device's property StorageVolume.ignored must equal false
         |- The device's property StorageVolume.usage must equal FileSystem
         |- The device's property Camera.supportedDrivers must equal gphoto
    When I then click on OK to accept the input, I get an error message "It appears that the action name, command, icon or condition are not valid. Therefore changes will not be applied.

    The nesting of the two containers does not look logical to me because the first container contains only one item but this is how I understand your description.

  8. #8
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Dznax 7D connects thru digikam instead of file manager

    Quote Originally Posted by HaBre99 View Post
    Thanks, Ian, your post looks as if it is the solution. I have a problem to match it with my the descriptions on my system.

    I have entered
    Code:
    Action Name: Open with File Manager
    Command: kioclient exec camera:/
    
    - Any of the contained conditions must match
       |- All of the contained conditions must match
          |-The device's property StorageVolume.ignored must equal false
          |-The device's property StorageVolume.usage must equal FileSystem
       |- The device's property Camera.supportedDrivers must equal gphoto
    When I then click on OK to accept the input, I get an error message "It appears that the action name, command, icon or condition are not valid. Therefore changes will not be applied.

    The nesting of the two containers does not look logical to me because the first container contains only one item but this is how I understand your description.
    Actually it should be more like this. It automatically gave me this layout when I added a new action to test it, all I had to do was change the values for everything.

    Also have you chosen an icon for the action? You have to choose an icon or else it will give you that error. Also here's a screenshot of what I had:



    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •