Results 1 to 7 of 7

Thread: Проблема с драйверами ATI на Gnome

  1. #1

    Default Проблема с драйверами ATI на Gnome

    Проблема такая:
    Сначала использовал OpenSuse 11.2 с KDE, драйверы ставились нормально и не было ни какиз проблем. Решил перейти на Gnome с переустановкой системы. Ставлю драйверы через консоль командой sh. Перезагружаю и всё, иксы не грузятся.
    Выдаёт какую-то ошибку про дисплей(извините, точнее сказать ничего не могу).
    Затем выполняю такую команду:
    Code:
    aticonfig --initial -f
    После чего при загрузке иксов появляется такая ошибка:
    Code:
    Fatal server error:
    Add/ScreenScreenInit failed for driver 0
    и ещё 4 последние строчки:
    Code:
    (EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.
    givin up.
    xinit: No such file or directiry (errno 2): unable to connect to X server
    xinit: No such process (errno 3): Server error.
    Полный лог скинуть не могу, т.к. не знаю, как vpn поднять через консоль.

  2. #2
    Join Date
    Jun 2008
    Location
    CZE, Praha
    Posts
    694

    Default Re: Проблема с драйверами ATI на Gnome

    А версия модуля таже смамая?

    Смена DE на работу модуля повлиять не могут

  3. #3
    Join Date
    Jun 2008
    Location
    CZE, Praha
    Posts
    694

    Default Re: Проблема с драйверами ATI на Gnome

    Ах в KDE теперь не используют compiz. Проблема видимо в нем. Ядро не PAE случаем? И какой размер ОЗУ?

  4. #4

    Default Re: Проблема с драйверами ATI на Gnome

    Не знаю насчёт ядра. Я с ним непосредственно не делал ничего. Установил систему, а потом и драйверы стал ставить.
    4GB озу.
    Сейчас пробовал после переустановки системы из репозиториев поставить драйверы, как в инструкции. После ввода:
    Code:
    su -c 'SaX2 -r -m 0=fglrx'
    нажимаю "проверить". Появляется голубой экран с настройками положения изображения на мониторе, но шёлка по стрелкам для его смещения или изменения размера ничего не происходит. Нажимаю "сохранить" и всё виснет. Перезагружаю комп через "reset" и всё, иксы не запускаются, только уже даже "aticonfig --initial -f" не помогает никак и ругается на какую-то ошибку в xorg.conf.
    Если его открыть через vi, то весь экран будет заполнен символом "@" и только внизу идут строчки с настройками.

  5. #5
    Join Date
    Jun 2008
    Location
    CZE, Praha
    Posts
    694

    Default Re: Проблема с драйверами ATI на Gnome

    64бита или 32?

    Что показывает uname -m?
    и
    uname -r

  6. #6

    Default Re: Проблема с драйверами ATI на Gnome

    64 бита.
    Code:
    uname -r
    2.6.31.5-0.1-desktop
    Code:
    uname -r
    2.6.31.5-0.1-desktop
    Иксы загружаются в безопасном режиме.

  7. #7

    Default Re: Проблема с драйверами ATI на Gnome

    Не знаю, что я сделал так, но вновь установив драйверы из репозитория, после
    Code:
    su -c 'SaX2 -r -m 0=fglrx'
    всё норамально прошло, ничего не зависло и иксы запустились в нормальном режиме с новыми драйверами.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •