Connection timed out
Testdrive needs Flash enabled and access to ports 843 and 5900 - 5908
(You may have an issue with a Flash blocker, a firewall, or a proxy)
Windows Server 2003 sp2

I suspect I'll just get the same copied and pasted assertions that the problem is on my end and if I'll only try installing flash, disabling firewalls, and allowing ports, everything will be fine. But just in case someone who cares actually reads this:

Tried from 2 different computers at 2 different locations (work and home) on Firefox. Both are virgin installations of Firefox (3.6.3) and Flash (10.0.42.34) latest versions. Neither has any outgoing ports blocked. Both failed to run testdrive with the above message.

Work is a fairly complex corporate network setting, but no blocked outgoing ports. Home is a simple network with a single home wireless router, configured by someone who knows what he's doing.

Installed Chrome on computer at home (one of the same computers that failed for Firefox above). Again, virgin installation of Chrome, latest version. Chrome worked. Version 5.0.375.70

Just to be sure, after Chrome worked, I tried again in Firefox on the same computer and it still failed. When you go to the Flash web site in Firefox, it indicates Flash is installed.

Home router does not have any port forwarding turned on for these ports, but it still worked.

I hope something in here helps someone make sense of this.

-dmlange