Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: How to auto start vmware service?

  1. #1

    Default How to auto start vmware service?

    every time I reboot the box, I have to run:
    sudo /etc/init.d/vmware start

    in order to start the vmware support processes.

    There are entries in /etc/init.d/rc5.d
    lrwxrwxrwx 1 root root 18 2010-06-08 18:08 K08vmware -> /etc/init.d/vmware
    lrwxrwxrwx 1 root root 18 2010-06-08 18:08 S19vmware -> /etc/init.d/vmware

    So, I do not know why it won't start upon boot time.

    It is minor annoyance but it would be nice if I can fix it as I run VMware quite often.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,659
    Blog Entries
    15

    Default Re: How to auto start vmware service?

    Quote Originally Posted by hpark21
    every time I reboot the box, I have to run:
    sudo /etc/init.d/vmware start
    Hi
    Have you checked in YaST->System->System Services (runlevels), select
    the 'expert' radio button to see if it's all enabled. Else from the
    command line;
    Code:
    /sbin/chkconfig vmware
    
    If off;
    
    sudo /sbin/chkconfig vmware on
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 0:17, 2 users, load average: 0.11, 0.40, 0.32
    GPU GeForce 8600 GTS Silent - Driver Version: 195.36.31


  3. #3

    Default Re: How to auto start vmware service?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Have you checked in YaST->System->System Services (runlevels), select
    the 'expert' radio button to see if it's all enabled. Else from the
    command line;
    Code:
    /sbin/chkconfig vmware
    
    If off;
    
    sudo /sbin/chkconfig vmware on
    I looked at them. and it is all enabled, checked through command line and it is turned on. I do not know why. According to system services, vmware is currently running, but when I try vmware player, it says /dev/vmmon does not exists. I have to run the vmware service manually.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,659
    Blog Entries
    15

    Default Re: How to auto start vmware service?

    Quote Originally Posted by hpark21
    I looked at them. and it is all enabled, checked through command line
    and it is turned on. I do not know why. According to system services,
    vmware is currently running, but when I try vmware player, it says
    /dev/vmmon does not exists. I have to run the vmware service manually.

    Hi
    So from the command line after a reboot, if you try;
    Code:
    sudo /etc/init.d/vmware status
    ps -ef |grep vm
    You should see then loaded and running?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 18:09, 2 users, load average: 0.21, 0.09, 0.02
    GPU GeForce 8600 GTS Silent - Driver Version: 195.36.31


  5. #5

    Default Re: How to auto start vmware service?

    Code:
    stranger@linux-mwos:~> sudo /etc/init.d/vmware status
    root's password:
    Module vmmon not loaded
    Module vmnet not loaded
    stranger@linux-mwos:~> ps -ef|grep vm
    stranger  6563  3442  0 07:47 pts/3    00:00:00 grep vm
    stranger@linux-mwos:~>
    It appears not.

  6. #6

    Default Re: How to auto start vmware service?

    Has anyone make any progress on this? Its still a problem.

    I have nearly the identical situation; it's like S19vmware isn't run or is otherwise broken. I can't find any error messages or warnings from any related scripts...the vmware service just doesn't start after any system start.

  7. #7

    Default Re: How to auto start vmware service?

    Quote Originally Posted by qqwasder View Post
    Has anyone make any progress on this? Its still a problem.

    I have nearly the identical situation; it's like S19vmware isn't run or is otherwise broken. I can't find any error messages or warnings from any related scripts...the vmware service just doesn't start after any system start.
    Came here looking after having the same exact issue. openSUSE 11.3 with VMware Workstation 7.1.2 installed.

    service vmware status lists vmmon and vmnet as not loaded. However, System Services in YAST has the service as running (currently) and at boot. If I 'service vmware restart' all is well.

    As a temporary workaround, I added 'service vmware restart' to /etc/rc.d/boot.local and I'm good to go every boot.

    Sure would love to know why this happens...

    Thanks!

  8. #8

    Default Re: How to auto start vmware service?

    Fixed ::

    Considering how much time I spent on this tonight... pretty simple fix:

    VMware KB: VMware Workstation fails to load when restarting a SUSE Linux host after the initial installation

    Works fine after setting the runlevel to 5 only. Interesting how VMware has allowed this little issue to linger for so long (note how the KB article started with openSUSE 10.

  9. #9

    Default Re: How to auto start vmware service?

    I just got the same issiue on Debian Squeeze and VMware-Workstation-Full-7.1.4-385536.i386.bundle (/etc/init.d/vmware not started after reboot). My solution was to replace the soft links in /etc/rc[235].d/S19vmware pointing to the absolute path /etc/init.d/vmware with relative links to ../init.d/vmware .

  10. #10

    Default Re: How to auto start vmware service?

    Same problem with VMware workstation 7.1.4 build-385536 but as the link to the KB stated, removing the 'vmware' service from runlevels 2 and 3 solved the problem. Also other USB devices showed up after the reboot. Those devices didn't work before.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •