Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Error when trying to install software

  1. #1
    Join Date
    Jun 2010
    Location
    Rio de Janeiro, Brazil
    Posts
    14

    Default Error when trying to install software

    I installed OpenSUSE 11.2 yesterday using the GNOME live CD. I did installed some software trying to get my wireless to work (broadcom-wl and the kernel module).

    Now, when I try to click on ' Install Software' option in the menu the following warning appears:

    "
    There was an error in the repository initialization.
    'repo-oss': [|] Valid metadata not found at specified URL(s)
    History:
    - Can't hardlink/copy /var/adm/mount/AP_0x00000001/suse/setup/descr/non_oss-11.2-20.22.1.i586.pat.gz to /var/cache/zypp/raw/repo-ossuSL8Z0
    - Can't provide ./suse/setup/descr/non_oss-11.2-20.22.1.i586.pat.gz : Can't hardlink/copy /var/adm/mount/AP_0x00000001/suse/setup/descr/non_oss-11.2-20.22.1.i586.pat.gz to /var/cache/zypp/raw/repo-ossuSL8Z0
    "

    Did I break something? How to fix it?

    Thanks in advance,

  2. #2
    Join Date
    Dec 2008
    Location
    Montgomery, AL
    Posts
    64

    Default Re: Error when trying to install software

    Yoiu can try (from a terminal):
    Code:
    sudo zypper clean
    sudo zypper ref
    sudo zypper up
    if that doesn't work, please post the output of:
    Code:
    sudo zypper lr

  3. #3
    Join Date
    Jun 2010
    Location
    Rio de Janeiro, Brazil
    Posts
    14

    Default Re: Error when trying to install software

    It seems I broke something - I installed Chrome and broadcom-wl by myself.

    Running zypper ref gives me:

    Code:
    linux-i9ok:/home/vitorpy # zypper ref
    Repository 'google-chrome' is up to date.
    Repository 'openSUSE-11.2-Non-Oss' is up to date.
    Retrieving repository 'openSUSE-11.2-Oss' metadata [error]
    Repository 'openSUSE-11.2-Oss' is invalid.
    Can't provide /content : Can't hardlink/copy /var/adm/mount/AP_0x00000001/content to /var/cache/zypp/raw/repo-oss0OkTHG
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-11.2-Oss' because of the above error.
    Repository 'openSUSE-11.2-Update' is up to date.
    Some of the repositories have not been refreshed because of an error.
    Running zypper lr gives me:

    Code:
    linux-i9ok:/home/vitorpy # zypper lr
    # | Alias         | Name                  | Enabled | Refresh
    --+---------------+-----------------------+---------+--------
    1 | google-chrome | google-chrome         | Yes     | Yes    
    2 | repo-debug    | openSUSE-11.2-Debug   | No      | Yes    
    3 | repo-non-oss  | openSUSE-11.2-Non-Oss | Yes     | Yes    
    4 | repo-oss      | openSUSE-11.2-Oss     | Yes     | Yes    
    5 | repo-source   | openSUSE-11.2-Source  | No      | Yes    
    6 | repo-update   | openSUSE-11.2-Update  | Yes     | Yes
    Bad luck in my first contact with openSUSE :/

  4. #4
    Join Date
    Jun 2010
    Location
    Rio de Janeiro, Brazil
    Posts
    14

    Default Re: Error when trying to install software

    I tried to check if chrome's repository was the problem but disabling it does not change zypper ref results. Running zypper ref with --verbose gives me:

    Code:
    linux-i9ok:/home/vitorpy # zypper --verbose ref
    Verbosity: 1
    Initializing Target
    Specified repositories: 
    Skipping disabled repository 'google-chrome'
    Skipping disabled repository 'openSUSE-11.2-Debug'
    Checking whether to refresh metadata for openSUSE-11.2-Non-Oss
    Retrieving: content [done]
    Retrieving: media [done]
    Retrieving: content [done]
    Retrieving: media [done]
    Retrieving: media [done]
    Retrieving: content.asc [done]
    Retrieving: content.key [done]
    Retrieving: content [done (0 B/s)]
    Retrieving repository 'openSUSE-11.2-Non-Oss' metadata [done]
    Checking whether to refresh metadata for openSUSE-11.2-Oss
    Retrieving: media [done]
    Retrieving: content.asc [done]
    Retrieving: content.key [done]
    Retrieving: content [done]
    Retrieving repository 'openSUSE-11.2-Oss' metadata [error]
    Repository 'openSUSE-11.2-Oss' is invalid.
    History:
     - Can't hardlink/copy /var/adm/mount/AP_0x00000001/content to /var/cache/zypp/raw/repo-ossucU3Z6
     - Can't provide /content : Can't hardlink/copy /var/adm/mount/AP_0x00000001/content to /var/cache/zypp/raw/repo-ossucU3Z6
     - [|] Valid metadata not found at specified URL(s)
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-11.2-Oss' because of the above error.
    Skipping disabled repository 'openSUSE-11.2-Source'
    Checking whether to refresh metadata for openSUSE-11.2-Update
    Retrieving: repomd.xml [done (0 B/s)]
    Repository 'openSUSE-11.2-Update' is up to date.
    Some of the repositories have not been refreshed because of an error.

  5. #5
    Join Date
    Dec 2008
    Location
    Montgomery, AL
    Posts
    64

    Default Re: Error when trying to install software

    what is the output of:
    Code:
    zypper lr repo-oss
    mine looks like:
    Code:
    Alias          : repo-oss                                                
    Name           : openSUSE-11.2-Oss                                       
    URI            : http://download.opensuse.org/distribution/11.2/repo/oss/
    Enabled        : Yes                                                     
    Priority       : 99                                                      
    Auto-refresh   : On                                                      
    Keep Packages  : Off                                                     
    Type           : yast2                                                   
    GPG Check      : On                                                      
    GPG Key URI    :                                                         
    Path Prefix    : /                                                       
    Parent Service :                                                         
    MD Cache Path  : /var/cache/zypp/raw/repo-oss

  6. #6
    Join Date
    Jun 2010
    Location
    Rio de Janeiro, Brazil
    Posts
    14

    Default Re: Error when trying to install software

    This:

    Code:
    linux-i9ok:/var/adm/mount # zypper lr repo-oss
    Alias          : repo-oss                                                
    Name           : openSUSE-11.2-Oss                                       
    URI            : http://download.opensuse.org/distribution/11.2/repo/oss/
    Enabled        : Yes                                                     
    Priority       : 99                                                      
    Auto-refresh   : On                                                      
    Keep Packages  : Off                                                     
    Type           : yast2                                                   
    GPG Check      : On                                                      
    GPG Key URI    :                                                         
    Path Prefix    :                                                         
    Parent Service :                                                         
    MD Cache Path  : /var/cache/zypp/raw/repo-oss

  7. #7
    Join Date
    Dec 2008
    Location
    Montgomery, AL
    Posts
    64

    Default Re: Error when trying to install software

    Lets try deletign it an re adding it:
    Code:
    sudo zypper rr repo-oss
    sudo zypper ar -f http://download.opensuse.org/distribution/11.2/repo/oss/ repo-oss
    sudo zypper ref

  8. #8
    Join Date
    Jun 2010
    Location
    Rio de Janeiro, Brazil
    Posts
    14

    Default Re: Error when trying to install software

    It didn't work.

    Code:
    linux-i9ok:/home/vitorpy # zypper rr repo-oss
    Removing repository 'openSUSE-11.2-Oss' [done]
    Repository 'openSUSE-11.2-Oss' has been removed.
    
    linux-i9ok:/home/vitorpy # zypper ar -f http://download.opensuse.org/distribution/11.2/repo/oss/ repo-oss
    Adding repository 'repo-oss' [done]
    Repository 'repo-oss' successfully added
    Enabled: Yes
    Autorefresh: Yes
    URI: http://download.opensuse.org/distribution/11.2/repo/oss/
    
    linux-i9ok:/home/vitorpy # zypper ref
    Retrieving repository 'openSUSE-11.2-Non-Oss' metadata [done]
    Retrieving repository 'repo-oss' metadata [error]
    Repository 'repo-oss' is invalid.
    Can't provide ./suse/setup/descr/dvd-11.2-20.22.1.i586.pat.gz : Can't hardlink/copy /var/adm/mount/AP_0x00000001/suse/setup/descr/dvd-11.2-20.22.1.i586.pat.gz to /var/cache/zypp/raw/repo-oss0y88JC
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'repo-oss' because of the above error.
    Repository 'openSUSE-11.2-Update' is up to date.
    Some of the repositories have not been refreshed because of an error.

  9. #9
    Join Date
    Dec 2008
    Location
    Montgomery, AL
    Posts
    64

    Default Re: Error when trying to install software

    I am at a loss, perhaps deleting it and readding it with a deffernt alias?

  10. #10
    Join Date
    Jun 2010
    Location
    Rio de Janeiro, Brazil
    Posts
    14

    Default Re: Error when trying to install software

    I tried running zypper clean -a for cleaning everything. After that, everything is broken.

    Code:
    linux-i9ok:/var/adm/mount # zypper clean -a
    All repositories have been cleaned up.
    
    linux-i9ok:/var/adm/mount # zypper ref
    Retrieving repository 'openSUSE-11.2-Non-Oss' metadata [error]
    Repository 'openSUSE-11.2-Non-Oss' is invalid.
    Can't provide ./suse/setup/descr/packages.en.gz : Can't hardlink/copy /var/adm/mount/AP_0x00000001/suse/setup/descr/packages.en.gz to /var/cache/zypp/raw/repo-non-oss7HACVr
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-11.2-Non-Oss' because of the above error.
    Retrieving repository 'repo-oss' metadata [error]
    Repository 'repo-oss' is invalid.
    Can't provide ./suse/setup/descr/dvd-11.2-20.22.1.i586.pat.gz : Can't hardlink/copy /var/adm/mount/AP_0x00000001/suse/setup/descr/dvd-11.2-20.22.1.i586.pat.gz to /var/cache/zypp/raw/repo-ossW7Qn89
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'repo-oss' because of the above error.
    Retrieving repository 'openSUSE-11.2-Update' metadata [error]
    Repository 'openSUSE-11.2-Update' is invalid.
    Can't provide ./repodata/d1d8afbafa9a1b10c1623cc7a95467b95e1a913b-updateinfo.xml.gz : Can't hardlink/copy /var/adm/mount/AP_0x00000001/repodata/d1d8afbafa9a1b10c1623cc7a95467b95e1a913b-updateinfo.xml.gz to /var/cache/zypp/raw/repo-updateznucWD
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-11.2-Update' because of the above error.
    Could not refresh the repositories because of errors.
    I was trying to put a .NET project to work on Mono so I could migrate my servers at work to Linux. Seems I'm going to have to stay with Windows for a while :/

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •