Results 1 to 5 of 5

Thread: enabling xdmcp

  1. #1
    Join Date
    Apr 2010
    Location
    New York
    Posts
    13

    Question enabling xdmcp

    Hello,

    I made the following changes on my linux server.

    /etc/sysconfig/displaymanager
    DISPLAYMANAGER="kdm"
    DISPLAYMANAGER_REMOTE_ACCESS="yes"
    DISPLAYMANAGER_ROOT_LOGIN_REMOTE="yes"

    The above values were "no" initially.

    I commented this line in /etc/X11/xdm/xdm-config
    !DIsplayManager.requestPort: 0
    It was uncommented initially

    the file /opt/kde3/share/config/kdm/kdmrc has the following:
    Enable=true
    Port=177
    Xaccess=/etc/X11/xdm/Xaccess
    Willing=/etc/X11/xdm/Xwilling

    The "Enable" was set to "false" and the "Port=177" was commented out initally.

    /etc/X11/xdm/Xaccess shows this:
    * #any host can get a login window

    Then I rebooted the server. I don't see xdmcp listening on port 177 when I do a netstat. Should I do anything else? Have I missed any other settings? Should I do any thing with any startup scripts?

    Thanks,
    soft-e

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: enabling xdmcp

    You don't say what version of openSUSE you are running. Looks like you are running KDE3 so an older version? Mine 11.2's sysconfig is the same as yours except that I set DISPLAYMANGER to kdm4. BTW xdmcp is UDP port 177, not TCP.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,669
    Blog Entries
    15

    Default Re: enabling xdmcp

    Quote Originally Posted by soft-e
    Hello,
    Then I rebooted the server. I don't see xdmcp listening on port 177
    when I do a netstat. Should I do anything else? Have I missed any other
    settings? Should I do any thing with any startup scripts?

    Thanks,
    soft-e

    Hi
    Did you add xdmcp to the Allowed Services in the firewall?

    I would imagine you won't see anything occur until you try a query.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 4:25, 3 users, load average: 0.18, 0.15, 0.12
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.25


  4. #4
    Join Date
    Apr 2010
    Location
    New York
    Posts
    13

    Default Re: enabling xdmcp

    I can't find the Allowed Services option. I tried. I clicked on YAST, then clicked on Security and Users, and then clicked on Firewall. Firewall Configuration Step 1 of 4: Basic settings. I can't see Allowed Services anywhere

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,669
    Blog Entries
    15

    Default Re: enabling xdmcp

    Quote Originally Posted by soft-e
    I can't find the Allowed Services option. I tried. I clicked on YAST,
    then clicked on Security and Users, and then clicked on Firewall.
    Firewall Configuration Step 1 of 4: Basic settings. I can't see Allowed
    Services anywhere
    Hi
    Is your firewall off and not configured?
    You should see something like;


    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 5:20, 2 users, load average: 0.05, 0.08, 0.11
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.25


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •