Results 1 to 2 of 2

Thread: OpenOffice.org crash at file dialog

  1. #1

    Lightbulb OpenOffice.org crash at file dialog

    Hi all,

    Since several weeks I'm facing an issue with OpenOffice.org 3.1 on my OpenSUSE 11.2 system with KDE4 desktop. I decided to update to 3.2.1 hoping the issue would be solved. Unfortunately it wasn't.

    I'm posting this message as I found a solutions (although work-around is a better word) for this. The problem is in the integration with KDE4, as running Ooo in small window managers like IceWM and TWM works fine.

    When I started Ooo in a shell, I got the error message

    X-Error: RenderBadPicture (invalid Picture parameter)

    on my screen. On this forum I didn't find a solution, so when I found the work-around, I decided to post it here.

    The work-around is very simple, just disable the KDE4 integration
    Start oowriter, go to Tools -> Options and select "General"
    Enable the option "Use OpenOffice.org dialogs" and press OK

    That's all. The file dialogs are a bit less fancy, but OpenOffice.org doesn't crash anymore.

    Regards,
    Roland Leurs
    (Open)Suse user since version 5.3 (November 1998)
    Currently running OpenSuse 11.2 on P4 @ 2.4GHZ / 1500MB / 160GB
    http://www.cis-websolutions.nl

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,170

    Default Re: OpenOffice.org crash at file dialog

    First: Welcome to these Forums.

    Then: It is seldom seen here that first time users have allready a solution for their problem.

    But I think you are after a real solution and not a bypass.

    IMHO this should be reported as a bug somewhere. But I am not sure where this integration comes from. Does anybody else know if this to be reported on the openSUSE Bugzille or the KDE one?
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •