Results 1 to 9 of 9

Thread: Can't update via YAST or zypper

  1. #1
    Join Date
    Dec 2009
    Location
    Manchester, UK.
    Posts
    74

    Default Can't update via YAST or zypper

    Hi all,

    Turned on my PC as soon as I got home & found that Factory repo had a whole bunch of updates, so I selected to 'switch system packages' & clicked accept.

    Whatever I tried to download & install displays an error message

    Have even deleted the factory repo & re-added, to ensure it wasn't a change of url causing problems.

    Anyone else having or had this problem? Any suggestions gratefully accepted

    I'm running 11.2 64bit KDE 4.4.3

    Thanks!
    openSUSE 15.1 (x86_64) KDE Plasma
    Gigabyte GA-MA785GM-US2H - AMD(R) DUAL CORE 270 @ 3.40GHz
    nVidia Geforce GTX280 - 8GB DDR2 800MHz RAM

    https://linuxcounter.net/user/482859.html

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Can't update via YAST or zypper

    ashley194 wrote:
    > Turned on my PC as soon as I got home & found that Factory repo



    have you read this: "IMPORTANT: Note repositories are in essence file
    servers on the internet containing applications, drivers, codecs, ...
    etc ... in this case, for openSUSE. and as a new user, when setting up
    your repositories by following the guidance in that page, initially
    set up only 4 repositories (repos). Just 4. No others. None! Those 4
    are OSS, Non-OSS, Update, and Packman. Likely the 1st three
    (OSS,Non-OSS, and Update) are already in place and you only need to
    add Packman. Please note that adding other repositories can cause
    compatibility problems. You may add others when the time comes when
    you learn how to solve problems that may arise from having others.
    Until then, stick to only the 4 repositories. One may also have to
    briefly add other repos, install an app, and then remove the repos
    (for example for installing a graphic driver, or installing an updated
    alsa sound driver). Once those 4 repos are setup, one can go to YaST >
    Software > Software Management and change the "filter" to "search" and
    do searches for specific applications for installation."
    cite: http://tinyurl.com/33xh7ld

    let me repeat one small part: "You may add others when the time comes
    when you learn how to solve problems that may arise from having
    others. Until then, stick to only the 4 repositories."

    so, i ask how do you propose to solve the problem?

    --
    DenverD (Linux Counter 282315)
    CAVEAT: http://is.gd/bpoMD
    posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
    2.6.22.19-0.4-default SMP i686
    AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
    CMedia 9761 AC'97 Audio

  3. #3
    Join Date
    Dec 2009
    Location
    Manchester, UK.
    Posts
    74

    Default Re: Can't update via YAST or zypper

    Hi DenverD,

    Did you mean to come on so strong?

    I've been running Linux (various flavours) since 2005 & openSUSE for over a year. Seeing my post count doesn't mean I'm a complete n00b.

    How do I propose to solve this issue? Well all I have is 6 repo's:

    1. OSS
    2. Non-OSS
    3. Update
    4. Packman
    5. KDE4 Factory
    6. nVidia

    I'll simply wait until 11.3, no worries. Just wanted to know if anyone else had these types of issues.

    Ta
    openSUSE 15.1 (x86_64) KDE Plasma
    Gigabyte GA-MA785GM-US2H - AMD(R) DUAL CORE 270 @ 3.40GHz
    nVidia Geforce GTX280 - 8GB DDR2 800MHz RAM

    https://linuxcounter.net/user/482859.html

  4. #4
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Can't update via YAST or zypper

    Quote Originally Posted by ashley194 View Post
    I'll simply wait until 11.3, no worries. Just wanted to know if anyone else had these types of issues.

    Ta
    Yes, I do. Also see here: YaST2 Cannot access installation media - openSUSE 11.0 64bit - openSUSE Forums
    It is actually a fairly old thread, although, if you scroll down there are posts only a few hours old.

  5. #5

    Default Re: Can't update via YAST or zypper

    Yep, getting the exact same issue. Not really sure what the issue is. It seemed to start just this morning.

    Looks like they might have a dead mirror.

    CDurbin

  6. #6

    Default Re: Can't update via YAST or zypper

    @ashley194 I am having the same issue as you on the 32bit version of KDE factory. If you look at the filelists.xml.gz file in the repodata it is making references to rpm files that are not in the repo. The filelists files have a big long name that starts with what looks like a guid at the start. Looks like the repository build command must have had some sort of issue the last time they did it.

    @DenverD Please ease up with the condescension. The problem the OP is having has nothing at all to do with conflicts created by adding many repositories. The repo in question is just broken today. You post, while accurate and well supported, was not really helpful.

    -djv

  7. #7

    Default Re: Can't update via YAST or zypper

    i concur, the usual link to the Factory KDE4 repo for 11.2 deflects (mirrorbrain?) to the nux.ipb.pt server which does not contain the files... hence, update fails.

    the .repo data files can be accessed showing the available updates, but the updates themselves are missing.

    hope somebody notices these posts and checks it out.

    while i'm on the subject, to not build the 4.4.4 release seems counterproductive in my opinion, it's a bug fix release and could be set outside the Factory repo if it's frozen for the pending 11.3. my 2 1/2 centavos.

  8. #8
    Join Date
    Dec 2009
    Location
    Manchester, UK.
    Posts
    74

    Default Re: Can't update via YAST or zypper

    Hi all,

    Just updated Factory (KDE) without issue

    Thanks!
    openSUSE 15.1 (x86_64) KDE Plasma
    Gigabyte GA-MA785GM-US2H - AMD(R) DUAL CORE 270 @ 3.40GHz
    nVidia Geforce GTX280 - 8GB DDR2 800MHz RAM

    https://linuxcounter.net/user/482859.html

  9. #9
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Can't update via YAST or zypper

    Keep this in mind folks, if a particular repository is down and thus preventing you from using YaST Software Manager or zypper, then disable that repository and try again.

    It is good to see that the repository is back up. Let the updates/upgrades resume.
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •