Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: eclipse and android

  1. #1
    Join Date
    Jun 2009
    Location
    Timisoara, Romania
    Posts
    190

    Question eclipse and android

    Hello all,

    I have installed Eclipse on to my openSUSE 11.2 and after that I wanted to install the android plugin but I cannot do that. I get the following errors:

    Cannot complete the request. See the details.
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.junit/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.ui/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.core/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.launching/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gef/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.junit.runtime/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.junit/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.core/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.launching/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.junit.runtime/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.ui/0.0.0
    Unsatisfied dependency: [com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gef/0.0.0


    Do you experience the same issues? Is there any workaround?

  2. #2

    Default Re: eclipse and android

    I had the same problem. Here is what I did to get it to work. It's not elegant, but it works.

    I uninstalled/deleted Eclipse (all five or so sub-packages too) through YaST2 (Install Software link).

    Downloaded JEE version of Galileo from

    Eclipse downloads - mirror selection

    It unzips the binary, so no installation needed. (It worked fine from my /home/Documents folder

    Continue with instructions at ADT Plugin for Eclipse | Android Developers

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: eclipse and android

    You have to add the ganymede update site to automatically fetch dependencies. There's probably a FAQ on the android site about this.

    However I switched to galileo (3.5) for other reasons including a failure to correct install another set of plugins in ganymede (3.4). Also because ganymede's old, there really should be a package for galileo in software.opensuse.org/search, but it doesn't matter too much because the Linux package from eclipse.org is pretty generic and works for all distros.

    I think that if you install galileo, it automatically includes the updates site (equivalent of an update repo in the eclipse world I guess) and therefore will solve the dependency problem. So yeah, I would say +1 for galileo.

  4. #4
    Join Date
    Jun 2009
    Location
    Timisoara, Romania
    Posts
    190

    Smile Re: eclipse and android

    Thanks a lot! It worked!

    Still I do not understand why yast installed the old eclipse version? Will the repository will be updated with the new version?

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: eclipse and android

    Because that's the latest that openSUSE provides. It's a bit out of date in that department.

  6. #6
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,294
    Blog Entries
    1

    Default Re: eclipse and android

    Quote Originally Posted by ken_yap View Post
    Because that's the latest that openSUSE provides. It's a bit out of date in that department.
    Will 11.3 have the required up-to-date version?
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: eclipse and android

    No idea, I'm not a dev.

  8. #8

    Default Re: eclipse and android

    Hi !
    I just read this:
    Eclipse instalando el plugin de Android (ADT) en Linux Invasin Tux

    It's in spanish but i found out that if you have eclipse 3.4 in opensuse 11.2
    it works if you replace the

    Galileo – http://download.eclipse.org/releases/galileo/

    for

    Ganymede – http://download.eclipse.org/releases/ganymede/

    And Voila'

    Hope it works for everyone.

  9. #9

    Default Re: eclipse and android

    Thanks, had the same problem.

    Had to start eclipse with root to install additional packages.
    -> kdesu eclipse

  10. #10

    Default Re: eclipse and android

    Finally it didn't work with gaymende. So I downloaded current binaries from eclipse.org and ran it from user directory.

    BTW: Had to wait very long until the emulator had booted (thought it didn't work at first)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •