Results 1 to 4 of 4

Thread: CUPS and error

  1. #1
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default CUPS and error

    Updated to CUPS 1.4.3 from printing repository and was getting this while page test printing:

    Code:
    /usr/bin/lp: Unsupported format 'application/postscript'!
    Downgraded to 1.3.11 and it was solved. Any ideas?


    openSUSE 11.2 x86_64, KDE 4.4.3

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: CUPS and error

    Was here any reason why you were trying to use the printing repo version of CUPS? Not sure if it will come down to a packaging error.

    FWIW, after a quick online search, I found various references to users trying to print in RAW format, with similar errors reported. It was suggested that a solution is to check /etc/cups/mime.* files and uncomment a line at the end looks like
    #application/octet
    then restart cups with
    Code:
    rccups restart
    Other than that, I think I would be checking out bug reports on the topic. Thats about all I can offer.

  3. #3
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: CUPS and error

    Code:
    #application/octet-stream	application/vnd.cups-raw	0	-
    Thats what is says, what should i change?


    And there is no real purpose on updating CUPS, other than fixing bugs.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: CUPS and error

    Try uncommenting (ie remove the '#' comment symbol). You'll need root privileges to edit of course. Then restart CUPS.

    I guess updating for security fixes makes sense, but I don't usually update CUPS within a release (unless there was a bug affecting me directly of course).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •