Results 1 to 3 of 3

Thread: After installing the GNOME Desktop Environment pattern, audio is buggy.

  1. #1

    Default After installing the GNOME Desktop Environment pattern, audio is buggy.

    I decided to try out openSUSE's implementation of GNOME via YaST. After installing it I didn't like it much, so I went back into KDE. The problems all seem to be pulseaudio-related and very Ubuntu 9.10-ish. Is there any way of fixing this without removing the entire GNOME desktop?

    Issues like..

    Only one sound playing at a time. Example: I am on youtube, no sound due to being on Skype. Reload youtube page, no sounds on skype but youtube works. Close youtube page, and all the sounds (calls, chats, etc) from skype all play at once in one large clutter.

    One of the reasons I gave up on the Ubuntus; don't want to face this here at all!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: After installing the GNOME Desktop Environment pattern, audio is buggy.

    Only one sound playing at a time. Example: I am on youtube, no sound due to being on Skype. Reload youtube page, no sounds on skype but youtube works. Close youtube page, and all the sounds (calls, chats, etc) from skype all play at once in one large clutter.
    This is actually normal. There may be a fix, but you need @oldcpu for this.

    You may find good advice here:
    SDB:Audio troubleshooting - openSUSE
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: After installing the GNOME Desktop Environment pattern, audio is buggy.

    Quote Originally Posted by caf4926 View Post
    This is actually normal. There may be a fix, but you need @oldcpu for this.
    This problem reads to be specific to Skype and pulse audio, and I use neither. So I don't think I can help directly.

    Newfie2, if you think it a pulse audio problem, you could open up a Terminal session and enter su - and then the password.

    At the terminal prompt enter this command (with root permissions).
    Code:
    setup-pulseaudio --disable
    restart and test.

    If that does not work, then you MUST enable it again with (with root permissions):
    Code:
    setup-pulseaudio --enable
    ... as caf4926 pointed out, there is a pulse audio section in the audio troubleshooting guide. But that was designed more to get basic sound working, as opposed to solve the problem of multiple applications using the sound device at once.

    There is a Pulse Audio system wide instance sort of guide on the pulse audio wiki page, but someone who uses pulse suggested to me thats not a good guide to follow, and with my not knowing pulse I can not make any judgment there.

    There is also a Skype section in the Pulse Audio Perfect Setup guide but that may be more for getting basic audio functioning than anything else. ....

    In truth, I don't know. I recommend you check out those links I provided and come to your own conclusions. .... or better yet, stick with KDE. Thats what I do. I tried Gnome, I liked its look feel, and I was very annoyed with its pulse audio implementation. So I stick with KDE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •