Results 1 to 8 of 8

Thread: Can't compile application with mpi/parallel processing support

  1. #1

    Default Can't compile application with mpi/parallel processing support

    Hello,

    I have to do some simulations with gerris, a cfd (computational fluid dynamics) package, that supports parallel processing on multiple cores.

    I'm using the 64 bit version of opensuse 11.2, installed openmpi and tried to install gerris cfd from the source.

    ./configure says, that mpi is not found and when I use the prefix --with-mpicc=/usr/lib64/mpi/gcc/openmpi/bin/mpicc:

    ./configure --with-mpicc=/usr/lib64/mpi/gcc/openmpi/bin/mpicc

    I get the following error message:
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... no
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for gcc... /usr/lib64/mpi/gcc/openmpi/bin/mpiCC
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... configure: error: cannot run C compiled programs.
    If you meant to cross compile, use `--host'.
    See `config.log' for more details.


    There is no `config.log' file!

    Any ideas what's the problem and how to fix it?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,226

    Default Re: Can't compile application with mpi/parallel processing support

    Do you have gcc and make installed?
    Henk van Velden

  3. #3
    Join Date
    Jun 2009
    Location
    Pennsylvania, USA
    Posts
    230

    Default Re: Can't compile application with mpi/parallel processing support

    centurio wrote:

    >
    > Hello,
    >
    > I have to do some simulations with gerris, a cfd (computational fluid
    > dynamics) package, that supports parallel processing on multiple cores.
    >
    > I'm using the 64 bit version of opensuse 11.2, installed openmpi and
    > tried to install gerris cfd from the source.
    >
    > ./configure says, that mpi is not found and when I use the prefix
    > --with-mpicc=/usr/lib64/mpi/gcc/openmpi/bin/mpicc:
    >
    > ./configure --with-mpicc=/usr/lib64/mpi/gcc/openmpi/bin/mpicc
    >
    > I get the following error message:
    > checking for a BSD-compatible install... /usr/bin/install -c
    > checking whether build environment is sane... yes
    > checking for gawk... gawk
    > checking whether make sets $(MAKE)... no
    > checking whether to enable maintainer-specific portions of Makefiles...
    > no
    > checking for gcc... /usr/lib64/mpi/gcc/openmpi/bin/mpiCC
    > checking for C compiler default output file name... a.out
    > checking whether the C compiler works... configure: error: cannot run C
    > compiled programs.
    > If you meant to cross compile, use `--host'.
    > See `config.log' for more details.
    >
    >
    > There is no `config.log' file!
    >
    > Any ideas what's the problem and how to fix it?
    >
    >

    Did you install all of the -devel packages for any of the packages/libraries
    you added?



  4. #4

    Default Re: Can't compile application with mpi/parallel processing support

    yes, I installed all the development packages!

    I installed gerris cfd using the snapshotpackages available for opensuse x86_64 and afer resolving some dependencies gerris is installed BUT doesn't work.

    There's a problem with DAT and IB - I get the following error message when I check gerris using gerris2D -V:

    DAT: library load failure: /usr/lib64/libdaplcma.so.1: undefined symbol: dat_registry_add_provider
    --------------------------------------------------------------------------

    WARNING: Failed to open "OpenIB-cma" [DAT_PROVIDER_NOT_FOUNDAT_NAME_NOT_REGISTERED].
    This may be a real error or it may be an invalid entry in the uDAPL
    Registry which is contained in the dat.conf file. Contact your local
    System Administrator to confirm the availability of the interfaces in
    the dat.conf file.
    --------------------------------------------------------------------------

    [0,0,0]: uDAPL on host linux-x7yq was unable to find any NICs.
    Another transport will be used instead, although this may result in
    lower performance.
    --------------------------------------------------------------------------
    gerris: using 2D libgfs version 1.3.2 (100602-162521)
    compiled with flags: -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -fPIC -DPIC
    MPI: yes
    pkg-config: yes
    m4 and gawk: yes
    Copyright (C) 2001-2009 NIWA.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    Any idea what's missing?

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,194
    Blog Entries
    14

    Default Re: Can't compile application with mpi/parallel processing support

    What does 'rpm -qa | grep dapl' give?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Can't compile application with mpi/parallel processing support

    it gives:

    dapl-devel-2.0.15-3.2.x86_64
    dapl-2.0.15-3.2.x86_64
    compat-dapl-1.2.12-3.2.x86_64

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,194
    Blog Entries
    14

    Default Re: Can't compile application with mpi/parallel processing support

    That's what's available, mmmm. My 2 cents: it's in the dat.conf, but I wouldn't know how to help out any further.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default I did more research on the problem...

    The following doesn't fix it but reduces the error messages:

    It looks like your version of Open MPI is compiled and linked against the DAPL library, but the DAPL library is not present on your system (or it is incorrectly installed...? I'm not very familiar with DAPL). You should probably contact your sysadmin to ask about the DAPL installation.

    FWIW, DAPL is not recommended for Linux systems. It is mainly in the Open MPI code base to support Solaris.

    You should be able to avoid these warnings by editing the Open MPI system-wide run-time parameters file and adding the following:

    btl = ^udapl

    This tells Open MPI to load all BTL plugins *except* the "udapl" plugin.

    I don't know where the Open MPI system-wide param file will be installed on your system; look for a file named "openmpi-mca-params.conf".

    New error messages:

    [linux-x7yq:05745] keyval parser: error 1 reading file /etc/openmpi-mca-params.conf at line 61:
    #
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    tells
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    MPI
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    load
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    BTL
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    *
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    *
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    "
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    "
    [linux-x7yq:05745] keyval parser: error 2 reading file /etc/openmpi-mca-params.conf at line 61:
    �n�2L
    gerris: using 2D libgfs version 1.3.2 (100602-162521)
    compiled with flags: -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -fPIC -DPIC
    MPI: yes
    pkg-config: yes
    m4 and gawk: yes
    Copyright (C) 2001-2009 NIWA.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    Any idea how to fix the last bit?

    The root cause is apparently wrong linking when creating the opensuse binaries for openmpi wrong = linking dapl correct would be compat-dapl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •