Results 1 to 5 of 5

Thread: KDE 4 Session start glitch

  1. #1
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    211

    Default KDE 4 Session start glitch

    Hi,

    When KDE starts up a new session, it restores the progs that were running at log out last time.

    I am running skype and that prog is brought back but I suspect that KDE is restarting the "bin" (skype-bin) rather than the startup script (skpe) which contains the necessary "LD_PRELOAD" stuff essential to get the webcam operating OK.

    I can't find where KDE stores the session info, any ideas?

    Thanks - AK

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,657

    Default Re: KDE 4 Session start glitch

    Skype restarts fine here.

    What is started in the shortcut/menu

  3. #3
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    211

    Default Re: KDE 4 Session start glitch

    Hi gogol,

    The menu bit is fine, it uses the script "skype". It's when it restores the session that it goes wrong, the video just doesn't work anymore. I have to kill it from the service bar and start it either in a shell or via the menu.

    If I could find where it stores the info to allow it to restore the session, I could make sure that it's using the right startup commands.

    Cheers - AK

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,657

    Default Re: KDE 4 Session start glitch

    I don't use video so maybe that is why I don't see the problem.

  5. #5
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    211

    Thumbs up Re: KDE 4 Session start glitch [SOLVED]

    Hi all,

    Got the answer to this.

    The KDE Session Manager gets the info from the skype so there wouldn't be any point in trying edit files etc. For info, the file is ~/.kde4/share/config/ksmserverrc .

    The method is first to exclude skype-bin from the session restore via System Settings (Advanced), Session Manager. Put skype-bin in the list of "Applications to be excluded from sessions".

    Next, open up a Dolphin and go to the Autostart directory. From the panel menu, go to the skype entry and drag the icon into the Dolphin and "Copy to here".

    That's it. On the first re-login, the KDE asked me if I trusted the prog (skype). I said OK. The next re-login, no question and everything is ok.

    Cheers - AK

    PS: Do we have a "Solved" button or something like that so that we can mark the problem as such?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •