Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: YAST unable to update. Giving errors. Please help. :(

  1. #1
    Join Date
    Jun 2010
    Location
    Permanent : Chicago, IL. Currently in Asia on a project. :P
    Posts
    14

    Unhappy YAST unable to update. Giving errors. Please help. :(

    Hi,
    I just happened to install opensuse 11.2 on my pc. I am able to connect to the internet through firefox,but when trying to update the YAST, i keep getting this error message. http://i49.tinypic.com/np2gdi.jpg

    It just wont connect to download the updates or install softwares.Feels kinda weird since i can connect thru the browser.Please help me out.

    Thanks,
    Karen

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Please post the result of this:

    Code:
    zypper lr -d
    what happens with
    Code:
    zypper lu
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Not much of help, but I do have the same problem since yesterday at least. I haven't tried to update for some days, so I don't know for how long it's been like this.

    /Anders

  4. #4
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    304

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Need to register for updates, in Yast/Software/Online Update Configuration. Click on the Advanced button, then on "Register for support and get update repository"

    I've had this problem with several versions of OpenSuse.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: YAST unable to update. Giving errors. Please help. :(

    You do not need to register to use the OpenSuse. AFAIK the registration does not work anyhow, at least not here. You do need to if you use the commercial Novell version.

  6. #6
    Join Date
    Jun 2010
    Location
    Permanent : Chicago, IL. Currently in Asia on a project. :P
    Posts
    14

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Quote Originally Posted by caf4926 View Post
    Please post the result of this:

    Code:
    zypper lr -d
    what happens with
    Code:
    zypper lu
    Dear Caf,
    thanks for your quick response. I really appreciate it.

    Here are the results for zypper lr -d :


    and for zypper lu :



    I'm sorry, I'm a noob with linux right now, and do not understand a lot of this gibberish,but i figure, I was getting the exact same error message while trying to update through Yast and it would ask me to abort/retry again.

    I'll appreciate all your help in this matter.

    TIA

  7. #7
    Join Date
    Jun 2010
    Location
    Permanent : Chicago, IL. Currently in Asia on a project. :P
    Posts
    14

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Quote Originally Posted by konsultor View Post
    Need to register for updates, in Yast/Software/Online Update Configuration. Click on the Advanced button, then on "Register for support and get update repository"

    I've had this problem with several versions of OpenSuse.
    @Konsultor : Thanks for your suggestion, but it would not even allow me to register. It again gives me the same error messages. Please check these screenshots :

    http://i47.tinypic.com/15p37zp.jpg

    http://i45.tinypic.com/vnf061.jpg

    http://i46.tinypic.com/343rtc1.jpg

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Am I to assume you have never been able to update?

    You have managed to ADD some repos!

    I'm going out now, but in the mean time try these things in this order. You need to open a terminal and become su -
    Become su in Terminal - HowTo - openSUSE Forums
    ========================

    Now do this in the terminal:

    Code:
    rpmdb --rebuilddb
    It takes a while
    Then try yast updates again. If it still fails do this:

    Code:
    zypper rr 7
    Code:
    zypper rr 5
    This will remove the 2 non-oss repos you have, not sure why you have two.
    Now try yast updates again. Does it still fail.

    Now do this

    Code:
    zypper ar -f http://download.opensuse.org/distribution/11.2/repo/non-oss/ non-oss
    This is adding non-oss back, i want to see if it will do it.

    If it's still not working. I think we may have to look at a DNS issue, where you have to change your network settings from DHCP and set the DNS info for your ISP.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    304

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Quote Originally Posted by gogalthorp View Post
    You do not need to register to use the OpenSuse. AFAIK the registration does not work anyhow, at least not here. You do need to if you use the commercial Novell version.
    It's not a "real" registration--you don't enter a key or serial number--but the process refreshes the list of repositories (and may send some info about your hardware to the developers).

  10. #10
    Join Date
    Jun 2010
    Location
    Permanent : Chicago, IL. Currently in Asia on a project. :P
    Posts
    14

    Default Re: YAST unable to update. Giving errors. Please help. :(

    Quote Originally Posted by caf4926 View Post
    Am I to assume you have never been able to update?

    You have managed to ADD some repos!
    As a matter of fact, I was able to add the repos, but that's about as much it would allow me (as you will notice in the last screenshot). After adding the repos, it will again give me the same error message when trying to install the softwares.



    Now do this in the terminal:

    Code:
    rpmdb --rebuilddb
    It takes a while
    Then try yast updates again. If it still fails do this:

    Code:
    zypper rr 7
    Code:
    zypper rr 5
    This will remove the 2 non-oss repos you have, not sure why you have two.
    Now try yast updates again. Does it still fail.
    After rebuilding db, i removed the 2 non-oss repos,as you suggested. Here are the screenshots :
    After rebuilddb :
    Still got the same error while trying to update :
    http://i45.tinypic.com/2mfxcw1.jpg

    After removing the 2 non-oss repos :


    http://i49.tinypic.com/15484so.jpg




    Now do this

    Code:
    zypper ar -f http://download.opensuse.org/distribution/11.2/repo/non-oss/ non-oss
    This is adding non-oss back, i want to see if it will do it.

    If it's still not working. I think we may have to look at a DNS issue, where you have to change your network settings from DHCP and set the DNS info for your ISP.
    Now this is really weird. It allows me to add the repos back.Please check this screenshot :
    http://i50.tinypic.com/alqafb.jpg

    I presume if its a network setting related issue, then it should not allow me to update anything.Not even the repos. But this error occurs only when trying to actually install the softwares from the links.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •